On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

GMail time only off in Firefox

  • 2 cavab
  • 1 has this problem
  • 6 views
  • Last reply by mikewp

more options

Hello, I have a strange issue. When I am in Gmail using Firefox, my time is off by 5 hours. I can open Gmail in Edge and the time is correct.

I have 2 time zones listed in my Google calendar. I removed the secondary one and the time still stays the same.

One posted mentioned that they changed the computer time zone and this resolved the issue. I tried that and still get the same incorrect time.

I can log into my laptop and I get the same issue with Firefox being 5 hours off but Edge being right on time.

Any input would be greatly appreciated. Thanks Mike

Hello, I have a strange issue. When I am in Gmail using Firefox, my time is off by 5 hours. I can open Gmail in Edge and the time is correct. I have 2 time zones listed in my Google calendar. I removed the secondary one and the time still stays the same. One posted mentioned that they changed the computer time zone and this resolved the issue. I tried that and still get the same incorrect time. I can log into my laptop and I get the same issue with Firefox being 5 hours off but Edge being right on time. Any input would be greatly appreciated. Thanks Mike

Chosen solution

Do you have enabled "Resist Fingerprinting" if you check this pref on the about:config page (i.e this pref is true and not false)?

You can open the about:config page via the location/address bar. Clear cookies the button to "Accept the Risk and Continue".

Read this answer in context 👍 0

All Replies (2)

more options

Seçilmiş Həll

Do you have enabled "Resist Fingerprinting" if you check this pref on the about:config page (i.e this pref is true and not false)?

You can open the about:config page via the location/address bar. Clear cookies the button to "Accept the Risk and Continue".

Helpful?

more options

cor-el, Thank you very much for the help. That resolved my issue.

Helpful?

Sual ver

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.