Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Custom Theme Is Suddenly In Dark Mode And I Can't Fix It

  • 2 cavab
  • 1 has this problem
  • 29 views
  • Last reply by cor-el

more options

Hi. I made my own custom theme a few weeks ago, and I liked it. It has a dark toolbar, but the automatic new tab was still light. I liked it this way. I updated the browser today, and now it's essentially in dark mode and I can't find how to change it back. I really hate white text on a black background, and as I did not choose that as part of my custom theme, I would really appreciate being given the choice to change it back.

Hi. I made my own custom theme a few weeks ago, and I liked it. It has a dark toolbar, but the automatic new tab was still light. I liked it this way. I updated the browser today, and now it's essentially in dark mode and I can't find how to change it back. I really hate white text on a black background, and as I did not choose that as part of my custom theme, I would really appreciate being given the choice to change it back.

Chosen solution

https://support.mozilla.org/en-US/questions/1360640

Apparently the problem is that I have Windows 10 in dark mode. HOWEVER, I have light mode selected for apps, which apparently firefox doesn't count as anymore?

Anyway, I only have windows on dark mode so I can have a color on my windows theme because Windows 10 is horrible like that.

Read this answer in context 👍 0

All Replies (2)

more options

Seçilmiş Həll

https://support.mozilla.org/en-US/questions/1360640

Apparently the problem is that I have Windows 10 in dark mode. HOWEVER, I have light mode selected for apps, which apparently firefox doesn't count as anymore?

Anyway, I only have windows on dark mode so I can have a color on my windows theme because Windows 10 is horrible like that.

more options

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior.

  • layout.css.prefers-color-scheme.content-override
    Dark (0), light (1), system (2) or browser (3)

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also this pref:

  • ui.systemUsesDarkTheme [0:light; 1:dark; 2:no-preference]