Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox color - dark theme

  • 2 cavab
  • 2 have this problem
  • 58 views
  • Last reply by cor-el

more options

I'm trying to customize colors of Firefox developer edition. I would like to have a dark toolbar bit i don't wont to enable dark mode for any website.

I have installed Firefox color and whenever i choose a darker color for the toolbar all websites are displaying their dark versions (it behaves like the dark mode is turned on).

I have tried to manual set browser.theme.content-theme and browser.theme.toolbar-theme but after every restart these get overridden.

Does anyone know how to make this happen?

The funny thing is that everything was fine before today's update...i tried reinstalling Firefox and also i tried disabling all extensions...

I'm trying to customize colors of Firefox developer edition. I would like to have a dark toolbar bit i don't wont to enable dark mode for any website. I have installed Firefox color and whenever i choose a darker color for the toolbar all websites are displaying their dark versions (it behaves like the dark mode is turned on). I have tried to manual set browser.theme.content-theme and browser.theme.toolbar-theme but after every restart these get overridden. Does anyone know how to make this happen? The funny thing is that everything was fine before today's update...i tried reinstalling Firefox and also i tried disabling all extensions...

All Replies (2)

more options

Oh, is that why my theme is doing this? I wanted a dark toolbar but a light background, is that really too much to ask for?

more options

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior.

  • layout.css.prefers-color-scheme.content-override
    Dark (0), light (1), system (2) or browser (3)

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also this pref:

  • ui.systemUsesDarkTheme [0:light; 1:dark; 2:no-preference]