Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Web sites not showing correctly with Firefox 91.0

  • 4 cavab
  • 1 has this problem
  • 27 views
  • Last reply by FredMcD

more options

Hi,

Some websites will suddenly only show parts of the content after I upgraded to 91.0. I tried to look at the websites with Chrome and it's no problem with the same web sites. I have tried "Trouble shooting mode" but the problem in Firefox is still there. I'm running Firefox on a Mac OS with Big Sur 11.5.1 Anybody having the same problem and know how to fix it?

Kind regards, Cath

Attached screenshots

Chosen solution

cor-el said

This could be a problem with High Contrast Mode on Mac. See "New" in the release notes. Firefox now automatically enables High Contrast Mode when "Increase Contrast" is checked on MacOS in the Accessibility settings.

Make sure you allow pages to choose their own colors.

  • Settings -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

Read this answer in context 👍 1

All Replies (4)

more options

Hey there!

See https://support.mozilla.org/en-US/kb/fix-problems-images-not-show for more information.

Hope I helped!

Bithiah

more options

Seçilmiş Həll

cor-el said

This could be a problem with High Contrast Mode on Mac. See "New" in the release notes. Firefox now automatically enables High Contrast Mode when "Increase Contrast" is checked on MacOS in the Accessibility settings.

Make sure you allow pages to choose their own colors.

  • Settings -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

more options

Thank you so much for the replies! I tried everything and finally it was all solved by just changing the color option to "Never". Sooo grateful FredMcD

more options

Glad to help. Safe Surfing.