Showing questions tagged: اعرض كل الأسئلة
  • حُلّت
  • المُؤرشفة

Firefox fails to load YouTube videos on refresh/re-visit

First attempt to play a video plays instantly, but clicking any video I've viewed since a cache clear or if I refresh the page, the videos load shifted to the right (no s… (read more)

First attempt to play a video plays instantly, but clicking any video I've viewed since a cache clear or if I refresh the page, the videos load shifted to the right (no sidebar video list). After a second, the sidebar loads in pushing the video to the 'normal' position, and as soon as this happens the video--that has played around 1 second--fails.

I have disabled all addons, refreshed firefox, disabled HW accel. Starting Firefox in safemode completely breaks it and I can't even navigate to a page, let alone test YouTube. I've reinstalled only 2 of the addons I had before since they're clearly not the issue.

Win10 1803, Firefox Quantum 61, Nvidia GTX 1080ti (driver WHQL 398.36)

Asked by wildcardNS 3 years ago

Answered by Shadow110 3 years ago

  • حُلّت
  • المُؤرشفة

Firefox ESR crashes at watching videos with "alsa_stream_get_position: Assertion `delay >= 0' failed"

hello, i have a Raspberry Pi 4 with 4GB and Raspberry Pi OS installed. (2020-05-27-raspios-buster-armhf.zip) when i use the stock Firefox ESR (installed via sudo apt inst… (read more)

hello, i have a Raspberry Pi 4 with 4GB and Raspberry Pi OS installed. (2020-05-27-raspios-buster-armhf.zip)

when i use the stock Firefox ESR (installed via sudo apt install firefox-esr) and watch videos (e.g. on Youtube, Vimeo, ...), Firefox does crash some times. according about:crashes, i already have submitted about 60 crash reports.

but watching the reports one thing is missing. when i open firefox from the console i can see some output, that is not appearing in the reports.

... firefox-esr: /build/firefox-esr-RgOFaD/firefox-esr-68.11.0esr/media/libcubeb/src/cubeb_alsa.c:1255: alsa_stream_get_position: Assertion `delay >= 0' failed. ExceptionHandler::GenerateDump cloned child 3366 ExceptionHandler::SendContinueSignalToChild sent continue signal to child ExceptionHandler::WaitForContinueSignal waiting for continue signal... Exiting due to channel error. Exiting due to channel error. Exiting due to channel error. Exiting due to channel error. Failed to open curl lib from binary, use libcurl.so instead Firefox ESR crashes when playing videos on Raspberry Pi OS (Debian)

during watching videos in firefox there is more different output to see that seems to be harmless. but always and only this line is printed to console, just befor Firefox crashes: firefox-esr: /build/firefox-esr-RgOFaD/firefox-esr-68.11.0esr/media/libcubeb/src/cubeb_alsa.c:1255: alsa_stream_get_position: Assertion `delay >= 0' failed. so i assume this is the main reason, why Firefox crashes on my system.

any idea how i can get these issue fixed? at the moment when i want to watch videos reliable i am be forces to use the external VLC Player by copy the url to VLC - at least for Youtube videos. but i want to watch videos from other web pages as well and i prefer to watch videos in firefox directly.

Asked by beta-tester 1 year ago

Answered by beta-tester 9 months ago

  • حُلّت
  • المُؤرشفة

can't play videos without restarting computer

I have a MacBook Pro (Retina, 13-inch, Early 2015) with firefox as my browser. I"m having a problem with playing videos and have tried to use firefox help lists to no ava… (read more)

I have a MacBook Pro (Retina, 13-inch, Early 2015) with firefox as my browser. I"m having a problem with playing videos and have tried to use firefox help lists to no avail. If I force quit the browser and then reload it I can play about 5-6 videos but after that it just buffers and tells me to restart my computer. I have removed adobe flash player and reinstalled it. I have removed the ad blocker I had on the computer and didn't re-install it. I have tried other things that are on the internet, nothing works. Any suggestions... please

Asked by jgrainger 4 years ago

Answered by cor-el 4 years ago

  • حُلّت
  • المُؤرشفة

Graphical glitches in YouTube HTML5 player

When I've been playing YouTube videos lately, I've noticed that a bunch of black boxes have been appearing over the player interface (The controls below the video) while … (read more)

When I've been playing YouTube videos lately, I've noticed that a bunch of black boxes have been appearing over the player interface (The controls below the video) while the video is playing. Unfortunately, I can't provide a good screenshot, as the boxes come and go too quickly for me to get them. This issue still occurs if I restart Firefox in safe mode. I think it started happening with Firefox 37.

Asked by aroskuski 6 years ago

Answered by aroskuski 6 years ago

  • حُلّت
  • المُؤرشفة

Youtube, Facebook and other embedded videos never load (FF 58.0.2)

I am unable to watch videos in Firefox since the last update. There is a spinning wheel and it never finishes loading. Since I reinstalled FF, there are no external plugi… (read more)

I am unable to watch videos in Firefox since the last update. There is a spinning wheel and it never finishes loading. Since I reinstalled FF, there are no external plugings. Tried re-install, restart, nothing worked. They do play properly in Chrome.

Asked by leonardoauc 3 years ago

Answered by FredMcD 3 years ago

  • حُلّت
  • المُؤرشفة

Great update today, now I can no longer use Prime or netflix

So thanks to your update today I can no longer watch videos via prime or netflix due to a Widevine.Cdm error. That's fantastic, especially as Microsoft are moving to Chro… (read more)

So thanks to your update today I can no longer watch videos via prime or netflix due to a Widevine.Cdm error.

That's fantastic, especially as Microsoft are moving to Chromium, you're really selling your service.

See I'm being totally nice. And not calling you names.

Asked by Reallypissoff 2 years ago

Answered by cor-el 2 years ago

  • حُلّت
  • المُؤرشفة

mp4 video plays but with no sound (W7, f/f 64bit, v75.0)

A .mp4 video clip on the web will play through f/f but with no sound. A .mp3 audio clip plays ok. The laptop sound controls are not muted. The mp4 clip shows a bar at th… (read more)

A .mp4 video clip on the web will play through f/f but with no sound. A .mp3 audio clip plays ok. The laptop sound controls are not muted. The mp4 clip shows a bar at the bottom and on the right there's a symbol that looks like a speaker with a bar through it. There seems no way to change this. The mp4 clip will play perfectly in WMP and from the website on a Samsung phone.

Asked by Gra 1 year ago

Answered by jscher2000 1 year ago

  • حُلّت
  • المُؤرشفة

Videos go slow after pausing em for a while

Yes hello, as the title says some videos go slow after i pause em to look on something else, specifically in a site called animeplus.tv i watch the videos there, then i p… (read more)

Yes hello, as the title says some videos go slow after i pause em to look on something else, specifically in a site called animeplus.tv i watch the videos there, then i pause em for a bit to check for something else, or another video in another site or well whichever reason, the thing is when i return to this video and resume playing it, it gets very slow playback, the audio is fine, but the video itself is not working properly, so far i just seen this issue happen in that website but perhaps is the flash player? i dunno i removed a addon that i though could be the issue but is not. and when i try this on Google Chrome, it works fine, i pause the video check for other stuff, and the video still plays like normal. so i am hoping for some ideas in what to do cause i do like Firefox and i do not want to transfer over to another browser.

Asked by Slyver1080 6 years ago

Answered by guigs 6 years ago

  • حُلّت
  • المُؤرشفة

Frame skipping on any audio or video

I've recently built a desktop PC with this configuration: Ryzen 7 1800X Geforce GTX 750 Ti (driver version: 399.07) 16GB DDR4 RAM 250GB SSD + a HDD for data only, no sys… (read more)

I've recently built a desktop PC with this configuration:

Ryzen 7 1800X

Geforce GTX 750 Ti (driver version: 399.07)

16GB DDR4 RAM

250GB SSD + a HDD for data only, no system files

Windows 10 64bit

External Sound card Scarlett 2i4 1st gen. [it worked fine with my old Windows7 desktop]


Any audio (soundcloud, zophar.net/music) or video (youtube, twitch, facebook) stream has the same problem: it randomly skips frames. I mean that video nor audio are interrupted, they continue, but they skip some "frames".

This bug occurs with the current official version, the current beta version and the current Nightly.

This bug does not occur on my laptop, windows 8 running an i5 CPU and no dedicated GPU.

This bug does not occur on other apps. I've tried: VLC, Facebook app, Twitch app, Microsoft Edge, Internet Explorer, Winamp.

Asked by DeRobyJ 3 years ago

Answered by DeRobyJ 3 years ago

  • حُلّت
  • المُؤرشفة

Video frames do not scale properly

In Firefox video frames don't scale properly. This affects both HTML5 videos e.g. youtube.com and Flash videos e.g. twitch.tv. When switching to Cinema view in youtube, o… (read more)

In Firefox video frames don't scale properly. This affects both HTML5 videos e.g. youtube.com and Flash videos e.g. twitch.tv. When switching to Cinema view in youtube, or closing the side panels in twitch, the frame will extend to the left and right, leaving black bars at the side, but the video does not scale and the frame does not increase in height. I don't have the issue in Safe Mode and also not in Chrome. However I still have the issue in Firefox with all extensions disabled. I tried to delete cookies, cache and refresh Firefox, but the issue still exists. I also tried to disable Hardware acceleration in both the Flash Player and Firefox, but that also does not solve the issue.

Asked by MannimStein 6 years ago

Answered by jscher2000 6 years ago

  • حُلّت
  • المُؤرشفة

make vlc plugin default player for youtube videos

hi is it possible to do so ? i still having high load and memory usage from youtube only videos, i would like to vlc be the default media player in youtube thanks in adva… (read more)

hi is it possible to do so ? i still having high load and memory usage from youtube only videos, i would like to vlc be the default media player in youtube thanks in advance

Asked by Simoorish 5 years ago

Answered by cor-el 5 years ago

  • حُلّت
  • المُؤرشفة

Videos don't load

Ever since some update, Firefox won't load Vines or Tumblr videos, but load YouTube videos, Facebook videos, and pretty much everything else. I've disabled hardware accel… (read more)

Ever since some update, Firefox won't load Vines or Tumblr videos, but load YouTube videos, Facebook videos, and pretty much everything else. I've disabled hardware acceleration, addons, and tried most (if not every) solution given here.

Asked by dragonkid828 6 years ago

Answered by dragonkid828 6 years ago

  • حُلّت
  • المُؤرشفة

Some Videos will not play in firefox but play fine in IE

I am running Windows 7 64 bit and Firefox is my browser. All of a sudden I can not play videos at places like Democracy Now and many other web sites (E.G. Malcolm Gladwel… (read more)

I am running Windows 7 64 bit and Firefox is my browser. All of a sudden I can not play videos at places like Democracy Now and many other web sites (E.G. Malcolm Gladwell) but most of Youtube is okay - except sometimes. I thought this may have been due adGuard but disengaging it or starting FF clean with no ad ons has no effect.

I was just informed by Costco Concierge Services that the reason is that both FireFox and Google Chrome have decided to “no longer support” certain add ons or plug ins (what is the difference if any between these tech terms of art?) and therefore if I can not play a video I will have to use Internet Explorer. Discovering what videos I can or can not use is a hit an miss case by case basis.

So, first is this true? I can not imagine Firefox or Google Chrome making a change that would actually require its users of many years to bump their prime product and, instead, turn to its prime competitors. That seems like suicidal sabotage. We are just every day end-users and not software engineers and the explanations I find are absolutely incomprehensible technobabble.

In plain English what is the real problem? What is the fix? And has Firefox actually decided to make us dump Firefox and turn to its competitor just to watch certain videos? Has Democracy Now decided to continue using a video format that is no longer supported by FF?

The attached pic is just and example. DN uses jW player but I find this problem at other web sites too.

Asked by LostInThisMaze 4 years ago

Answered by Moses 4 years ago

  • حُلّت
  • المُؤرشفة

YouTube videos are black when using HTML5 player.

Today when I started up my laptop, Firefox wouldn't play any YouTube video - the audio still works and the preview of the frame when seeking is there, but instead of vide… (read more)

Today when I started up my laptop, Firefox wouldn't play any YouTube video - the audio still works and the preview of the frame when seeking is there, but instead of video there is just a black screen. I have NO intention of installing Flash Player. Please help? Thanks in advance.

Asked by username9001 6 years ago

Answered by guigs 6 years ago

  • حُلّت
  • المُؤرشفة

Why is it so difficult to get Firefox to play web videos?

I have developed a very basic opening page for my web site. It contains a 45 second movie. It works on IE, Chrome, and Safari but will not work on Firefox. Why? I have… (read more)

I have developed a very basic opening page for my web site. It contains a 45 second movie. It works on IE, Chrome, and Safari but will not work on Firefox. Why?

I have spent numerous hours attempting to try workarounds with no luck. I am considering just putting a statement on my front page that says I cannot make this site work properly with Firefox.

It would seem to be in Firefox's best interest to figure this out and fix it vs being the lone browser out there where basic common video formats do not work well.

Please let me know if there is a very quick workaround to make this work because I am certainly not going to spend any more time trying to figure it out.

Thanks for listening

Asked by anolte 7 years ago

Answered by anolte 7 years ago

  • حُلّت
  • المُؤرشفة

On some web sites, the player is covered by . . .

an invisible screen. Sometimes, I can remove it using Inspect Element. For example, on YouTube, the block is coded; <div id="theater-background" class="player-height"… (read more)

an invisible screen. Sometimes, I can remove it using Inspect Element. For example, on YouTube, the block is coded;

<div id="theater-background" class="player-height"></div>

After I remove the above, the block is gone. How can I get this to not be there in the first place?

Asked by FredMcD 6 years ago

Answered by user1194064 6 years ago

  • حُلّت
  • المُؤرشفة

Firefox doesn't drop videocard usage after closing youtube

Hello. So, as the question says, Firefox doesn't drop GPU usage and GPU core frequency (but it drops GPU memory frequency). I tried the other browsers (Chrome, Opera, Edg… (read more)

Hello. So, as the question says, Firefox doesn't drop GPU usage and GPU core frequency (but it drops GPU memory frequency). I tried the other browsers (Chrome, Opera, Edge) and it's fine. I have AMD RX560 graphic card with the latest drivers and I also tried previous versions

Asked by giindur 3 years ago

Answered by giindur 3 years ago

  • حُلّت
  • المُؤرشفة

Firefox v 55.0 crashes my tabs upon loading a video

Alright, so first the story, then the specifics. Story: I updated to Firefox 55.0 a few weeks ago, presumably when it came out, as I had auto-updates enabled. Immediately… (read more)

Alright, so first the story, then the specifics.

Story: I updated to Firefox 55.0 a few weeks ago, presumably when it came out, as I had auto-updates enabled. Immediately after doing so, the large majority of videos would crash my tab. I'd get what I can only assume is the standard message of "Gah, My tab crashed!" etc. Anyways, I did some digging around, these forums and others, none of the solutions worked. I settled for the quick n dirty solution, and rolled back to firefox 54.0, which worked fine. Until today. Today, 54.0 was experiencing the issue as well, so I naturally decided to try 55.0 - which didn't work either. That leaves me where I'm at now.

Specific details: Tabs crash upon trying to load a video, presumably of a different format. It crashes occasionally on youtube videos, but is for the most part OK with them. Scrolling through a facebook feed however, will give you videos from lots of different sources, and I can reliably crash my tab within 10s if I load up facebook and just scroll down.

Potential fixes I have tried (of which, none solved my issue):

  • Going into About:config and changing the browser.tabs.autorestart and browser.tabs.autorestart2 both to be false. This is following the recommendation of another thread, given to a different user with a similar problem, found here: ( https://support.mozilla.org/en-US/questions/1159697 ).
  • Booting the browser up into safe mode
  • Updating any/all drivers. Specifically I can for sure, without a doubt, say that my gfx card drivers are up to date.
  • Creating a new firefox profile, and using it instead.

At this point the only thing that comes to mind is the idea that the plugin loading these videos isn't working correctly? But is it even a plugin?

Worth noting, if I change the about:config file pieces I listed above to both be false, instead of crashing a tab it will crash the entire browser. A crash report of that specific incident can be found using bp-92e3bbb7-9388-4412-9573-504010170905 .

The normal issue happening can be found using bp-a8e33356-c344-4159-889b-b330a0170905 .

Thank you for any/all help you can provide.

Asked by Juicearific 4 years ago

Answered by FredMcD 4 years ago