Showing questions tagged: اعرض كل الأسئلة
  • حُلّت
  • Locked

HERE is the answer to put "TABS BELOW" which will work with Firefox V90 using the - userChrome.css - file

HERE IS THE ANSWER Here is the answer to get TABS BELOW with Firefox V90 . . copy all of this code below the broken line into your - userChrome.css - file and save it. Yo… (read more)

HERE IS THE ANSWER Here is the answer to get TABS BELOW with Firefox V90 . . copy all of this code below the broken line into your - userChrome.css - file and save it. You can modify the 45px in this line if you wish to get an appropriate height . . just experiment with different numbers till you get it right --menubar-height: 45px; /*30px|41px=11px; caption buttons on menubar*/

Also to make the tabs wider or narrower, modify the line which is coded width: 50vw !important;

Finally you must enable - css - in Firefox, by typing about:config into your address bar, and search for toolkit. When all the toolkit options appear change the one which says toolkit.legacyUserProfileCustomizations.stylesheets to TRUE by click the icon in the right hand column. Than close Firefox and reopen, and check how it looks This will enable your - css - file to be read, and interpreted and accepted by the Firefox browser.

-------------------------------------------------------------------
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

/* TABS: bottom - Firefox 65 and later - updated for 89+ */
/* https://searchfox.org/mozilla-release/source/browser/themes/shared/tabs.inc.css */
/* https://raw.githubusercontent.com/Aris-t2/CustomCSSforFx/master/classic/css/tabs/tabs_below_navigation_toolbar_fx89.css */
/* https://developer.mozilla.org/en-US/docs/Tools/Browser_Toolbox */

/* ROOT - VARS */
/* you can adjust the CSS variables until it looks correct */
/* you can use the Browser Toolbox to get the toolbar heights */

*|*:root {
  --tab-toolbar-navbar-overlap: 0px !important;

  --tab-min-height: 40px !important;
  --tab-min-width:  60px !important;

  --tab-adjust:  0px; /* adjust tab bar - only for 68-73 */
  --tab-caption: 5px; /* caption buttons on tab bar */
}

/* TAB BAR - below nav-bar */
#navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) {-moz-box-ordinal-group:10 !important;}
#TabsToolbar {-moz-box-ordinal-group:1000 !important;}

#TabsToolbar {
  display: block !important;
  position: absolute !important;
  bottom: 0 !important;
  width: 50vw !important;
}

#tabbrowser-tabs {
  width: 100vw !important;
}

/* navigator-toolbox - PADDING */
*|*:root:not([chromehidden*="toolbar"]) #navigator-toolbox {
  position: relative !important; /*89+*/
  padding-bottom: calc(var(--tab-min-height) + 1px) !important; /*ADJUST*/
  background-color: var(--toolbar-bgcolor) !important;
}

/* TabsToolbar with menubar and titlebar hidden - rules for Firefox 65-73 */
*|*:root[tabsintitlebar]:not([inFullscreen="true"]):not([sizemode="maximized"]) #toolbar-menubar[autohide="true"] ~
 #TabsToolbar{
  bottom: var(--tab-adjust); /*ADJUST*/
}

/* TABS: height */
#tabbrowser-tabs,
#tabbrowser-tabs > .tabbrowser-arrowscrollbox,
.tabbrowser-tabs[positionpinnedtabs] > .tabbrowser-tab[pinned] {
  min-height: var(--tab-min-height) !important;
  max-height: var(--tab-min-height) !important;
}

#TabsToolbar {
  height: var(--tab-min-height) !important;
  margin-bottom: 1px !important;
  box-shadow: ThreeDShadow 0 -1px inset, -moz-dialog 0 1px !important; /*OPTIONAL*/
  background-color: var(--toolbar-bgcolor) !important;
  color:            var(--toolbar-color) !important;
/*  z-index: 1 !important; */
}

/* indicators *//*
*|*:root[privatebrowsingmode=temporary] .private-browsing-indicator {
  position: absolute !important;
  display: block !important;
  right: 0px !important;
  bottom: 0px !important;
  width: 14px !important;
  pointer-events: none !important;
}
*/
.private-browsing-indicator {display: none !important;}
.accessibility-indicator    {display: none !important;}

/* Indicators - HIDE *//*
*|*:root:not([accessibilitymode])             .accessibility-indicator    {display: none !important}
*|*:root:not([privatebrowsingmode=temporary]) .private-browsing-indicator {display: none !important}
*/

/* Drag Space */
.titlebar-spacer[type="pre-tabs"],
.titlebar-spacer[type="post-tabs"] {
  width: 20px !important;
}

/* Override vertical shifts when moving a tab */
#navigator-toolbox[movingtab] > #titlebar > #TabsToolbar {
  padding-bottom: unset !important;
}

#navigator-toolbox[movingtab] #tabbrowser-tabs {
  padding-bottom: unset !important;
  margin-bottom: unset !important;
}

#navigator-toolbox[movingtab] > #nav-bar {
  margin-top: unset !important;
}

/* Hide window-controls and caption buttons on Tab Bar */
#TabsToolbar #window-controls {display: none !important;}
#TabsToolbar .titlebar-buttonbox-container {display: none !important;}

Asked by Trevor George, Bristol, UK 4 months ago

Answered by Trevor George, Bristol, UK 4 months ago

  • حُلّت

Can´t paste in http://forum.worldoftanks.eu

Hello there, since the FF90.xx I can´t paste anymore in the World of Tank EU forum. I did refresh firefox and tried it without addons and in private mode and it does not … (read more)

Hello there,

since the FF90.xx I can´t paste anymore in the World of Tank EU forum. I did refresh firefox and tried it without addons and in private mode and it does not work. The only chance that I can paste is in the mobile version from the used IP.Board. I can´t even see the paste/einfügen option in the posting section.

I have some other members inside the community that reported the same issue to me.

It would be nice to get some help/ideas.

With best regards.

Dragokar

Asked by Dragokar 2 months ago

Answered by Nemac 2 months ago

  • حُلّت

Numbers displaying sideways

So recently, when I open web pages, any numbers will display sideways. I reinstalled firefox, but this did not resolve. They appear correctly in other browsers (i.e., c… (read more)

So recently, when I open web pages, any numbers will display sideways. I reinstalled firefox, but this did not resolve. They appear correctly in other browsers (i.e., chrome). Does anyone know what I can do to resolve this? Thanks!

Asked by rdaufan 3 months ago

Answered by rdaufan 2 months ago

  • حُلّت

Repeated crash on quit

iMac macOS 11.5 Firefox 90.0.2 Firefox pretty much crashed every time I quit. Doesn't matter if I'm looking at a web page or close all windows before quitting. Restarting… (read more)

iMac macOS 11.5 Firefox 90.0.2

Firefox pretty much crashed every time I quit. Doesn't matter if I'm looking at a web page or close all windows before quitting.

Restarting in Trouble Shoot mode doesn't help either.

The cause seems to be synchronisation - if I sign out of my account and no longer synchronise, the problem goes away and I can quit without Firefox crashing.

Asked by UKLarry 2 months ago

Answered by UKLarry 2 months ago

  • حُلّت

Browsing some websites!

Dear Sir, I have problems browsing some specific sites like presstv.ir Last Linux update helped to remove this issue but recent Firefox update brought back the issue. I … (read more)

Dear Sir, I have problems browsing some specific sites like presstv.ir Last Linux update helped to remove this issue but recent Firefox update brought back the issue. I have therefore avoid latest Firefox update on my other computers but still want to highlight the issue. I also wonder if this has anything to do with the restrictions US government has put on such sites belonging to the government of Iran?

With regards, //Saeed M. Rad

Asked by saeed1 3 months ago

Answered by jonzn4SUSE 2 months ago

  • حُلّت

Printing Problems after update

Hello Community, Upon updating Firefox today, some sites are cutting off the majority of the page and printing in the top-left corner. I've tried the following and none h… (read more)

Hello Community, Upon updating Firefox today, some sites are cutting off the majority of the page and printing in the top-left corner. I've tried the following and none have helped:

Close and reopen Firefox Refresh Firefox Uninstall and reinstall Firefox Restart my computer Print from the system dialog Print from the Firefox dialog Cleared all add-ons Print from a different computer with a different FF account Print to a different printer Print to PDF

I've attached the PDF (after converting to JPG as required by this page) which was printed through Firefox which shows the issue. The same page prints normally in Edge and Chrome. I printed the same page yesterday without issue and when I did the test from another computer with a different FF account, it printed normally, the browser updated and had the problem so it's definitely something with the most recent FF update.

This may seem minor in scope since it only effects certain sites but it's a huge problem for me as I print quite a few pages from this site daily for order processing. Thank you to anyone who can help!

Derek

Asked by derek48 3 months ago

Answered by AliceWyman 2 months ago

  • حُلّت

on home page a icon listed as "xcazp3" it will not dismiss, what is it?

on home page a icon listed as "xcazp3". It won't dismiss and google doesn't know what it is and I can't get it off my home page. Try to open it and it shows 404 error. … (read more)

on home page a icon listed as "xcazp3". It won't dismiss and google doesn't know what it is and I can't get it off my home page. Try to open it and it shows 404 error. What is it?

Asked by surf1mo 2 months ago

Answered by cor-el 2 months ago

  • حُلّت

"Pause notifications until Firefox restarts" no longer visible or available in Firefox 90.0, what are some other possible options?

I am trying to disable Firefox notifications whenever I take screenshots, and googling for solutions, I found the commonly suggested solution is to uncheck the "Pause no… (read more)

I am trying to disable Firefox notifications whenever I take screenshots, and googling for solutions, I found the commonly suggested solution is to uncheck the "Pause notifications until Firefox restarts" box in Permissions:

How to turn off forever the "screenshot" splash notification

"shot Copied" window

This option is not available in my browser version; thus, I'm hoping there's a newer workaround for this.

Asked by 0zen 2 months ago

Answered by AliceWyman 2 months ago

  • حُلّت

Video Speed Control Not Working Anymore

Hi, I had been using this addon: [https://addons.mozilla.org/en-US/fire.../video-speed-control/] and I had no problems with it, until today when I went to increase the sp… (read more)

Hi,

I had been using this addon: [https://addons.mozilla.org/en-US/fire.../video-speed-control/] and I had no problems with it, until today when I went to increase the speed of a video I was watching, and it wouldn't work no matter what. Clicking to increase the video speed doesn't make the video go faster, as it should.

I uninstalled it and installed many other video speed controller addons, one by one, but none of them work at all either!

The video speed control had been working perfectly well up until now, and I hadn't modified any settings or anything else, that might cause it to stop working.

So how can I get this video speed control addon: [|https://addons.mozilla.org/en-US/firefox/addon/video-speed-control/] to work for me again? Help! I don't want to switch web browsers.

Thank you very much for your time and help, I really appreciate it!

Asked by Clara Klein 2 months ago

Answered by cor-el 2 months ago

  • حُلّت

Radars and Bing maps will not load anymore

Local TV Station Radars and Bing maps will not load anymore. However, the weather channel radar does work. Weird. Running Firefox 90.0.0(64bit) on Win 10. Tried deletin… (read more)

Local TV Station Radars and Bing maps will not load anymore. However, the weather channel radar does work. Weird. Running Firefox 90.0.0(64bit) on Win 10. Tried deleting all cookies and cache- no joy. Tried safe mode- no joy. All Radars and Maps work in Edge, but not Firefox. What else can I do?

Thanks!! Jon Abel

Asked by tigerjonabel 2 months ago

Answered by cor-el 2 months ago

  • حُلّت

Print Preview not printing what it is showing

Hi, Since a couple of days ago the "Print Preview" feature is not working properly again. I think we had an browser update. We had another one today and I was hoping th… (read more)

Hi, Since a couple of days ago the "Print Preview" feature is not working properly again. I think we had an browser update. We had another one today and I was hoping the problem was going to be fixed but it was not.

I have the Print set to old (false) mode. I have used this mode for years to print all of my documents and webpages.

This is what is happening. I do my print preview and adjust the scale number accordingly. The print preview shows, I adjust number of pages, preferences etc. then hit print.

The page that prints is not complete. Is missing the part of the right side and bottom. I have not changed any printer settings. I have also changed it back to the NEW(true) printer mode an the exact thing happens. It happens with both webpages and documents. I first realized what what going on when I printed my bank statement and it was missing the right side and bottom of each page.

THIS IS NOT PRINTER PROBLEM!!!!! Using the EGDE and Explorer browsers, the pages print perfectly so it has to be a Firefox problem.

Can you please help me solve this problem. I hate to have to use another browser just to print. I have enclosed pictures of what is happening.

Amy

Asked by Amylogamy 2 months ago

Answered by AliceWyman 2 months ago

  • حُلّت

Printing at Reduced Scale Cuts Off Page

I have an issue where Firefox is cutting off the lower half of each page (blank) when I print with reduced scale. It is an issue that only occurs in Firefox—I have tried … (read more)

I have an issue where Firefox is cutting off the lower half of each page (blank) when I print with reduced scale. It is an issue that only occurs in Firefox—I have tried another browser. I have tried three printers and it causes the issue on all of them. The issue occurs on all web pages I have tried. I have reset the print settings in Firefox, run Firefox in troubleshooting mode, and refreshed Firefox.

Print preview will show the pages correctly with reduced size, but when printed, the bottom half of each page is blank. However, in print preview, if I change the settings to only print the first page, the preview will then show the first page with the bottom half missing.

I am wondering if this problem is caused by the latest Windows update. That is the last change to the computer I am aware of before this printing problem occurred.

Anything else I can try to resolve this issue?

Asked by n_s_assistant 3 months ago

Answered by Jonathan Watt 2 months ago

  • حُلّت

Certain websites won't load at all in Firefox, but work fine in Edge

Hello, since the recent update to version 90.0 I noticed that certain websites (youtube, facebook, spotify) won't load at all. I just get a blank screen. Additionally on … (read more)

Hello,

since the recent update to version 90.0 I noticed that certain websites (youtube, facebook, spotify) won't load at all. I just get a blank screen. Additionally on instagram I can't see any images or videos.

At first I tried to open these websites in another browser (MS Edge) and there everything works just fine.

To solve my problem I already tried a lot of different approaches, but nothing has helped so far. Here is a overview of everything I tired so far: - deleted the cache and cookies (per Firefox as well as with CCleaner) - deactivated and later deinstalled all my add-ons - started Firefox in Troubleshooting-Mode - used the feature to clean Firefox - completely deinstalled and reinstalled Firefox - disabled and deleted my anti-virus software - temporarily stopped Windows Defender Firewall - used new profiles with the about:profiles menu - used different programs I already had installed (avira, Windows Defender, spybot S&D) to scan for viruses, trojans or malware. And I also used the ones Mozilla recommends on this site: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware -> nothing was found apart from a few tracking cookies

Now I am at my wit's end and don't know what else I could do get my Firefox to work properly again. I hope someone more knowledgeable than me can help me out to find a solution.

Best regards and thank you for your help Andreas

Asked by andreas.baer87 3 months ago

Answered by andreas.baer87 2 months ago

  • حُلّت

No Netflix or Amazon Prime on Firefox 90.0.2. (64bit) for MacOS Catalina - Widevine issues

Netflix and Prime Video do not allow video playing and give me errors associated with Widevine. Thing is, all the threads I have found about Widevine issues for Firefox o… (read more)

Netflix and Prime Video do not allow video playing and give me errors associated with Widevine. Thing is, all the threads I have found about Widevine issues for Firefox on MacOS say that new widevine is not supported on or before MacOS 10.11.

I am using a MacbookPro 13" 2012 Running MacOS 10.15.17 (Catalina) Firefox 90.0.2 (64-bit)

Installed Firefox 78.9.0esr as suggested roll back solution and it did not change anything. Reinstalled Firefox 90.0.2 and now Firefox Plugins section is is telling me that "Widevine Content Decryption Module provided by Google Inc. will be installed shortly." but it doesn't seem to change. I have always stayed updated on MacOS and Firefox versions, and suddenly in early 2021 this has become an issue that persists to date.

Is the current status of Widevine for Firefox on MacOS BROKEN?

There are no roll backs that seem to work, and I can't find anyone else with my MacOS and Firefox versions that are reporting the same problem. Streaming is not only the way of the future, it has been the standard for media viewing for over 5 YEARS. Firefox needs to figure how to make widevine work from the get go or it will quickly go the way of the dinosaur.

I don't WANT to use Chrome (thought I currently do for Netflix), please don't suggest that as a solution.

Asked by pMa1 2 months ago

Answered by cor-el 2 months ago

  • حُلّت

Facebook Messenger not loading complete page Firefox 90.0.2 (64-bit) Windows 10

The Messenger page loads partially and stops. Same page works fine in New Microsoft Edge (Chromium). Problem seemed to start with last upgrade to 90.0.2. https://www.fa… (read more)

The Messenger page loads partially and stops. Same page works fine in New Microsoft Edge (Chromium). Problem seemed to start with last upgrade to 90.0.2. https://www.facebook.com/messages/t/1234... I tried disabling uBlock Origin, Privacy Possum, Privacy badger, page still won't load completely, just partially and "locks up".

Asked by Craiga 2 months ago

Answered by FredMcD 2 months ago

  • حُلّت

Website problem with citi.com, asked for multiple logins

I am having a new problem with < https://www.citi.com/ > I have used this website for years with Ffox with noo problem. What I experience now is that I can login a… (read more)

I am having a new problem with < https://www.citi.com/ > I have used this website for years with Ffox with noo problem. What I experience now is that I can login and use it just fine, i.e. access any of its links, except if I try to use the Virtual Credit Card (VCC) feature. To use that feature you login, select VCC, which takes you to a new page, on which you launch a popup that generates the VC. My issue is that I login, select he VCC page, but instead it takes me back to the main screen to login again. This circular problem can continue as many times as I try it. Below I list my equipment and trouble shooting steps.

I am using a win10 PC running 21H1 and the current version of FFox. I have a Malwarebytes Browser Guard installed (MB).

1. I tried the login on my Surface GO running win10 Home Edition and no MB installed. It worked fine. 2. I tried to login with Chrome and Edge on my PC, neither with the MB browser guard, and they work fine. 3. I have had the MB installed for quite some time and the Citi site always worked fine. Nevertheless I disabled it. That made no difference. 4. Next I clicked the FFox shield and disabled the Enhance Tracking protection. No difference. 5. I deleted all cookies and cache info related to citi, amounting to 10 entries. That made no difference. 6. I deleted all cookies and cache totally. Now I was able to log in and go to the VCC page. 7. I closed out of the citi site and tried to re login. The problem reappeared. 8. I deleted all cookies and cache yet again, closed FFox, launched it again, tried the Citi site and it worked fine. 9. I logged out of citi, tried to log in again, and once more it did not work.

Any ideas?

Asked by eberger5 2 months ago

Answered by eberger5 3 weeks ago

  • حُلّت

Somehow firefox is trying to open (by itself) a page that is sytematically blocked by SOPHOS antivirus.

Somehow firefox is trying to open (by itself) a page that is sytematically blocked by SOPHOS antivirus. It is a malware or a setting in Firefox causing this? the site is:… (read more)

Somehow firefox is trying to open (by itself) a page that is sytematically blocked by SOPHOS antivirus. It is a malware or a setting in Firefox causing this? the site is: flashvd.net/.well-known/http-opportunistic. This is happening only when firefox is running. thanks

Asked by wiprada 2 months ago

Answered by wiprada 2 months ago