Showing questions tagged: اعرض كل الأسئلة
  • حُلّت

Firefox exclusively scrolling extremely fast

Scrolling in Firefox is causing any webpage to scroll many lines at once with a single click, and it seems to be exclusively happening to Firefox, as every other applicat… (read more)

Scrolling in Firefox is causing any webpage to scroll many lines at once with a single click, and it seems to be exclusively happening to Firefox, as every other application scrolls normally. I have tried searching here and elsewhere for a solution, and I have tried to change about:config settings based on the recommendations I could find to no avail. I have also tried to refresh Firefox and have used Troubleshoot Mode, but those too have not worked. I have no clue as to what could have caused this, as I have not been messing with any settings prior to this.

Asked by eventfulhorizon 3 weeks ago

Answered by eventfulhorizon 3 weeks ago

  • حُلّت

X button hitbox doesn't reach the edge of the screen in KDE Plasma 6

On a fresh install of openSUSE Tumbleweed 20240313 with KDE Plasma 6 (Wayland), the X button in the upper right corner of the screen does not allow you to click it when t… (read more)

On a fresh install of openSUSE Tumbleweed 20240313 with KDE Plasma 6 (Wayland), the X button in the upper right corner of the screen does not allow you to click it when the pointer is in the upper right corner of the screen. Default behavior in KDE is to just let you close the window anyways even though the button itself is circular.

Is there any way to change this?

Asked by wheelman2004 4 weeks ago

Answered by cor-el 4 weeks ago

  • حُلّت

Choppy video on some sites after update to Firefox 115.8.0esr

Video on some websites is choppy after updating to a newer version of Firefox (115.8.0esr). I have attempted to upload a video of the problem but it seems only still imag… (read more)

Video on some websites is choppy after updating to a newer version of Firefox (115.8.0esr). I have attempted to upload a video of the problem but it seems only still images are allowed and this doesn't illustrate the problem. An example website where this occurs is https://www.fiat.it but there are plenty of other examples. It looks as if the playback is jumping forwards and backwards between frames. Strangely Youtube videos seem OK.

Some information which may be of use

OS: OpenSuse Leap 15.5 HW: Dell Precision 7510 with Nvidia Quadro M2000M video card and driver version 550.54.14

I have also noticed that when starting Firefox from the command line I see frequent messages like

Sandbox: attempt to open unexpected file /sys/devices/system/cpu/cpu0/cache/index2/size Sandbox: attempt to open unexpected file /sys/devices/system/cpu/cpu0/cache/index3/size Sandbox: attempt to open unexpected file /sys/devices/system/cpu/present Sandbox: attempt to open unexpected file /sys/devices/system/cpu Sandbox: unexpected multiple open of file /proc/cpuinfo

Probably not relevant but I included it just in case it is useful

Any help you can offer with debugging would be much appreciated, thanks

Asked by Nigel.Woolaway 1 month ago

Answered by jonzn4SUSE 1 month ago

  • حُلّت
  • المُؤرشفة

I am running Firefox on Ubuntu 22.04 and it constantly crashes. Trying to determine what is causing this.

I have a new installation of Ubuntu 22.04 on my 2015 Lenovo IdeaPad 300. I have a new SSD HD 1 TB in size and it should work, however, Firefox keeps crashing. Other app… (read more)

I have a new installation of Ubuntu 22.04 on my 2015 Lenovo IdeaPad 300. I have a new SSD HD 1 TB in size and it should work, however, Firefox keeps crashing. Other apps are crashing too.

Asked by Daniel Grindstaff 7 months ago

Answered by Daniel Grindstaff 7 months ago

  • حُلّت

Firefox logged out my accounts each time i close, but setting disabled.

Ubuntu 22.04.3 LTS Firefox 123.0 (64-bit) The browser deletes cookies when closed. Every time I log in, I need to re-enter passwords (they are saved) on all sites, this … (read more)

Ubuntu 22.04.3 LTS Firefox 123.0 (64-bit)

The browser deletes cookies when closed. Every time I log in, I need to re-enter passwords (they are saved) on all sites, this is certainly tiring. I read about a similar problem from other users, they had the “Delete cookies and site data when Firefox is closed” setting enabled, but I didn’t.

Asked by kexitt07 1 month ago

Answered by kexitt07 1 month ago

  • حُلّت

Disable download finished notification

I want to disable notifications when a download is finished, however the key in about:config 'browser.download.manager.showAlertOnComplete' does not exist any more. Is th… (read more)

I want to disable notifications when a download is finished, however the key in about:config 'browser.download.manager.showAlertOnComplete' does not exist any more. Is there some other way to disable these notifications?

Asked by Robin_w151 1 month ago

Answered by zeroknight 1 month ago

  • حُلّت

Firefox manual update with Linux Ubuntu

I have a System 76 laptop running Ubuntu 14.04 LTS. The LTS (Long Term Support) ended years ago with Firefox 66. All of that works fine still. My problem is: 1. The worl… (read more)

I have a System 76 laptop running Ubuntu 14.04 LTS. The LTS (Long Term Support) ended years ago with Firefox 66. All of that works fine still. My problem is: 1. The world is telling me to upgrade my browser. 2. Mozilla tells me "Note: If you use your Linux distribution's packaged version of Firefox, you will need to wait for an updated package to be released to its package repository. This article only applies if you installed Firefox manually (without using your distribution's package manager)." 3. There will never be an updated package because LTS has ended. 4. IS THERE A WAY TO MANUALLY INSTALL A NEWER BROWSER LIKE FIREFOX 123?

Asked by Jim 1 month ago

Answered by Jim 1 month ago

  • حُلّت

Assistance Request - Firefox Browser Animation and Window Issues

Dear Firefox Support Team, I hope this message finds you well. I am writing to seek assistance with a persistent issue I have been experiencing in my Firefox browser. De… (read more)

Dear Firefox Support Team,

I hope this message finds you well. I am writing to seek assistance with a persistent issue I have been experiencing in my Firefox browser. Despite my efforts to troubleshoot, I have encountered problems with various animations within the browser.

The specific issues include:

  Text Selection Animation: The animation for text selection does not function.
   Element Overflow Scroll: The animation for scrolling within elements in overflow does not work.
   Developer Menu Resizing (F12): The animation for resizing the developer menu (F12) is not functioning.
   Button Hover Effects: When hovering over elements such as buttons, the expected CSS :hover modifications do not occur.
   The cursor remains the same regardless of where it is moved. This is particularly problematic as the cursor often retains the icon corresponding to editable text even when over buttons.

Additionally, there are complications when resizing the browser window. Upon resizing, the window seems to "half" itself, making it impossible to drag or further resize. This behavior also hides the three standard buttons present in all windows.

An additional symptom is that when I initially open the browser, it functions perfectly. However, during usage, the first indication of a problem is the disappearance of the mouse cursor, requiring movement for a couple of seconds. From that point onward, all mentioned issues begin to manifest.

I have taken several steps to address these issues, including:

   Complete Firefox Reinstallation: I uninstalled and reinstalled Firefox from scratch in an attempt to resolve the problem.
   ESR Version Testing: I experimented with the Extended Support Release (ESR) version of Firefox, but the issues persisted.
   Hardware Acceleration Disable: I disabled hardware acceleration to check if it was causing the problems, but the animations still did not work correctly.

Despite these efforts, the problems persist, and I am reaching out to seek your expert guidance in resolving these issues. Your assistance in this matter is highly appreciated.

Thank you for your time and consideration.

Best regards,

Ivan Beltrame

Asked by Ivan Beltrame 5 months ago

Answered by cor-el 5 months ago

  • حُلّت

Unable to Access FlightRadar24 web site due to issue with WebGL

Since this week I have been unable to access flightradar24 web site due to a problem with WebGL. It tells me that I need a compatible browser e.g. Firefox I am running L… (read more)

Since this week I have been unable to access flightradar24 web site due to a problem with WebGL. It tells me that I need a compatible browser e.g. Firefox

I am running Linux Mint 21.3 Cinnamon on and I7 processor with a NVIDIA Corporation GK208B [GeForce GT 710] graphics card.

I have edited the about:config file as follows:

webgl.force_enabled TRUE

but noted a collection of failed messages as shown on the attached screen shot.

This web site is still accessible using chromium on the same computer, suggesting that there isn't a hardware problem.

Thanks

Howard

Asked by h.brissenden 1 month ago

Answered by h.brissenden 1 month ago

  • حُلّت

Webpage elements do not open.

On this webpage on the link below, when the 'Comments' button is clicked, nothing happens. It works via the Chrome browser. https://www.mirror.co.uk/news/politics/george… (read more)

Asked by johnh009 1 month ago

Answered by zeroknight 1 month ago

  • حُلّت

How to get rid of unrequested invasive rendered area debugging overlay?

After updating my openSUSE Firefox package from version 122 to 123 every frame inside each window started to have weird grey overlay of scrollable area. I failed to find … (read more)

After updating my openSUSE Firefox package from version 122 to 123 every frame inside each window started to have weird grey overlay of scrollable area. I failed to find any description of such a thing happening, let alone how to get rid of it. I tried removing build-in distro-default preferences and had complete audit of all my custom preferences in about:config but none changed that behavior. I even updated to 124b4 but this also haven't changed anything. Naturally, nuking entire profile is not an option, I might as well replace the whole browser. So, how do I get rid of this thing?

Asked by F0X 1 month ago

Answered by zeroknight 1 month ago

  • حُلّت

Wrong Scaling with HiDPI Screen on Linux

Dear Technical Support, I'd like to report a problem which affects the rendering of websites in Firefox with a HiDPI monitor. I'm having issues with the text and graphi… (read more)

Dear Technical Support,

I'd like to report a problem which affects the rendering of websites in Firefox with a HiDPI monitor.

I'm having issues with the text and graphics of web pages, that are often mismatched or misaligned, with text being too large compared to graphical elements. See the enclosed pictures for an example; as you can see, this happens also on your website. Also, I've noted that pages (and plugins) appear to be "shrinked" as opposed to when viewed on Chrome, where they are shown to their true size.

Setting ui.textScaleFactor=100 and tweaking with layout.css.devPixelsPerPx did not change much. I must admit that I find this behavior quite strange, since HiDPI monitors have been around for more than a decade, and especially considering that this did not impact my experience with Firefox on Windows, using the same monitor and machine.

I hope to find an effective solution to this problem and look forward to your reply. Please let me know if I can be of any help in this matter.

Best regards, Federico

Asked by Federico 1 month ago

Answered by Federico 1 month ago

  • حُلّت

Sync does not work on any device

I have never managed to get Firefox Sync to work on my devices, I don't know why. I don't get an error message saying it failed or why it failed. I run Firefox on desktop… (read more)

I have never managed to get Firefox Sync to work on my devices, I don't know why. I don't get an error message saying it failed or why it failed. I run Firefox on desktop (Linux) and Android, both always updated to the latest version.

My use case is simple, I just want my mobile Firefox to have all the bookmarks I have on desktop already.

On Android, when I go to my account settings it says "Las synced: never". Clicking the "Sync now" button does absolutely nothing.

On Desktop I go to Settings - Sync, press the Sync button. It appears to work, though no feedback is ever provided.

When I go to about:sync-log, on desktop, finally an error is shown. It seems to attempt to connect to https://sync-765-us-west-2.sync.services.mozilla.com/1.5/207352084/info/collections and fails. Manually going to the URL also fails on both desktop and mobile. Entire log below

1709188645048 Sync.LogManager DEBUG Flushing file log 1709188645050 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709188645050 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709188645052 Sync.LogManager DEBUG Log cleanup threshold time: 1708324645052 1709188645052 Sync.LogManager DEBUG Done deleting files. 1709188684156 FirefoxAccounts DEBUG FxAccountsWebChannel message received: fxaccounts:fxa_status 1709188684156 FirefoxAccounts DEBUG fxa_status received 1709188684156 FirefoxAccounts DEBUG service: sync 1709188684156 FirefoxAccounts DEBUG is private browsing: false 1709188684291 FirefoxAccounts DEBUG FxAccountsWebChannel message received: fxaccounts:loaded 1709188684291 FirefoxAccounts WARN Unrecognized FxAccountsWebChannel command: fxaccounts:loaded 1709188690370 FirefoxAccounts DEBUG FxAccountsWebChannel message received: fxaccounts:pair_preferences 1709188690446 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709188690446 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709188690446 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709188690446 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709188690496 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709188767104 FirefoxAccounts DEBUG FxAccountsProfileClient: Requested profile 1709188767104 FirefoxAccounts DEBUG getOAuthToken enter 1709188767104 FirefoxAccounts TRACE getCachedToken returning cached token 1709188767104 FirefoxAccounts DEBUG getOAuthToken returning a cached token 1709188767104 Services.Common.RESTRequest DEBUG GET request to https://profile.accounts.firefox.com/v1/profile 1709188767361 Services.Common.RESTRequest DEBUG GET https://profile.accounts.firefox.com/v1/profile 304 1709188768376 Sync.RemoteTabs INFO Generating tab list with filter 1709188768377 Sync.RemoteTabs INFO Final tab list has 0 clients with 0 tabs. 1709188991788 FirefoxAccounts ERROR Pairing channel error: Error: WebSocket unexpectedly closed(resource://gre/modules/FxAccountsPairingChannel.sys.mjs:3599:20) JS Stack trace: FxAccountsPairingChannel</_setupListeners/<@FxAccountsPairingChannel.sys.mjs:3599:20 1709189210399 FirefoxAccounts DEBUG FxAccountsWebChannel message received: fxaccounts:fxa_status 1709189210400 FirefoxAccounts DEBUG fxa_status received 1709189210400 FirefoxAccounts DEBUG service: 30b11ae57025e70b 1709189210400 FirefoxAccounts DEBUG is private browsing: false 1709189279244 Sync.SyncScheduler DEBUG Network link status changed to "changed". Offline?: false 1709189285734 Sync.SyncScheduler DEBUG Network link status changed to "changed". Offline?: false 1709189303334 Sync.SyncScheduler DEBUG Network link status changed to "changed". Offline?: false 1709189310511 Sync.SyncScheduler DEBUG Network link status changed to "changed". Offline?: false 1709189312578 Sync.SyncScheduler DEBUG Network link status changed to "changed". Offline?: false 1709189527477 FirefoxAccounts DEBUG FxAccountsProfileClient: Requested profile 1709189527477 FirefoxAccounts DEBUG getOAuthToken enter 1709189527477 FirefoxAccounts TRACE getCachedToken returning cached token 1709189527477 FirefoxAccounts DEBUG getOAuthToken returning a cached token 1709189527477 Services.Common.RESTRequest DEBUG GET request to https://profile.accounts.firefox.com/v1/profile 1709189527975 Services.Common.RESTRequest DEBUG GET https://profile.accounts.firefox.com/v1/profile 304 1709189534135 Sync.Service DEBUG User-Agent: Firefox/123.0 (Linux x86_64) FxSync/1.125.0.20240219145322.desktop 1709189534135 Sync.Service INFO Starting sync at 2024-02-29 06:52:14 in browser session 1LYtwG18bBEH 1709189534135 Sync.Service DEBUG In sync: should login. 1709189534135 Sync.Service INFO User logged in successfully - verifying login. 1709189534135 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709189534135 Sync.SyncAuthManager DEBUG unlockAndVerifyAuthState already has (or can fetch) sync keys 1709189534135 Sync.Status DEBUG Status.login: error.login.reason.network => success.status_ok 1709189534135 Sync.Status DEBUG Status.service: error.login.failed => error.login.failed 1709189534135 Sync.Service DEBUG Fetching unlocked auth state returned success.status_ok 1709189534136 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1709189538030 Sync.Resource WARN GET request to https://sync-765-us-west-2.sync.services.mozilla.com/1.5/207352084/info/collections failed: [Exception... "The connection was established, but no data was ever received" nsresult: "0x804b0014 (NS_ERROR_NET_RESET)" location: "<unknown>" data: no] No traceback available 1709189538030 Sync.Service DEBUG verifyLogin failed: [Exception... "The connection was established, but no data was ever received" nsresult: "0x804b0014 (NS_ERROR_NET_RESET)" location: "<unknown>" data: no] No traceback available 1709189538031 Sync.Status DEBUG Status.login: success.status_ok => error.login.reason.network 1709189538031 Sync.Status DEBUG Status.service: error.login.failed => error.login.failed 1709189538031 Sync.Status DEBUG Status.login: error.login.reason.network => error.login.reason.network 1709189538031 Sync.Status DEBUG Status.service: error.login.failed => error.login.failed 1709189538031 Sync.ErrorHandler ERROR Sync encountered a login error 1709189538032 Sync.SyncScheduler DEBUG Clearing sync triggers and the global score. 1709189538032 Sync.SyncScheduler DEBUG Next sync in 3600000 ms. (why=schedule) 1709189538034 Sync.Service DEBUG Exception calling WrappedLock: Error: Login failed: error.login.reason.network(resource://services-sync/service.sys.mjs:1041:15) JS Stack trace: onNotify@service.sys.mjs:1041:15 1709189538034 Sync.Service DEBUG Not syncing: login returned false. 1709189538035 FirefoxAccounts TRACE not checking freshness of profile as it remains recent

Asked by Cosme Benito 1 month ago

Answered by jonzn4SUSE 1 month ago

  • حُلّت

Linux save dialog limitations

I've just tried to save something from firefox on linux(Manjaro KDE) and was baffled that there doesn't seem to be a way to manually enter the path and navigate to it in … (read more)

I've just tried to save something from firefox on linux(Manjaro KDE) and was baffled that there doesn't seem to be a way to manually enter the path and navigate to it in the save dialog. In addition to that, there are many locations missing and I can't seem to find a way to add new custom or favorites ones either.

All that combined means it was impossible to save my file directly to a network location, which is something I very often need to do. It just seems insane for such a basic feature to be missing and I've found a 4 years old thread about it meaning nothing has been done to fix this since? https://support.mozilla.org/en-US/questions/1279125

The only way I can see would be to mount the network path(not a good solution for one offs) and navigate to it(a symlink can make it closer to one of the existing shortcut but still annoyingly require more clicks) every time but that's very tedious since most of my saving is on a specific server drive.

Asked by SamKook 1 month ago

Answered by jonzn4SUSE 1 month ago

  • حُلّت

colorfore theme

How can I restore a previous theme? I had a "colorfore" theme that Mozilla offered a few years ago set up in Firefox. It was perfect! I could see everything clearly with … (read more)

How can I restore a previous theme? I had a "colorfore" theme that Mozilla offered a few years ago set up in Firefox. It was perfect! I could see everything clearly with my aging eyesight.Then one of my synced computers needed a new Linux OS installation so I signed out of sync on that machine. Installed the new OS. When I started Firefox the first time I signed into sync. I got my history, bookmarks and bookmark bar, but no custom colors. Now my computer at work has its colors reset to the out of box colors too. I have lost the colorfore colors I have been using for several years now. How can I get the colorfore colors back? Thank you for your attention in this matter. I love Firefox, use it exclusively and contribute to Mozilla. Gregg Scholfield

Asked by Gregg Scholfield 1 month ago

Answered by cor-el 1 month ago

  • حُلّت

Firefox not preventing sleep

Hello, I have a problem with Firefox on Linux, doesn't seem to be distro specific as I've tried Manjaro/Ubuntu/Neon, when using KDE in that when listening to music on Yo… (read more)

Hello,

I have a problem with Firefox on Linux, doesn't seem to be distro specific as I've tried Manjaro/Ubuntu/Neon, when using KDE in that when listening to music on YouTube music my computer will go to sleep after the elected time. On KDE you can see which applications are preventing sleep and/or screen lock, other applications are listed here but not Firefox.

When playing a video everything works as expected.

I would investigate myself, but I don't know where to start so if someone can point me in the right direction or offer any insights?

Currently using: KDE Neon KDE 6.0 Kernel 6.5.0-21 Wayland

Asked by dclark16 1 month ago

Answered by zeroknight 1 month ago

  • حُلّت

Using system wide proxy setting in Linux

I have the HTTP_PROXY, HTTPS_PROXY and FTP_PROXY (and their lowercase counterparts) exported and then the firefox binary is started from the shell script. The settings in… (read more)

I have the HTTP_PROXY, HTTPS_PROXY and FTP_PROXY (and their lowercase counterparts) exported and then the firefox binary is started from the shell script. The settings in firefox say it will 'Use system proxy settings'. Nevertheless I do not see the proxy being used as I can not access the web pages that need the proxy. The 'about:config' also does not show that firefox picked up any proxy related information from the shell environment.

I know the proxy address is correct because if I use brave browser instead of firefox (same shell script that launches brave) I can reach the web pages behind the proxy as expected.

Asked by hinko.kocevar 1 month ago

Answered by TyDraniu 1 month ago

  • حُلّت

Firefox Bookmarks toolbar disappears as soon as any website selected

This issue has arisen on Firefox for Linux Mint (my current version is 123.0 (64bit)). I like Firefox, and I like its bookmarks toolbar, and have used it for many years,… (read more)

This issue has arisen on Firefox for Linux Mint (my current version is 123.0 (64bit)). I like Firefox, and I like its bookmarks toolbar, and have used it for many years, but there seems to be a new bug introduced today:- The bookmarks toolbar is present and correct when I start Firefox, but now it disappears as soon as I select any bookmark, or if I enter any web address or if I open a new tab. The [View >Toolbars > Bookmarks Toolbar > Alway Show] option is already selected, but the toolbar is no longer visible. If I click on it again, the bookmarks toolbar reappears (or I can restart Firefox, and this will also restore the toolbar). But the toolbar now disappears as soon as I use the browser in any way, and so is currently not really of practical use, as it needs constant restoring. Hope you can help resolve this. Many thanks in advance

Asked by pxr1377 1 month ago

Answered by cor-el 1 month ago

  • Locked

this forum board

Locking this thread, please continue here: [/questions/1440721] Can someone please tell me how to answer questions asked, in emails to me, receoved from support helpers. … (read more)

Locking this thread, please continue here: [/questions/1440721]
Can someone please tell me how to answer questions asked, in emails to me, receoved from support helpers. In ~6 emails received so far, my only response option looks like clicking the "Mark It as Solved" button...I can't see how to answer, for example, that I'm using Debian Buster, with KDE. Also, jonzn4SUSE asked me to "see screenshot" of his SUSE distribution, but I can't see that image, nor a file attachment. Thanks again.

Asked by lee.hinkleman 1 month ago