Showing questions tagged: Show all questions
  • Solved

Capturing control of the add-on.

Why was one of the add-ons able to take over control of the entire browser and add-ons in it and establish its own rules? At the same time, it deleted all history and ope… (read more)

Why was one of the add-ons able to take over control of the entire browser and add-ons in it and establish its own rules? At the same time, it deleted all history and open tabs and my profile (firefox) did not save anything and did not restore the current session after reinstalling the browser, although it is worth remembering the current session and tabs there. I tried to remove this add-on for a long time, but it blocked all possibilities to do it. The browser began to open with one tab with an incomprehensible address, which was not even displayed correctly, and any attempt to search for something led to the opening of an incomprehensible search engine, but it was possible to go to Google. I don’t remember the name of the search engine, alas, it was several months ago, there was still no time to write to you. Oh yes, on the screenshots everything is in Russian, I'm not sure that you can fully understand them, and if so, write to me about it and I will try to translate the key positions. I would be glad to hear at least some thoughts on this in my profile mail. Here are some screenshots:

Asked by mr.andersan 3 weeks ago

Answered by cor-el 3 weeks ago

  • Solved

Open a SPECIFIC and SINGLE webpage every time Firefox is opened

Hello, Whenever I open Firefox, I simply want www.google.com to be the only tab to open and load. Right now, Firefox opens my previous tabs every time I open the applica… (read more)

Hello,

Whenever I open Firefox, I simply want www.google.com to be the only tab to open and load.

Right now, Firefox opens my previous tabs every time I open the application and I cannot stand it. I do not want this feature at all. I want my entire previous history of tabs to be completely WIPED whenever I open Firefox. I want absolutely no memory of any tabs I previously visited. I only want www.google.com to open in a single tab every time I open the browser.

How do I achieve this?

Thanks

Asked by Saleem Kawar 3 weeks ago

Answered by jscher2000 3 weeks ago

  • Solved

Is there any way to hide site status indications?

So Firefox shows site status indications in the lower left corner. I don't know the technical term, since it's not just the one site I've allowed to send notifications. O… (read more)

So Firefox shows site status indications in the lower left corner. I don't know the technical term, since it's not just the one site I've allowed to send notifications. On some pages, these contrast with the background. So these flash as the page loads, and they can flash again if the page tries to load something new every 30 seconds. I am photosensitive and flashing can hurt and I want to either block this or find some way to reduce the contrast, such as showing this in a continuous bottom panel.

Is there any way to block this? And what are they supposed to be called?

Asked by MarjaE 3 weeks ago

Answered by cor-el 3 weeks ago

  • Solved

Main menu opens, showing up to the right, partly/mostly out of my screen

I'm using OpenSuSE Leap 15.2 , updated Firefox these days, and now when I click on the menu, it opens and shows up to the right, out of the screen (when maximized). Also … (read more)

I'm using OpenSuSE Leap 15.2 , updated Firefox these days, and now when I click on the menu, it opens and shows up to the right, out of the screen (when maximized). Also when I hover over options close to the right edge of the screen, the bubbles show partly out of the screen, same as the main menu. I've tried Refresh, Safe Mode, downgrading to a previous version, but nothing helps now Mind the menu on the screenshot.

Any ideas?

best, Istvan

Asked by Pityucount 3 months ago

Answered by Pityucount 3 weeks ago

  • Solved

Fermer plusieurs onglet

Hi, Je n'ai pas trouvé dans About:Config une option pour revenir au fonctionnement précédent avec les options fermer les onglets Fermer les onglets directement accessible… (read more)

Hi,

Je n'ai pas trouvé dans About:Config une option pour revenir au fonctionnement précédent avec les options fermer les onglets Fermer les onglets directement accessibles comme c'est toujours le cas dans Chrome (Voir PJ).

J'utilise beaucoup ces options et je déplore d'avoir à passer par un menu intermédiaire.

Cdt

JPS

Asked by YBSalaun 3 weeks ago

Answered by cor-el 3 weeks ago

  • Solved

disable app update

Hi, I'm used to deploying/configuring Firefox in an organization with settings in autoconfig.js, etc. Recently, I've seen that some settings are honored, others aren't, s… (read more)

Hi,

I'm used to deploying/configuring Firefox in an organization with settings in autoconfig.js, etc. Recently, I've seen that some settings are honored, others aren't, so I started using policies.json as well as keeping my autoconfig.js. Can they work together?

In any case, I am unable to disable app update with either of them. I have the following in policies.json:

{

   "policies": {

"DisableFirefoxAccounts": true, "DisablePocket": true,

       "DisableAppUpdate": true,

"DontCheckDefaultBrowser": true, "DNSOverHTTPS": { "Enabled": false }, "Certificates": { "ImportEnterpriseRoots": true } "PopupBlocking": { "Allow": ["http://10.215.144.56:8080", "https://intranet.mydomain.org"], "Default": true | false, "Locked": true | false }

   }

}

I'm also showing a snippet of my autoconfig.js file:

lockPref("app.update.auto", false); lockPref("app.update.enabled", false); lockPref("app.update.mode", 0); lockPref("app.update.service.enabled", false); lockPref("app.update.disable_button.showUpdateHistory", false); lockPref("app.update.url", ""); lockPref("app.update.url.details", ""); lockPref("app.update.url.manual", ""); lockPref("signon.rememberSignons", false); lockPref("extensions.update.enabled", false);

The problem is that when I start Firefox 78.3.0 ESR and go to the about Firefox window, I can see that the app update is not disabled.

How can I make sure that all the above settings in autoconfig.js are actually honored?

Thanks

Asked by vieri 3 weeks ago

Answered by cor-el 3 weeks ago

  • Solved

Change pdf viewer background color (both sides of the pdf) to dark

Hey there, awesomes! I'd like to change my Firefox pdf viewer's background color (both sides of the pdf) to dark, currently it shows light gray (see `background_bg.png`)… (read more)

Hey there, awesomes! I'd like to change my Firefox pdf viewer's background color (both sides of the pdf) to dark, currently it shows light gray (see `background_bg.png`). And here is effect I want it to look like (see screenshot from Chrome `wished_bg.png`). Thanks in advance (:

PS: I don't want to change my theme to dark. It seems I have to change my css, but I dunno which & how.

Asked by Mark Taylor 1 month ago

Answered by jscher2000 1 month ago

  • Solved

Cannot update self-hosted add-on due to "Certificate issuer is not built-in" error

I have a custom add-on that I'm working on for my team. It's hosted internally on a server signed by our company's internal CA. The add-on is signed by Mozilla, but not h… (read more)

I have a custom add-on that I'm working on for my team. It's hosted internally on a server signed by our company's internal CA. The add-on is signed by Mozilla, but not hosted on AMO.

I am on the latest version of Fedora running Firefox 81.0. In the browser console I get this error relating to the URL for the addon when I tell Firefox to check for updates: "Certificate issuer is not built-in".

I have the company CA installed and when I navigate to the site in the browser, Firefox recognizes the cert. I've done some reading on the subject and seen several threads about it. I've tried a few things already, but most of the threads where a couple of years old.

I'm asking the question here hoping to figure out what the current state of the problem is and which settings I should tweak to have it trust the company CA or what my options are.

Thank you in advance for any support on the issue.

Asked by bplaxco 1 month ago

Answered by bplaxco 3 weeks ago

  • Solved

userChrome.css to disable blue highlight marker on active tab

I am using tab-on-bottom code in userChrome.css that I got from the web. 1. There is a highlight feature of the tabs. A mouse-over will do a subtle enhancement of the top… (read more)

I am using tab-on-bottom code in userChrome.css that I got from the web.

1. There is a highlight feature of the tabs. A mouse-over will do a subtle enhancement of the top portion of the line delineating of the tab. 2. The active tab has a blue bar at the top portion of the line delineating the tab.

I want both to go away. I have code to highlight the background color of the active tab and need no other highlight function.

The userChrome.css is below.

Thanks, Gert

/* TABS: bottom - Firefox 65 and newer; should for now work with XUL @namespace */


  1. TabsToolbar {
 -moz-box-ordinal-group: 1000 !important;
 display: block !important;
 position: absolute !important;
 bottom: 0 !important;
 width: 100vw !important;

}

  1. tabbrowser-tabs {
 width: 100vw !important;

}

  • |*:root:not([chromehidden*="toolbar"]) #navigator-toolbox {
 padding-bottom: calc(var(--tab-min-height) + 1px) !important; /*adjust*/

}

/* position Tab bar with Menu bar and Title bar hidden for Firefox 65-73 - omit in Firefox Nightly */

  • |*:root[tabsintitlebar]:not([inFullscreen="true"]):not([sizemode="maximized"])
  1. toolbar-menubar[autohide="true"] ~ #xTabsToolbar{
 bottom: var(--tab-min-height) !important;
 padding-top: calc(var(--tab-min-height) - 0px) !important; /*adjust*/

}

/* TABS: height */

  • |*:root {
 --tab-toolbar-navbar-overlap: 0px !important;
 --tab-min-height: 30px !important; /*adjust to set height or omit to use density*/
 --tab-min-width:  80px !important; /*adjust to set width or omit to use default*/

}

  1. TabsToolbar {
 height: var(--tab-min-height) !important;
 margin-bottom: -0px !important; /*adjust*/
 background-color: #F5F6F7 !important;

}


/* caption buttons - hide */

  • |*:root[tabsintitlebar]:not([inFullscreen="true"])
#toolbar-menubar[autohide="true"] ~ #TabsToolbar
.titlebar-buttonbox-container {display: none !important;}

/* Change Color of active tab */ .tab-background[selected="true"] {

   background-color: #A8FFAD !important;
   background-image: none !important;

}

/* Rounded corners on tabs firefox 58 */ /* http://forums.mozillazine.org/viewtopic.php?f=38&t=3037688# */ .tabbrowser-tab::after, .tabbrowser-tab::before {

  border-left: none !important;

} .tab-background {

 border-radius: 6px 6px 6px 6px !important;
 border-image: none !important;
 border-left: 1px solid !important;
 border-right: 1px solid !important;
 border-top: 1px solid !important;
 border-width: 1px !important;
 border-color: #000080 !important;
 background-attachment: none!important;
 background-color: #DAD7D0 !important;
 background-image: none !important;

}

/* Menu bar (File Edit View) height and background color */

  1. toolbar-menubar, #menubar-items, #main-menubar {
 height: 30px !important;
 background-color: #DAD7D0 !important;
 background-image: none !important;
 font-size: 14px !important;

}

/* Menu bar (File Edit View) text color */ .menubar-text, .tabbrowser-tab:not([selected="true"]) tab-label {

 color: #080808 !important;

}

/* Use Normal top and bottom padding for Compact */

  1. PlacesToolbarItems .bookmark-item {
 padding-top: 10px !important;
 padding-bottom: 6px !important;

}

Asked by drgert1 4 weeks ago

Answered by jscher2000 4 weeks ago

  • Solved

Removing Firefox Alpenglow theme isn't possible

Hello, Since the new release version of firefox. There is a extra theme installed and I can't remove it because I don't like it. I'm using Thematic extention to rotate be… (read more)

Hello,

Since the new release version of firefox. There is a extra theme installed and I can't remove it because I don't like it. I'm using Thematic extention to rotate between my theme's that i like. I have looked in the menu to remove it manually, but the selection isn't there. The added picture shows the only option I have (it's in dutch) and that is manage. So how can I remove or relocate it.

Greetings,

Asked by Willem 1 month ago

Answered by cor-el 4 weeks ago

  • Solved

remove Search with Amazon from address bar suggestions

Everytime I open the suggestions in the address bar Search with Google or Search with Amazon appear at the top. You cannot remove them by using the 'forget about this sit… (read more)

Everytime I open the suggestions in the address bar Search with Google or Search with Amazon appear at the top. You cannot remove them by using the 'forget about this site' feature and if you change the browser.urlbar.openViewOnFocus to 'False' you don't get the suggestions. Can you tell me how to permanently remove Search with Google or Search with Amazon from the suggestions. Thank you.

Asked by gspotts 6 months ago

Answered by jscher2000 6 months ago