Firefox reports a secure connection without existing certificate

When i click on the lock icon in the address bar, nothing happens (I would expect to see the encryption and certificate, but no widget opens). When I right-click into the… (read more)

When i click on the lock icon in the address bar, nothing happens (I would expect to see the encryption and certificate, but no widget opens). When I right-click into the page and select "View Page Info", "Security", "View Certificate", no certificate exists. Only generic info is shown (Servers+Authorities). Also an error is reported in the system log, confirming that no certificate exists: JavaScript error: chrome://browser/content/browser-siteIdentity.js, line 642: TypeError: issuerCert is undefined

Questions:

  • Why does Firefox show the lock icon while no certificate exists?
  • How does Firefox establish a secure connection without having a certificate? (From my understanding a certificate is needed for TLS to work.)

Version used: Firefox 78.12.0esr ('Mozilla/5.0 (X11; FreeBSD amd64; rv:78.0) Gecko/20100101 Firefox/78.0'), no add-ons or plugins.

Asked by pmc1 1 week ago

Last reply by pmc1 1 day ago

The bookmarks menu in Firefox stopped scrolling

After the 90.0.2 update, the bookmarks menu no longer scrolls with the center wheel of my mouse. The center wheel scrolls properly in my emails, on webpages, everywhere e… (read more)

After the 90.0.2 update, the bookmarks menu no longer scrolls with the center wheel of my mouse. The center wheel scrolls properly in my emails, on webpages, everywhere else but the in the bookmarks. I have to use the up or down arrows to scroll through them, and it's a royal pain because I have so many bookmarks.

Asked by zx9r170 1 month ago

Last reply by zx9r170 2 days ago

Selective Blocking of JWplayer by Site

I would like to block some sites (entire domains) from injecting JWPlayer iframes while I'm trying to read the site. (The Hill, https://thehill.com, is particularly annoy… (read more)

I would like to block some sites (entire domains) from injecting JWPlayer iframes while I'm trying to read the site. (The Hill, https://thehill.com, is particularly annoying with this.) However, I need to see content that some other sites embed in JWPlayer, so I can't use the nuclear option of blocking the cdn for jwplayer in my hosts file.

Are there any settings or add-ons available that allow by-domain blocking of JWPlayer? (I don't care if it's a "whitelist" or "blacklist" approach, so long as I can manually determine which sites play and which don't.)

Asked by Jaws 2 days ago

Last reply by Jaws 1 day ago

Firefox not loading Facebook images

Hello, I am at a loss to trying to fix a problem after extensive troubleshooting. When I am on Facebook for about five minutes, Firefox stops loading most images. This on… (read more)

Hello, I am at a loss to trying to fix a problem after extensive troubleshooting. When I am on Facebook for about five minutes, Firefox stops loading most images. This only occurs with Firefox, not Safari or Chrome. And it only occurs with Facebook and Instagram, which is owned and run by Facebook. I have to restart Firefox to get images back and then after five minutes or so, it happens again every time. Can anyone help? This is driving me crazy!

Thank you

Asked by lkutchermusic 6 days ago

Last reply by lkutchermusic 5 days ago

Locked out of Firefox sync, formal request to delete personal data best solution?

Hi, it's been a while since I used Firefox and I don't seem to have a way of getting back into Sync with my primary e-mail address since I can't find my backup code. Who … (read more)

Hi, it's been a while since I used Firefox and I don't seem to have a way of getting back into Sync with my primary e-mail address since I can't find my backup code. Who do I contact to either get my account deleted so I can start again, or get an account reset option set to my e-mail address? Ultimately none of my devices are logged in, and I cannot find my backup code.

The impression I have so far is that you have to sign in with another e-mail account (which is what I have done now), but this is not the e-mail account I want to use.

If Mozilla are storing my name and contact details for the sign in, would the best route be a formal request for deletion of personal data?

Thanks

Asked by jim.clow 2 days ago

Last reply by jim.clow 4 hours ago

Unable to log into Firefox Sync

I recently got all new devices and traded in my previous ones and when trying to login to Firefox Sync, I can sign in successfully but then I’m required to provide the 6-… (read more)

I recently got all new devices and traded in my previous ones and when trying to login to Firefox Sync, I can sign in successfully but then I’m required to provide the 6-digit code that is sent to my email. I am unable to login to my email because the password in stored in my Firefox Sync saved passwords.

Attempted to reset my email password (Gmail) but I need to enter the last password that I used, which I have no idea since I’ve always used Firefox Sync and all I get from Google is “we are unable to verify this account belongs to you”. So not much traction on gaining access to my email account.

In my mind, I assumed that by utilizing Firefox Sync as a form of a password manager, I wouldn’t be in this situation as long as I knew my Firefox Sync password. I have since learned otherwise. I can sign-in on accounts.firefox.com but of course making any change requires that I put in the code that was sent via email.

I attempted to download Lockwise and again prompted to enter the code sent via email.

So at this point, I’m just wondering if I’m out of luck and although I know my password to my Firefox account that I’ll be unable to regain access to it or my email because I can’t access the 6-digit code being sent to that email.

Any additional support or suggestions are appreciated but I feel like I’m unfortunately at the end of the line here on what else could be done.

Asked by Corey W 4 hours ago

Last reply by Corey W 15 minutes ago

Changes in Firefox from Version 86 to 90, 92

Apologies for asking this here, but I've done the Google and can't find an answer. Background: I keep 2-3 Firefox versions and profiles on my computer. The software is in… (read more)

Apologies for asking this here, but I've done the Google and can't find an answer.

Background: I keep 2-3 Firefox versions and profiles on my computer. The software is in, for example, directories FFox82, FFox84, FFox86 The profiles are in, for example, directories Firefox82, Firefox84, Firefox86 (The software and profiles are on different drives.)

When I do an upgrade, I copy the newest software to a new directory and rename it (e.g., FFox92 - so now there are 4 sw directories) Then I copy the newest profile directory and give it a corresponding name (e.g., Firefox92 - so now there are 4 profile directories). I install the new version to its directory and thenlaunch with a -p option. Then I create a new profile and point it to the corresponding folder. Then I launch the new version with the -p option pointing to the new profile directory.

This has worked for decades.

But I just tried it with Firefox 90 and Firefox 92 and NO GO. It acts as if I've never used Firefox before. No apps, no toolbars, no bookmarks, nothing.

What is going on? Am I stuck on Firefox86 for the rest of the century?

And, please, don't tell me how wonderful these new versions are and I should simply accept the change. I have a virtual lifetime invested in the toolbars, extensions and bookmarks on my computer.

I simply want to know if there is a fix and, if so, what it is.

Asked by RemySecor 6 days ago

Last reply by RemySecor 4 days ago

Media Key functionality intermittent

Periodically Firefox will stop accepting media key input from my keyboard, the media keys continue to function for Chrome (neither are open at the same time, when functio… (read more)

Periodically Firefox will stop accepting media key input from my keyboard, the media keys continue to function for Chrome (neither are open at the same time, when functionality fails in Firefox, I open chrome to test if the keys are working) media.hardwaremediakeys.enabled is set to true, have swapped it to false and back, restarted, double and triple checked the physical media keys. Sometimes Firefox will just accept the media key input, and sometimes it won't

Asked by takashi1532 1 month ago

Last reply by takashi1532 1 day ago

Firefox shows blank white page for all tabs, unusable

Referencing these threads: 1281774 1307368 1317055 https://support.mozilla.org/en-US/questions/1333680 (I posted a reply to this thread, but I can't view it and the mod… (read more)

Referencing these threads: 1281774 1307368 1317055 https://support.mozilla.org/en-US/questions/1333680 (I posted a reply to this thread, but I can't view it and the moderator has apparently closed it thinking this problem has gone away)

We can ascertain that NOTHING seems to help this condition. In fact these threads apply to me as Win 7 / 64 bit apply to me. This started probably about 1.5 years ago.

I too have this problem and yes, it is random. BUT once locked in with this condition, it may "get stuck" for another 5 attempts for the same link. BEST Example, I do surveys every Friday and Saturday night. I use my netscape (AOL) email account. At random, while clicking on the survey link the tab will come up blank and no matter what you do, you CANNOT get this tab to do ANYTHING. No reload, no clicking on a new bookmark, no clicking on home, or typing in the address bar and pressing enter on THAT particular tab. How often does it happen? Maybe 12 times a month (during survey time: maybe every other weekend).

One step further on this. My wife's account on the PC actually does this on a DAILY BASIS REPEATEDLY EVERY DAY when she opens FireFox. In her case, it can ONLY be solved by closing and reopening FireFox after waiting like...say...2 minutes after previously opening it? I have tried opening new tabs etc as mentioned above (including the old right clicky trick and using the "Open in new tab" function). Kinda silly when you have like 27 tabs of blankness. Considering it is her account on the Pc, ok, maybe the "refresh" function might work on her? BZZZT! Nope.

Current version. I can attest that a PC at my 2 jobs that both have Win 7 and at least one, if not both, have 64 bit versions and do NOT display this malady. Also, I did re-install FF about 2 years ago for some other problem. I just ran the troubleshooting more...no go. Per this lead, try https://support.microsoft.com/en-us/topic/the-latest-supported-visual-c-downloads-2647da03-1eea-4433-9aff-95f26a218cc0... and guess what? No such help . Anyone have have something to kill this bug?

Asked by metalman630 1 month ago

Last reply by metalman630 6 days ago

N-th tab in firefox doesn't load

Hiya, I'm having a minor inconvenience with firefox 91.0.2 for a few months now. It's popped up a few months ago and hasn't resolved itself in between updates. I'm guilt… (read more)

Hiya,


I'm having a minor inconvenience with firefox 91.0.2 for a few months now. It's popped up a few months ago and hasn't resolved itself in between updates.

I'm guilty of having many (well over 20) tabs open at the same time and around the 20th or 30th tab even, usually one of the (newly opened) tabs, simply never loads. If I open the same link in another tab, the link (any url) does load. See the screencap below.

This is on a windows 64 bit machine OS build: 19043.1165 (21H1) Windows Feature Experience Pack 120.2212.3530.0

I'm running Norton 360 Antivirus software.

Will try running in safe mode, to see if it still happens and confirm in a reply to this message.

Hoping you guys might have some suggestions.

BTW: https://support.mozilla.org/en-US/questions/1317506 is probably the same problem, unfortunately the thread has been archived. This one: https://support.mozilla.org/en-US/questions/1285104 also seems similar.

White Bar appears above all firefox windows when Firefox is maximized, need help getting rid of it.

I have a strange white bar that appears above the Firefox window at all times, but it's only visible on one of my other monitors, which is positioned above the monitor Fi… (read more)

I have a strange white bar that appears above the Firefox window at all times, but it's only visible on one of my other monitors, which is positioned above the monitor Firefox is on. I've tried starting firefox with all my extensions and themes disabled, and all that did was make the bar black instead of white.

This lead me to believe it was the Title bar. However, that's currently disabled. When I enable the title bar, the white bar disappears, but then I'm left with the title bar (which I do not want).

Is there a way I can have the Title bar disabled and not have this bar appear?

Worth noting I'm using the Lepton UI mod (which doesn't seem to be responsible for this) and DisplayFusion (which I thought would have been responsible for this, however I cannot be sure). Running Win 10.

Asked by Shigbeard 3 days ago

Last reply by Shigbeard 3 days ago

Ubuntu Snap problem with Firejail

I read that Firefox will using the Snap version by default on Ubuntu 21.10 and beyond. Will the non-Snap version still be available in lets say Ubuntu 22.04 and beyond? T… (read more)

I read that Firefox will using the Snap version by default on Ubuntu 21.10 and beyond. Will the non-Snap version still be available in lets say Ubuntu 22.04 and beyond? The reason I ask is because I use Firejail to sandbox Firefox and Firejail doesn't work with Snaps and yes I know that Snaps and Flatpacks both sandbox apps but I prefer Firejail because of the Private Home profile (nothing is saved in this profile settings, bookmarks, add-ons etc) its way more secure than the sandbox offered by a Snap.

Asked by Baldape 4 days ago

Last reply by Baldape 3 days ago

MY site not Working On Mozilla

Hey there! my site is over all good i'm open my site in mozilla but got Error by Mozilla blocked My site Here's site Url > [link hidden] Any Solution or please Gui… (read more)

Hey there! my site is over all good i'm open my site in mozilla but got Error by Mozilla blocked My site Here's site Url > [link hidden] Any Solution or please Guide me

Asked by zs1558743 6 days ago

Last reply by zs1558743 3 days ago

Blacked out letters on Firefox Bookmarks Toolbar and Window tabs

Sometimes (not always!), the entries on my bookmarks toolbar appear with the lower case a's blacked out, and the leading edge of lower case e's as well. Nowhere else on t… (read more)

Sometimes (not always!), the entries on my bookmarks toolbar appear with the lower case a's blacked out, and the leading edge of lower case e's as well. Nowhere else on the page does this happen. Anyone else ever seen this? Is there a fix? Thanks

Asked by dtowson 1 week ago

Last reply by dtowson 6 days ago

LINKS DO NOT WORK

LINKS IN THIS SITE DO NOT WORK. THE OWNERS HAVE TESTED IT WITH FIREFOX AND ALL OK WHAT IS WRONG WITH MY PC www.bidorbuy.co.za A SIMPLE NOT TECHNICAL ANSWER PLEASE. … (read more)

LINKS IN THIS SITE DO NOT WORK. THE OWNERS HAVE TESTED IT WITH FIREFOX AND ALL OK WHAT IS WRONG WITH MY PC

www.bidorbuy.co.za

A SIMPLE NOT TECHNICAL ANSWER PLEASE.

Asked by rod18 5 days ago

Last reply by rod18 5 days ago

Some YouTube videos aren't in sync with the audio

I'm having a problem with a couple videos where the video and audio aren't in sync. For example, the video in the first screenshot is only 2:30, yet when I play it, it se… (read more)

I'm having a problem with a couple videos where the video and audio aren't in sync. For example, the video in the first screenshot is only 2:30, yet when I play it, it seems to partially mimic the video in the second screenshot; it "extends" to 2:41, and it plays the video from the second video. However, it plays the audio from the first video and the progress bar still only goes to 2:30, yet the video keeps playing for another 11 seconds without any audio until the video from the second video ends. Seeking forward causes the different recommendations to pop up as if the video had ended normally.

I am using a MSI laptop on Windows 10. I have restarted my computer, cleared my cookies and cache, and updated Firefox to the latest version. This problem persists with all of my extensions disabled, and when logged in or out of YouTube (no matter the account) or in incognito mode. At first, I thought it had something to do with the video and/or channel, since the other video with the same problem was also uploaded by AmericanDadVEVO. When I tried watching the video in the first screenshot on Microsoft Edge (which I barely use and have no extensions on), however, it worked normally.

Any help would be appreciated! I really do not want to switch to another browser.

Asked by David_H23 2 weeks ago

Last reply by David_H23 5 days ago

Sometimes Quora.com will not run properly in a newly opened session. Other times it works perfectly.

Fairly regularly I go to the Quora.com site to answer questions others have asked. Perhaps in one in four times I launch Firefox browser and go to this site it will not r… (read more)

Fairly regularly I go to the Quora.com site to answer questions others have asked. Perhaps in one in four times I launch Firefox browser and go to this site it will not respond beyond the first page and eventually report that something on the page is slowing the browser. If this does not happen, everything works normally and very quickly.

The only way I can continue is to close the browser completely and relaunch. Even if I wait a minute or so, when I relaunch it tells me Firefox is already running and asks if I wish to close it. If I let it close the browser, the new launch normally works perfectly.

When the problem occurs, opening other tabs and closing the original one does not seem to make a difference. It still does not work properly.

I am not sure when this started, and I have only experienced this problem on this one site. When I have tried using the Chrome browser I have not seen this happening on this site. I don't like the Chrome browser but have it installed to allow streaming my screen to a Chromecast dongle.

The Firefox browser in the Windows 64-bit version 92.0.

This start happening a few weeks ago (it is now mid September 2021). I am not sure whether something has changed in Firefox or in the Quora site. I have seen this problem on both my Windows 8.1 Pro and Windows 10 Pro PCs.

Asked by str8chat 1 week ago

Last reply by str8chat 2 days ago

Firefox 92, troubleshoot mode messed up my addons, trying to get them back

Someone in Bugzilla instructed me to use Troubleshoot Mode for a separate problem, so I did. After reverting back to normal mode, I find that my addons are gone. Then I… (read more)

Someone in Bugzilla instructed me to use Troubleshoot Mode for a separate problem, so I did. After reverting back to normal mode, I find that my addons are gone. Then I checked about:profiles. I find that one profile (default-release) has my tabs in normal colors (gray) and no addons, while another profile (default) has my addons, but the tabs are strangely white, which I don't want. How do I get the addons to appear while having normal tab color (gray)?

Asked by wkrp 1 day ago

Last reply by wkrp 15 hours ago

Is it possible to return the Bookmarks to their orginal setting without using a CSS file?

Windows 10 x64 Pro Firefox 92.0 Is there a way to restore the appearance of Firefox Bookmarks to v88 or earlier? The extra space between each Bookmark is a pain and none … (read more)

Windows 10 x64 Pro Firefox 92.0

Is there a way to restore the appearance of Firefox Bookmarks to v88 or earlier? The extra space between each Bookmark is a pain and none of the "fixes" seem to work.

I am not up with messing around with css files to make things seem as they was.

I have Proton Colors Add-on and that supposed to make things look as they did before but they do not.

When Firefox updated to 91.0 I reinstalled v88 which was fine - apart from Firefox nagging me on a daily basis to update to 92.0 which I stupidly did.

Any suggestions please?

Peter

Asked by Peter749 1 week ago

Last reply by Peter749 6 days ago