Showing questions tagged: اعرض كل الأسئلة

Firefox Buttons dont work - Linux

When I run firefox on WSL2, buttons dont work on any pop up windows. Foe example when installing a firefox extention - it will download and pop up a small window at the t… (read more)

When I run firefox on WSL2, buttons dont work on any pop up windows. Foe example when installing a firefox extention - it will download and pop up a small window at the top right to add the extentionto firefox. The buttons dont work. Another example is when opening up the firefox menu bar (hamburger bar) - it will pup up a small window to allow to open up settings, go to add ons, open bookmarks or history. The buttons dont work. Last example is the pop up window for this Ash your question page for firefox support - When clicking "Which topic best described your question - it will pop up a small window to select what type of question Im gonna ask. The buttons dont work.

I dont know how to fix this. I restarted, deleted my firefox profile, started of safe mode, nothing worked. How do I solve this issue?

Asked by Ian Teves 3 hours ago

Netflix Error - F7355-1203

Hi, I was using FF on Ubuntu 22.04.4 LTS. Had version FF 120.x and playing video in Netflix worked fine. Then I updated to FF 124.x and playing video stopped with error… (read more)

Hi,

I was using FF on Ubuntu 22.04.4 LTS. Had version FF 120.x and playing video in Netflix worked fine. Then I updated to FF 124.x and playing video stopped with error F7355-1203.

I've checked the DRM setting and it is enabled, I checked addons and I have OpenH264 and Widevine installed, both set to always active.

I've checked installed codecs and I do have libavcodec58 installed. No update for that available via apt. I also have ffmpeg installed, no problem with that either. I can play Netflix videos in Chrome, but not in Firefox now. Something happened to Firefox when I updated from 120.x to 124.x. Today I updated to 125.x, same problem, Netflix video won't play.

I've unchecked the DRM setting and re-checked it, and that does reinstalled Widevine but does not fix the problem.

Any ideas what could be the cause?

Asked by mark545 4 days ago

Last reply by mark545 4 hours ago

  • حُلّت

How do I disable search suggestions based on my search history, without deleting my search history?

I've disabled this for my google account. So when I search from google.com this behavior doesn't happen. But when I type anything into my address bar on Firefox to search… (read more)

I've disabled this for my google account. So when I search from google.com this behavior doesn't happen. But when I type anything into my address bar on Firefox to search, the first suggestions are from my search history.

I don't want to delete my search history.

I often use my search history to find specific things that I need, but didn't bookmark at the time. I need my search history to be saved. I just don't want to automatically receive suggestions based on it.

Is there any way to turn this off? Even with an extension or something?

Asked by Clinton Graham 6 hours ago

Answered by jscher2000 - Support Volunteer 5 hours ago

Tags box in the bookmarking panel

There used to be a box to write tags as you can see here: https://support.mozilla.org/en-US/kb/categorizing-bookmarks-make-them-easy-to-find?redirectslug=Bookmark+Tags&am… (read more)

There used to be a box to write tags as you can see here: https://support.mozilla.org/en-US/kb/categorizing-bookmarks-make-them-easy-to-find?redirectslug=Bookmark+Tags&redirectlocale=en-US

What happened to it? When it was deleted? Why? Is there a way to restore it?

Asked by Facni 1 day ago

Last reply by zeroknight 16 hours ago

Firefox does not display background color in option tags

I am trying to use a <select> tag to display a color selector. So each <option> has a background color to match its displayed text: ```<select id="stroke… (read more)

I am trying to use a <select> tag to display a color selector. So each <option> has a background color to match its displayed text:

```<select id="strokeColor" name="strokeColor" style="width: 10em;">

             <option value="black" style="background: #000000; text: #FFFFFF">
                     black
             </option>

<option value="aqua" style="background: #00FFFF">

                     aqua
             </option>

<option value="blue" style="background: #0000FF">

                     blue
             </option>

<option value="brown" style="background: #A52A2A">

                     brown
             </option>

<option value="gray" style="background: #808080">

                     gray
             </option>

<option value="green" style="background: #00FF00">

                     green
             </option>

<option value="magenta" style="background: #FF00FF">

                     magenta
             </option>

<option value="orange" style="background: #FFA500">

                     orange
             </option>

<option value="purple" style="background: #800080">

                     purple
             </option>

<option value="red" style="background: #FF0000">

                     red
             </option>

<option value="white" style="background: #FFFFFF">

                     white
             </option>

<option value="yellow" style="background: #FFFF00">

                     yellow
             </option>

<option value="#000000" selected="" style="background: #000000">

                     #000000
             </option>
         </select>```

On Chrome this displays as expected:

https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2024-04-18-22-02-25-eebbd5.png

But on Firefox the background colors are ignored:

https://assets-prod.sumo.prod.webservices.mozgcp.net/media/uploads/images/2024-04-18-22-02-35-bd90ee.png

How can I get Firefox to display the background colors?

Asked by jamescobban 3 days ago

Last reply by NoahSUMO 23 hours ago

Browser makes strange "sw.js" requests to servers, no plugin to blame

I'm developing a website and noticed while testing that firefox sends requests to "/sw.js" on my local webserver. When starting with a fresh profile folder, this does not… (read more)

I'm developing a website and noticed while testing that firefox sends requests to "/sw.js" on my local webserver. When starting with a fresh profile folder, this does not happen (and also not with other browsers). So, I thought, this might be one of my extensions, but in Troubleshooting mode, the browser still sends these requests, everytime a site is refreshed. It does not affect performance or anything, I am just afraid that I was somehow hacked as I did not make many settings in firefox. Do you know, how I could further diagnose the problem?

Asked by Dro 1 day ago

Last reply by TyDraniu 1 day ago

  • حُلّت

Prevent Firefox from closing - kiosk application

Hello! I would like to develop an application that runs continuously, say, at a panel found in a kiosk. I am considering designing it as a webpage that runs locally thro… (read more)

Hello!

I would like to develop an application that runs continuously, say, at a panel found in a kiosk. I am considering designing it as a webpage that runs locally through the browser but I would like to prevent the users from interacting with the OS or closing the tab and the browser. Is there a way to lock Firefox in full screen and hide the exit buttons? Alternatively, do you have another recommendation for development that is more appropriate, for instance a native app?

Thank you in advance for your help.

Asked by serendipity 1 day ago

Answered by TyDraniu 1 day ago

drag and drop keeps breaking.

i am using firefox developer edition version 126.0b3 (64-bit) on linux mint with an x11 desktop and for some reason the drag and drop breaks frequently. i think i have f… (read more)

i am using firefox developer edition version 126.0b3 (64-bit) on linux mint with an x11 desktop and for some reason the drag and drop breaks frequently.

i think i have figured out how i can consistently recreate the bug as well as sort of fix it temporarily.

i start with a newly launched browser. everything works fine. but then if i attempt to drag and drop something shortly after i drag and dropped something else and it did the little animation where it returns to its original position, i find that i cant drag and drop anything FROM firefox to anywhere else. and i also cannot rearrage tabs.

it seems to fix itself whenever I drag something from another program TO firefox successfully such as text into a textbox, or a .html file into the window to view it.

Asked by goombabomber11 3 days ago

  • حُلّت

MimeTypes.rdf missing

Hi, I'm using FF on Fedora 39. However Firefox does not remember any file associations. The MimeTypes.rdf file in the profile is missing and is also not created on rest… (read more)

Hi,

I'm using FF on Fedora 39.

However Firefox does not remember any file associations. The MimeTypes.rdf file in the profile is missing and is also not created on restarting the browser.

In the options I've now set the configuration to "Ask whether to open or save files". Now I see a popup when clicking on a file however there is no checkbox with "remember this file associations" (or something similiar).

Asked by daswas 4 days ago

Answered by cor-el 4 days ago

firefox private mode language error

I use firefox on fedora 38 and after update firefox about a month ago . i got this error when use private mode ,for thai languge it just error but in normal mode it ok . … (read more)

I use firefox on fedora 38 and after update firefox about a month ago . i got this error when use private mode ,for thai languge it just error but in normal mode it ok .

Asked by SD SD 4 days ago

Last reply by zeroknight 4 days ago

Unintended scroll to top of page

browsing website (reddit or amazon for example), the window scrolls to the top every time I move the mouse. doesn't happen all the time though, and only in Firefox. I've … (read more)

browsing website (reddit or amazon for example), the window scrolls to the top every time I move the mouse. doesn't happen all the time though, and only in Firefox. I've serached the internet and can't find anything related. Please help

Asked by myblackfrog 4 days ago

Last reply by zeroknight 4 days ago

Google Maps Street View

When the little yellow man is placed on to the map, and a direction arrow is clicked, the view just continues to spin round. Clicking on the 'X' in the top right hand cor… (read more)

When the little yellow man is placed on to the map, and a direction arrow is clicked, the view just continues to spin round. Clicking on the 'X' in the top right hand corner terminates street view. This does not happen with other browsers.

My OS is Debian 12, Firefox is the latest version 115.9.1esr (64bit).

Asked by johnh009 5 days ago

Last reply by zeroknight 4 days ago

Integrated Webcam not working

The integrated webcam (IMC Networks Integrated Camera, according to lsusb) on my linux laptop does not work in firefox (v124). It works in desktop apps (eg webcamoid), an… (read more)

The integrated webcam (IMC Networks Integrated Camera, according to lsusb) on my linux laptop does not work in firefox (v124). It works in desktop apps (eg webcamoid), and chromium. I've checked the permissions (about:preferences#privacy), and that is not the problem. about:support does not list the device in the input at all. I've tried using LD_PRELOAD=/usr/lib64/libv4l/libv4l1compat.so, but that has not helped. Does anyone have any suggestions?

Asked by Mike Benson 1 week ago

Last reply by zeroknight 4 days ago

  • حُلّت

Firefox input lag on Ubuntu 22.04

Hello Good People, I noticed that the snap version of Firefox had a lag issue when typing into input field. For example, when composing an email and wanting to use backs… (read more)

Hello Good People,

I noticed that the snap version of Firefox had a lag issue when typing into input field. For example, when composing an email and wanting to use backspace to quickly delete a misspelled word, then backspace works slowly, stuttering and jittering. If I hold down a key in the input field it also lays the character down in a stuttery, slow way.

I tried reinstalling the system and that solved the issue. But it has returned again. Maybe it was an update. I also installed WINE and waybridge to get some windows plugins to work on my DAW. I don't know if that has affected it.

I also tried removing the snap version and installing firefox using the terminal but the problem persisted.

It's an annoying problem. Any advice appreciated.

Asked by m.p.hammond 1 week ago

Answered by jonzn4SUSE 5 days ago

Change Firefox filename pattern for Take Screenshots

Firefox can take screenshots of pages or screenshots of custom areas of pages. According to the documentation, when we download the image, the filename should follow the… (read more)

Firefox can take screenshots of pages or screenshots of custom areas of pages.

According to the documentation, when we download the image, the filename should follow the pattern: Screen Shot yyy-mm-dd at hh.mm.ss.png. If I use the :screenshot at the console, the pattern works as documented.

But Firefox is using a different pattern when I choose Take Screenshot from the context menu. The pattern includes the page's title. Example: Screenshot 2024-04-14 at 18-35-16 General ‹ Settings ‹ Geomaster Lda — WordPress.png.

Since the page title can have non common filename characters, I have problems with such filenames. My uploads to MediaWiki fails with such filenames. I know I can report or improve MediaWiki, but my question here is quite simple.

Can I change the Firefox's default pattern for Take Screenshot's downloads?

Asked by Jorge Gustavo Rocha 5 days ago

Last reply by jonzn4SUSE 5 days ago

ChromeOS Firefox - hardware acceleration

I just got a chromebook! Details: Device name: Lenovo Flex 3 12.2" chromebook, 8GB ram. Intel N100 Device code name: IP Flex 3 CB 12 (pujjo, version 123.15786.0) Firefox… (read more)

I just got a chromebook! Details:

Device name: Lenovo Flex 3 12.2" chromebook, 8GB ram. Intel N100 Device code name: IP Flex 3 CB 12 (pujjo, version 123.15786.0) Firefox version: 124.0.2 (flatpak) OS version: Version 123.0.6312.112 (Official Build) (64-bit) Chrome: Version 123.0.6312.112 (Official Build) (64-bit)

When I watch a youtube video with chrome my cpu usage is 20-30% When I do the same with firefox my cpu usage is 50%

Running `about:support` and going into `webrender_compositor` I get the following errors under `env`: 1. Blocklisted by gfxInfo 2. Blocklisted; failure code 3. FEATURE_FAILURE_WEBRENDER_COMPOSITOR_DISABLED

I have set almost all these force renders = True and even granted gpu access to firefox flathub but still no difference in performance. I am asking now because I am just going in circles in the rabbit hole.

Asked by FirefoxFanWhisky 6 days ago

Last reply by FirefoxFanWhisky 5 days ago

extensions.json key

Hello I want to use extension xpi's from a shared external folder over multiple Linux profiles. So i examined the profile folder and found extensions.json. Though i can'… (read more)

Hello

I want to use extension xpi's from a shared external folder over multiple Linux profiles. So i examined the profile folder and found extensions.json. Though i can't find any documentation to it's keys online.

There's "rootURI:" with a "jar:file://path/to/extension.xpi!/", so i tried just replacing the path with the shared one. Though i observed that just makes firefox replace the path with the current one. So i examined further and found the "location:" key with the default value "app-profile". So my guess is, there's other values for other usecases, right?

So, in summary, what i need is:

  • documentation to extensions.json keys or possible values to "location" key.
  • if that isn't intended/doesn't work, how i can achieve my goal otherwise.

And please don't suggest the sync feature, that doesn't work for my usecase.

Asked by dani.priv+moz 5 days ago

Last reply by cor-el 5 days ago

Why can't some Wikipedia pages activate read mode?

Hello everyone, Why some Wikipedia pages cannot activate reading mode under Debian 12 and Firefox ESR 115.9.1, for example this English Wikipedia page on Emmabuntüs does… (read more)

Hello everyone,

Why some Wikipedia pages cannot activate reading mode under Debian 12 and Firefox ESR 115.9.1, for example this English Wikipedia page on Emmabuntüs does not allow reading mode to be activated while French, Spanish and German pages can ?

See our test video on this subject: http://share.emmabuntus.org/Accessibility/Firefox_mode_lecture_non_disponible_emmabuntus_en.mp4

Is there a utility to test pages compatible with reading mode?

Or otherwise in which Firefox log file to see if a page is compatible or not?

Thanks in advance for your help.

Asked by Patrick-Emmabuntus 6 days ago

Last reply by Patrick-Emmabuntus 5 days ago

Japanese Input not appearing

Since about one year I am unable to use Japanese input only in Firefox. When I try to switch with fcitx and control+space, nothing happens. However, fcitx-mocz works ever… (read more)

Since about one year I am unable to use Japanese input only in Firefox. When I try to switch with fcitx and control+space, nothing happens. However, fcitx-mocz works everywhere else on my computer (i.e. terminal, thunderbird, other browsers, etc.). Furthermore, I uninstalled fcitx and everything associated with it and reinstalled it according to this thread: https://support.mozilla.org/en-US/questions/1367181 (just with mocz for Japanese). This also didn't change anything. Any help is appreciated! My system: Operating System: Linux Mint 20.3 Kernel: Linux 5.15.0-91-generic Architecture: x86-64 fcitx version: 4.2.9.7 Mozilla Firefox 121.0

Asked by Paracelsus 3 months ago

Last reply by zeroknight 5 days ago

What and where is my Security Key and how do I touch it?

Please see the attached image. Firefox believes I have a security key. What is a security key? Where do I find it? Why does Firefox think I have one? And why is the… (read more)

Please see the attached image.

Firefox believes I have a security key.

What is a security key? Where do I find it? Why does Firefox think I have one?

And why is there no helpful information to explain this confusing UX?

Asked by kurrent93 6 days ago

Last reply by zeroknight 5 days ago