Showing questions tagged: اعرض كل الأسئلة
  • حُلّت
  • المُؤرشفة

I can't save files in Firefox

Firefox worked perfectly, but since a few days I can't download anything. I'm using Mozilla Firefox snap for Ubuntu 22.04, version 110.0.1 (64 bits) canonical-002 - 1.0 W… (read more)

Firefox worked perfectly, but since a few days I can't download anything. I'm using Mozilla Firefox snap for Ubuntu 22.04, version 110.0.1 (64 bits) canonical-002 - 1.0 With Chrome everything works perfectly so I assume it's a problem from Firefox.

When I open a PDF, a MP3 or any file, the "save" option doesn't display anything. Usually it opened a dialog where I could choose the folder where I wanted to download the file, but now I have nothing.

I have only 4 extensions: - adblocker ultimate - duckduckgo privacy essentials - vuejs dev tools - zotero connector

I always had them and I never encountered any problem.

Asked by DJ Caësar 9114 12 months ago

Answered by DJ Caësar 9114 11 months ago

  • حُلّت
  • المُؤرشفة

Google sign in pop-up.

Does anyone know how to configure Firefox to stop the annoying google log-in pop-up? I've seen others ask the same question, but I have not seen any functional answers. … (read more)

Does anyone know how to configure Firefox to stop the annoying google log-in pop-up? I've seen others ask the same question, but I have not seen any functional answers. I've never had a google account, for anything. I don't get the pop-up with other browsers, like Falcon or Brave. It's just a problem on Firefox. I appreciate you help!

Asked by njbetavirp1 1 year ago

Answered by njbetavirp1 1 year ago

  • حُلّت
  • المُؤرشفة

Firefox using FIDO2 Security Keys

Firefox seems to have a problem on Linux using USB Security Keys. I have two Yubico Security Keys which I use for 2FA. The problem seems to be that Firefox cannot communi… (read more)

Firefox seems to have a problem on Linux using USB Security Keys. I have two Yubico Security Keys which I use for 2FA. The problem seems to be that Firefox cannot communicate with the USB port, as it doesn't make any difference whether the USB Security Key is plugged in or not, the error returned is always the same and the Security Key does not light up.

I believe Firefox's WebAuth code must be fine, as it works on Windows, which is why I think it's some kind of permissions problem. Chrome works perfectly with the Security Keys on my computer.

I've used a number of sites (I've listed a couple below) where you can test your Security Key with Firefox on KDE Neon and the error is always "UnknownError: The operation failed for an unknown transient reason":

https://www.token2.com/tools/fido2-test/ https://demo.yubico.com/webauthn-technical/registration

I cannot log into Bugzilla with GitHub as my GitHub login uses a Security Key as the second factor.

Asked by dave353 10 months ago

Answered by cor-el 10 months ago

  • حُلّت
  • المُؤرشفة

Some video content can not be displayed.

I use a laptop with Fedora 36 installed. Firefox is version 104.0.1 Until a few days ago, there were no problems with video display. But since a few days, video content … (read more)

I use a laptop with Fedora 36 installed. Firefox is version 104.0.1

Until a few days ago, there were no problems with video display. But since a few days, video content that is offered by the news site from NOS (Dutch television) is not displayed anymore. I only get this error: The media playback was aborted due to a corruption problem or because the media used features your browser did not support.

Also some content on Youtube aborts. For example loading https://www.youtube.com/watch?v=qq0BUiEs3JM results in this error: Er is een fout opgetreden. Probeer het later opnieuw. (Afspeel-ID: Ui0fzPxdSexgYcZ4).' (An error occured, try later again).

When using the Chrome Browser both websites can be used without giving errors implying that all the codecs are available.

How can I detect why video is blocked?

(Twitter also gives problems. After a fraction of a second, it stops displaying video)

Asked by Ben Engbers 1 year ago

Answered by Ben Engbers 1 year ago

  • حُلّت

Cloudflare challenges only work in incognito (with all extensions)

I've been having an issue for a while now where the cloudflare challenges that ask you to click the check mark to "verify your connection is secure" would just endlessly … (read more)

I've been having an issue for a while now where the cloudflare challenges that ask you to click the check mark to "verify your connection is secure" would just endlessly ask me to click the button and never continue. Sometimes it would say to unblock access to challenges.cloudflare.com.

But if I a launch an incognito window I can visit website with the challenge and it won't even ask! I've added all my extensions to run in incognito mode and everything still works, I can visit the websites in incognito just fine. So the one changing variable is incognito vs non-incognito.

I can have two windows open, one incognito and one not, and browse to the same website and the non-incog window will fail but the incog will just go to the site.

I thought incognito was supposed to only affect the session storage? Does it silently change other things to the running environment of the browser (about:config options, slightly different extension configs)?

Anyone know why this small change would suddenly allow cloudflare challenges to work?

Asked by txrxnet 5 months ago

Answered by txrxnet 5 months ago

  • حُلّت
  • المُؤرشفة

Firefox flags MP4 file as malware

Hi, Is there any reason firefox would flag an mp4 file legitimately? The file extension and file type are absolutely mp4. There seem to be no mp4 related zero days… (read more)

Hi,

Is there any reason firefox would flag an mp4 file legitimately?

  • The file extension and file type are absolutely mp4.
  • There seem to be no mp4 related zero days.

Does Firefox perhaps just treat all downloads from suspicious domains as malware? Is there a zero day I missed? Is this based on some missing metadata on the file or something?

Thanks for any advice you can give here, I'm scared.

Asked by jordanfilipovski 10 months ago

Answered by cor-el 10 months ago

  • حُلّت
  • المُؤرشفة

Firefox version 102 removed Edit and Resend Request (Console Tools) - and broke "Resend"

Using Firefox version 102: Open console tools and navigate to Network tab Right click on a POST request "Edit and Resend" is no longer an option? There is still the rese… (read more)

Using Firefox version 102:

Open console tools and navigate to Network tab Right click on a POST request "Edit and Resend" is no longer an option? There is still the resend option Clicking resend allows you to edit the request, but unfortunately the "Content-Length" attribute is not automatically updated like it was with edit and resend, so all requests fail after being edited. This is because the Content-Length header indicates the size of the message body, in bytes, sent to the recipient. When you add or removes bytes in a JSON request for example, it doesn't get updated. The attribute can also not be manually set. How can I use version 102 to edit and resend requests the same way I used to?

Thank you.

Asked by programming_all_night 1 year ago

Answered by TyDraniu 1 year ago

  • حُلّت
  • المُؤرشفة

Import Certificates button not functioning

I am attempting to import server certificates into Firefox. But the "Import" button does nothing when viewing certificates. Any work around? I need to import our serv… (read more)

I am attempting to import server certificates into Firefox. But the "Import" button does nothing when viewing certificates. Any work around? I need to import our server certificates into the Authorities section.

Ubuntu 22.04 Firefox installed through snap. Version 104.0 just upgraded this afternoon.

Thank you, James

Asked by James Finnall 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • حُلّت
  • المُؤرشفة

Firefox Automatically Redirecting from HTTP to HTTPS (RESOLUTION)

As per this issue I reported a while back, I was experiencing odd issue with automatic redirect to HTTPS for some private development sites. I finally found a fix for th… (read more)

As per this issue I reported a while back, I was experiencing odd issue with automatic redirect to HTTPS for some private development sites.

I finally found a fix for the issue. The problem appears to be with DuckDuckGo Privacy Essentials Extension which apparently *may automatically redirect to the http site. In order to prevent this, I added my development sites to 'Unprotected Sites' and this prevented DuckDuckGo from doing the automatic redirect to https.

  • - Odd thing is that I had multiple domains pointing to the same web instance and only one of the domains was having this issue with the DDG extension. Both were going to the same IP through a HTTP proxy. The proxy and web server were not the issue. This symptom points to an maybe an issue in Firefox....

In summary, be wary of odd redirects and the DuckDuckGo Privacy Essentials extension if you are doing web development work.

Asked by Timothy C. Quinn 1 year ago

Answered by Timothy C. Quinn 1 year ago

  • المُؤرشفة

Disabling Control +w keybind

Could you add a option of closing tab with <kbd>Ctrl</kbd>+<kbd>w</kbd> to the advanced preference? Also, I realized that: ```browser.tabs.warnO… (read more)

Could you add a option of closing tab with <kbd>Ctrl</kbd>+<kbd>w</kbd> to the advanced preference?

Also, I realized that:

```browser.tabs.warnOnClose False``` Does this option activates warn when closing the tab? If your answer is yes, it is not working at all.

Asked by maxemilian 1 year ago

Last reply by wtfiwinomgs 1 year ago

  • حُلّت
  • المُؤرشفة

All tabs are crashing and show the message 'Gah. Your tab just crashed'

I am using firefox v104 on linux mint. This problem happened this evening. Every tab i open shows the same error. I tried the solutions suggested in other similar forum… (read more)

I am using firefox v104 on linux mint. This problem happened this evening. Every tab i open shows the same error.

I tried the solutions suggested in other similar forum posts like >safemode (tabs still crashed) >driver update (my drivers are up to date as far i can tell) >deleting cache and reinstalling firefox (tabs crash). I took a backup of my bookmarks and extensions as suggeated in another forum post. > one youtube video (https://youtu.be/F9VaXwSB_po) suggested toggling media.cubeb.sandbox in the config section. The tabs started loading after that but it wasnt that useful as i wasnt able to get any videos to play in the browser.

Also, i don't really know if the issue is related, but chrome tabs were also not loading or responding ('Page unresponsive' error).

Please help. Thank you :)

Asked by Vaghar 1 year ago

Answered by Vaghar 1 year ago

  • حُلّت
  • المُؤرشفة

Firefox breaks my desktop environment's scrollbar style and (gradient) color and in version 98+ refuses css to approximate it

I work on kubuntu 20.04 with plasma 5.18.8 desktop environment. I have a QtCurve-based custom application style, which I almost match with css for GTK apps. Firefox has t… (read more)

I work on kubuntu 20.04 with plasma 5.18.8 desktop environment. I have a QtCurve-based custom application style, which I almost match with css for GTK apps. Firefox has to be an exception by itself! Not only that, but it changes my ability to customize its interface, from time to time and even changes access to such ability, on some updates.

My scrollbar customizations in userChrome.css and userContent.css do not work any more (other CSS changes still work, for menu/addressbar/tabbar/bookmarksbar orderint and tab styling). I had to resort to settings in user.js file, to get a 20px width scrollbar, suitable for my big screen, but... it gets very wide when I increase the focus, on some webpages and becomes very ugly! Furthermore, I cannot make sense of the proper use of "ui.themedScrollbar*" settings and the scrollbar and its slider result in the same color. These are my settings in user.js:

user_pref("widget.content.gtk-theme-override", "backwater"); user_pref("widget.non-native-theme.enabled", false); // Use GTK-3.0 gtk.css: set to false user_pref("toolkit.legacyUserProfileCustomizations.stylesheets", true); // Use userChrome.css & userContent.css: set to true user_pref("widget.gtk.alt-theme.scrollbar_active", true); user_pref("widget.non-native-theme.scrollbar.size.override", 20); // If nothing else works, fix scrollbar width to 20px user_pref("widget.non-native-theme.gtk.scrollbar.round-thumb", false); user_pref("widget.non-native-theme.gtk.scrollbar.thumb-size", 1.0); // originally 0.75 user_pref("widget.non-native-theme.gtk.scrollbar.allow-buttons", true); // it was true, anyway... user_pref("layout.css.cached-scrollbar-styles.enabled", false); user_pref("layout.css.color-mix.enabled", true); user_pref("widget.non-native-theme.scrollbar.style", 4); // wide scrollbar theme: set to 4 user_pref("ui.themedScrollbar", "#bad1f5"); user_pref("ui.themedScrollbarInactive", "#668cc4"); user_pref("ui.themedScrollbarThumb", "#e4e4e4"); user_pref("ui.themedScrollbarThumbHover", "#e4e4e4"); user_pref("ui.themedScrollbarThumbActive", "#668cc4"); user_pref("ui.themedScrollbarThumbInactive", "#bad1f5"); user_pref("browser.dom.window.dump.enabled", false); user_pref("extensions.ui.sitepermission.hidden", false); user_pref("fission.experiment.max-origins.qualified", true);

Either with the "ui.themedScrollbar*" settings or without them (and cleared from the prefs.js file), the scrollbar and its slider result in the same color, unless I (tryingly) click on some place on the scrollbar outside its slider; then I can see the slider, _only_ for the duration of the mouse-down event (which causes up or down page-hight scrolling).

The default, very thin scrollbar, as well as my modified wide scrollbar with invisible slider are both useless to me! I have even tried fx-autoconfig (https://github.com/MrOtherGuy/fx-autoconfig) to make the scrollbar CSS work, but no result. At this point, I am considering switching to another browser, despite the trust I have to mozilla, for my data and privacy.

Asked by kavadias 1 year ago

Answered by kavadias 1 year ago

  • حُلّت
  • المُؤرشفة

Sync doesn`t sync my tabs

Sync is a nightmare. It is so unintuitive! What exactly would be wrong with having separate Export and Import buttons for each of Settings, Addons, Tabs, History, Bookm… (read more)

Sync is a nightmare. It is so unintuitive! What exactly would be wrong with having separate Export and Import buttons for each of Settings, Addons, Tabs, History, Bookmarks, etc? I have a desktop box and a newer laptop I wanted to get up to date. I pressed the Sync button on the desktop ... By the way, there`s a link below that reads "Connect another device" ... Connect where? Someone is designing these interfaces who has absolutely zero imagination. Anyways, I signed off, moved the ethernet cable to my laptop, signed in, pressed Sync, and voila!, I got my Bookmarks, at least. But I have no idea how to get my tabs and windows. I tried with a "download link" something or other, but it seemed to assume I was sync-ing to a phone, and didn`t work. Any way to get my tabs?

Asked by Dan_W 1 year ago

Answered by cor-el 1 year ago

  • حُلّت
  • المُؤرشفة

Scroll bars not showing up on some sites since 112 update

I'm using Firefox in Ubuntu 22.04.2. I recently update to 112.0, then 112.0.1 With both versions, the scroll bar is not available on some sites which used to work in pre… (read more)

I'm using Firefox in Ubuntu 22.04.2. I recently update to 112.0, then 112.0.1

With both versions, the scroll bar is not available on some sites which used to work in previous versions. Items which are outside the initial viewing area are not visible.

Is anyone else affected by this issue?

Asked by gomgomfirefox 10 months ago

Answered by cor-el 10 months ago

  • حُلّت
  • المُؤرشفة

Unable to upload or download files

Hello all, For some reason, I can no longer upload or download files, with the pop-up window failing to appear entirely. I can upload folders through, for example, Dropb… (read more)

Hello all,

For some reason, I can no longer upload or download files, with the pop-up window failing to appear entirely. I can upload folders through, for example, Dropbox or Google Drive, but individual files don't work.

I've reset my browser, uninstalled and reinstalled it, opened it in troubleshooting mode, disabled enhanced tracking protection, but nothing seemed to work. I've tested another browser, and I was able to upload and download files just fine.

Is there anything I can do to fix this? I'm on Ubuntu 22.04 using Firefox 107.0.1.

Asked by Erika Campbell 1 year ago

Answered by jonzn4SUSE 1 year ago

  • حُلّت
  • المُؤرشفة

2FA login on web sites does not work with Firefox (Linux)

2FA login on sites works with Chromium but NOT WITH Firefox (Linux) Present setup: Does NOT work firefox 102.7.0esr on debian 11.6 bullseye 5.10.162-1 (x86-64) firefox … (read more)

2FA login on sites works with Chromium but NOT WITH Firefox (Linux)

Present setup:

Does NOT work firefox 102.7.0esr on debian 11.6 bullseye 5.10.162-1 (x86-64) firefox 110.0 on Ubuntu MATE 22.04 LTS 5.15.0-58 (x86-64)

Works chromium 109.0.5414.119 on debian 11.6 bullseye 5.10.162-1 (x86-64)

I am able to register and authenticate with security devices Yubikey NEO (without FIDO2) and Yubikey 5 NFC (FIDO2 compliant) on several sites (eg. pypi, google..) using Chrome or Chromium but now not with Firefox at all. It has not worked for at least the last few updates. Changing settings in about:config or plugging/unplugging keys, stopping every Firefox plugin etc. don't help. Neither does a fresh Firefox install without any super-security-settings.

Testing sites like Yubico's own or Okta's works fine using Chromium but not Firefox.

From what I can see this is not especially related to FIDO2 (Webauthn). pypi seems to use U2F which should work just fine with Firefox since way back.

I haven't tested Firefox for Windows but Chrome browser for Windows 10 works fine (which I tested first when Firefox didn't cut the mustard), I therefore expect it to work also on Chrome browser for Linux. Just to check if this was related to a debian bullseye package, I tested it on Ubuntu MATE too, which didn't do the trick. Haven't done any more testing than that on MATE.

This seems like a strictly firefox problem. -What to do?

Yours, Kaare

Asked by kaare 1 year ago

Answered by kaare 1 year ago

  • حُلّت
  • المُؤرشفة

"Your browser can't play this video" on YouTube

Hello! Just installed Ubuntu 20.04.4 on my laptop and now find that I'm not able to watch some YouTube videos on Firefox 97. It seems mainly just live streams that I can'… (read more)

Hello! Just installed Ubuntu 20.04.4 on my laptop and now find that I'm not able to watch some YouTube videos on Firefox 97. It seems mainly just live streams that I can't watch. When I go to one it shows "Your browser can't play this video...Learn more" in the video window. Clicking Learn More takes me to a page that doesn't explain what the problem is. Any idea what the fix might be? The same videos play just fine on other devices on my network. Any help would be greatly appreciated.

Asked by kdpryor 1 year ago

Answered by kdpryor 1 year ago

  • حُلّت
  • المُؤرشفة

Unable to run 'flatpak install firefox' on chromebook

I was following this article https://support.mozilla.org/en-US/kb/run-firefox-chromeos Installed flatpak and repositories but when I try to use flatpak to install firefo… (read more)

I was following this article https://support.mozilla.org/en-US/kb/run-firefox-chromeos

Installed flatpak and repositories but when I try to use flatpak to install firefox I get "No remote refs found similar to ‘firefox’".

I have tried following a few other ways to get it installed, such as using sudo and using sudo su but that has not worked at all.

I followed to flatpak quick setup on Chromebook guide that is linked in the above help article and created the nested containers in crosh as well.

below is what happens if I go to flathub and copy-paste their recommended command to install firefox.

Remote ‘flathub’ found in multiple installations:

  1) system
  2) user

Which do you want to use (0 to abort)? [0-2]: 2 error: Nothing matches org.mozilla.firefox in remote flathub

Asked by Kili Luther 1 year ago

Answered by cor-el 1 year ago

  • حُلّت
  • المُؤرشفة

Is there a way to reset my Firefox password without losing my data?

I forgot my password to my Firefox account, and only just realized I haven't updated it in KeypassXC when I was trying to log in to a new machine. It seems that, even tho… (read more)

I forgot my password to my Firefox account, and only just realized I haven't updated it in KeypassXC when I was trying to log in to a new machine. It seems that, even though I am already logged in on my old computer and have full access to my account (including saved passwords, bookmarks, and browsing history) I can't find a way to reset my password without deleting all of my synced data. From the "Change Password" menu, it requires my old password if I want to change it without deleting everything. Also, I have 2FA enabled, so why isn't there the option to authenticate my identity in a password reset using 2FA instead of my old password? I know a similar thing already exists for recovery keys, but I only have 2FA. Is there any way for me to reset my password where I don't lose everything? Thank you.

Asked by Isaac Mellington 1 year ago

Answered by cor-el 1 year ago

  • حُلّت
  • المُؤرشفة

Copy-pasting of files not working in Ubuntu 22.04

Hey there, Intro: I recently switched to Linux and (because Brave is so broken) also to Firefox and I am liking it so far. Problem: Unfortunately I can't copy-paste fil… (read more)

Hey there,

Intro: I recently switched to Linux and (because Brave is so broken) also to Firefox and I am liking it so far.

Problem: Unfortunately I can't copy-paste files from Ubuntu Files (Nautilus) to Firefox (I tested image files and also sounds files, neither is working).

Test with Firefox: 1. Download a random photo (e.g. from Unsplash) 2. Select the file and hit ctrl + c in Files/Nautilus 3. I go to the clipboard inspector 4. I hit ctrl + v 5. The image does not show up in the output (see screenshot)

Test with Brave: 1. Do the same as above 2. The image does show up in the output (see screenshot)

Notes: - I am using Linux Ubuntu 22.04 with Wayland - Firefox Version 107.0 (64-bit) for Ubuntu Canonical - 1.0 - I have no extensions installed - I am not using the snap version (so I can scroll smoothly) ... I think I used apt-get install but not 100% sure

Asked by Stephan 1 year ago

Answered by Stephan 1 year ago