Showing questions tagged: Show all questions
  • Archived

Latest update removed logins, bookmarks. "old firefox" not present

As above. FF installed the update despite the checked option to NOT install automatically. NO "old firefox" folder was created-anywhere. No other profile is present tha… (read more)

As above. FF installed the update despite the checked option to NOT install automatically. NO "old firefox" folder was created-anywhere. No other profile is present that has the old data. My adult daughter's grad school laptop. Years of bookmarks, logins and I do not know what all ARE GONE!! I allowed FF to download but NOT INSTALL-since it was not my machine and I wanted to avert any disaster (I, in fact, looked at the options first, to make sure) NOW WHAT?? Is that is a bug?? Why was there no "old FF" created? Why did it install regardless of instructions to the contrary. Is there some other place to look? She does not seem to have any automatic backups for FF profiles.

Asked by patty_r 1 year ago

Last reply by jscher2000 8 months ago

  • Archived

Firefox mac 65.0.2 profile hiding folder

I been having problems with Firefox ever since I refreshed 65.0.1 losing 6 years of bookmarks, addons and passwords, after 7 hours and I managed to get old files back and… (read more)

I been having problems with Firefox ever since I refreshed 65.0.1 losing 6 years of bookmarks, addons and passwords, after 7 hours and I managed to get old files back and had to redo addons and passwords. It became unreliable with copying/paste not working, slowness etc and when I found that it was not updating to latest 65.0.2 I scrapped it and downloaded latest. But cannot get old version of profile back. Instead I have no files showing up in local directory, though root directory is showing *see screenshot. So I have to restart everything from scratch with important passwords and bookmarks etc. It still will not show but closing down firefox it does save and keep customised setup and session etc. Is this normal to vanish on this version?

have mac MojaveOS 10.14.3

Asked by Myk3y 1 year ago

Last reply by cor-el 1 year ago

Why would thumbnails not load from Youtube?

About 36 hours ago when I went to Youtube, the list of recommended videos loaded, but none of them had a thumbnail image. Mousing over individual clips resulted in the br… (read more)

About 36 hours ago when I went to Youtube, the list of recommended videos loaded, but none of them had a thumbnail image. Mousing over individual clips resulted in the brief preview as usual. Going to individual subscribed channels, the first few rows of clips had thumbs, the others didn't. Removing addons did not improve this situation, nor did refreshing FF. The issue also occurs on MS Edge, but not on Chrome or Brave. dL

Asked by Dale_Latimer 4 weeks ago

Last reply by McCoy 3 weeks ago

  • Archived

How can I start two FF instances under two Windows accounts at once w/o -no-remote? I need to be able to send URLs to them.

I have one FF (36.0) installation and two Windows user accounts: one for work (w/o internet access but with access to domain resources like JIRA) and one for internet acc… (read more)

I have one FF (36.0) installation and two Windows user accounts: one for work (w/o internet access but with access to domain resources like JIRA) and one for internet access (w/o access to local resources). I need two instances of FF running at the same time with different resources. I've created profiles with different names under both accounts and specify profile names using -p parameter. However when I try to start both instances of FF (second one is started via RUNAS), second instance can't be started, new tab in already running instance is opened instead:

firefox.exe -p profile runas.exe /profile /savecred /user:user_i "\"firefox.exe\" -p profile_i"

When I start one of them with -no-profile, I can start both at once... but when I try to execute firefox.exe with an URL in order to open a tab with this URL in one of running instances (local URLs I open by starting firefox.exe under work account and remote URLs I open by starting FF via RUNAS), it can't sent URL to already running instance of same user, it always sends URLs to an instance that is runnung w/o -no-remote.

firefox.exe -p profile -url "url" runas.exe /profile /savecred /user:user_i "\"firefox.exe\" -p profile_i -url \"url\""

So, I need to have two instances under two different Windows user accounts, and when firefox.exe is started again, it should only communicate with instance that is running under same user account, it must not communicate with instance that is running under different Windows account.

Asked by MVV_ 5 years ago

Last reply by cor-el 5 years ago

  • Archived

Firefox crashes on startup

Firefox crashes on startup and does the same in safe mode. I tried downloading the latest version and deleting Library Application Support files, but it does the same. It… (read more)

Firefox crashes on startup and does the same in safe mode. I tried downloading the latest version and deleting Library Application Support files, but it does the same. It must be a user setting of some sort because I can create another Mac user account and Firefox opens fine.

This is a new machine running Mac OS 10.14.2 and I've not been able to use Firefox yet. The only terminal settings I've changed, from what I can recall, is to help with font smoothing (https://ahmadawais.com/fix-macos-mojave-font-rendering-issue/) and messing around with dark mode (option to be in dark mode but only for dock & menu bar). I'm unsure if those settings are related but thought I'd mentioned it. Other than that this is a pretty much brand new machine.

Crash ID: bp-69fee8d8-a9c0-45fb-aa60-257270190123

AdapterDeviceID: 0x3e9b AdapterVendorID: 0x8086 BuildID: 20190108160530 ContentSandboxCapable: 1 ContentSandboxLevel: 3 CrashTime: 1548252669 DOMIPCEnabled: 1 Email: derekalong@gmail.com FramePoisonBase: 9223372036600930304 FramePoisonSize: 4096 InstallTime: 1548252096 MozCrashReason: MOZ_CRASH(Using observer service off the main thread!) Notes: FP(D00-L1000-W00000000-T000) WR? WR- OMTP? OMTP+4 GL Layers? GL Context? GL Context+ GL Layers+ ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384} ProductName: Firefox ReleaseChannel: release SafeMode: 0 SecondsSinceLastCrash: 518 StartupCrash: 0 StartupTime: 1548252669 TelemetryEnvironment: {"build":{"applicationId":"{ec8030f7-c20a-464f-9b0e-13a3a9e97384}","applicationName":"Firefox","architecture":"x86-64","buildId":"20190108160530","version":"64.0.2","vendor":"Mozilla","displayVersion":"64.0.2","platformVersion":"64.0.2","xpcomAbi":"x86_64-gcc3","updaterAvailable":true},"partner":{"distributionId":null,"distributionVersion":null,"partnerId":null,"distributor":null,"distributorChannel":null,"partnerNames":[]},"system":{"memoryMB":8192,"virtualMaxMB":null,"cpu":{"count":12,"cores":6,"vendor":"GenuineIntel","family":6,"model":158,"stepping":10,"l2cacheKB":256,"l3cacheKB":12288,"speedMHz":3200,"extensions":["hasMMX","hasSSE","hasSSE2","hasSSE3","hasSSSE3","hasSSE4_1","hasSSE4_2","hasAVX","hasAVX2","hasAES"]},"os":{"name":"Darwin","version":"18.2.0","locale":"en-US"},"hdd":{"profile":{"model":null,"revision":null},"binary":{"model":null,"revision":null},"system":{"model":null,"revision":null}},"gfx":{"D2DEnabled":null,"DWriteEnabled":null,"ContentBackend":"Skia","adapters":[{"description":null,"vendorID":"0x8086","deviceID":"0x3e9b","subsysID":null,"RAM":null,"driver":null,"driverVersion":null,"driverDate":null,"GPUActive":true}],"monitors":[{"screenWidth":2560,"screenHeight":1440,"scale":1}],"features":{"compositor":"none","gpuProcess":{"status":"unused"},"wrQualified":{"status":"blocked"},"webrender":{"status":"opt-in"}}},"appleModelId":"Macmini8,1"},"settings":{"blocklistEnabled":true,"e10sEnabled":true,"e10sMultiProcesses":4,"telemetryEnabled":false,"locale":"en-US","update":{"channel":"release","enabled":true,"autoDownload":true},"userPrefs":{"browser.search.widget.inNavBar":false},"sandbox":{"effectiveContentProcessLevel":3},"addonCompatibilityCheckEnabled":true,"isDefaultBrowser":null},"profile":{}} ThreadIdNameMapping: 6:"Gecko_IOThread",7:"Timer",8:"Socket Thread",9:"JS Watchdog",16:"JS Helper",11:"JS Helper",12:"JS Helper",13:"JS Helper",15:"JS Helper",17:"JS Helper",10:"JS Helper",14:"JS Helper",20:"Cache2 I/O",21:"Cookie",23:"GMPThread",24:"Compositor",25:"ImgDecoder #1",26:"ImageIO",27:"IPDL Background",29:"DOM Worker",46:"StyleThread#1",45:"StyleThread#0",47:"StyleThread#2",48:"StyleThread#3",50:"StyleThread#5",49:"StyleThread#4",48:"ImageBridgeChild",49:"ProcessHangMon",52:"StreamTrans #41", Throttleable: 1 UptimeTS: .74215417 Vendor: Mozilla Version: 64.0.2 useragent_locale: en-US

This report also contains technical information about the state of the application when it crashed.

Asked by derekalong 1 year ago

Last reply by FredMcD 1 year ago

  • Archived

Hard reboot caused profile loss

I had to hard-reboot my Windows machine, and when I launched Firefox (Developer Edition) upon after boot, my profile was lost. I had to set up Firefox Sync again, browse… (read more)

I had to hard-reboot my Windows machine, and when I launched Firefox (Developer Edition) upon after boot, my profile was lost. I had to set up Firefox Sync again, browser toolbar settings were reset, extensions were present but all their data was wiped, my session was lost (except oddly for pinned tabs). Windows didn't show any chkdisk activity during boot (looked like a clean boot). I wasn't prompted to create a new profile, so it appears the profile directory still existed. I don't understand what happened, or how I can even diagnose the issue.

Asked by keeganwitt 1 year ago

Last reply by cor-el 1 year ago

  • Archived

After upgrade to Windows 10 Versions 1809 or 1903, hotlinks from Windows 10 Mail app no longer open default browser Firefox except in background.

Hi all. I rely on quick opening of hyperlinks from Windows 10 Mail app to answer Microsoft Community forums questions in FIrefox, which is set as my default Browser, and… (read more)

Hi all. I rely on quick opening of hyperlinks from Windows 10 Mail app to answer Microsoft Community forums questions in FIrefox, which is set as my default Browser, and has defaults set for http and https protocols. When I upgraded to both Windows 10 Version 1809 and later to 1903, Firefox stopped opening on it's own and instead opens a new tab every time I click the link in the background. I have to click it's taskbar shortcut to open it.

These hotlinks still work correctly in Edge and CHrome but I need Firefox for managing my Bookmarks collection to easily drag them into help posts which isn't easily done in the other browsers.

Appreciate any help.

Asked by GregCarmack 1 year ago

Last reply by jscher2000 1 year ago

  • Archived

Cant find profile. Can I delete and reinstall?

Tried to refresh Firefox. After, I tried to open and it said, "Your Firefox profile can not be loaded. It may be missing or is inaccessible." After several tires, I move… (read more)

Tried to refresh Firefox. After, I tried to open and it said, "Your Firefox profile can not be loaded. It may be missing or is inaccessible." After several tires, I moved Firefox to the trash and tried to reinstall. I got the same window again. Help, please. Thank you. I'm using a MAC v.10.12.6, if that helps.

Asked by flcwoods 2 years ago

Last reply by Shadow110 2 years ago

Firefox keeps turning "cookies.sqlite" into .bak since it updated to version 74.0

Immediately after updating to version 74.0, I noticed Firefox had logged me out from all sites I usually am automatically logged into at the start of a session. It was n… (read more)

Immediately after updating to version 74.0, I noticed Firefox had logged me out from all sites I usually am automatically logged into at the start of a session. It was not the first time I encountered this problem, as it had been happening at irregular intervals, and found that it was caused by firefox replacing the "cookies.sqlite" file in my profile folder with a new one, while also dubbing the old one "cookies.sqlite.bak". I always resolved the problem by:

-Closing Firefox

-Deleting the recently created "cookies.sqlite" in my profile folder

-Renaming "cookies.sqlite.bak" into "cookies.sqlite"

-(Usually) Creating a copy of the .bak file and keeping it in a folder as insurance, in case I found no recent .bak the next time it happened or it got corrupted somehow

After doing this, upon starting firefox I would find all my cookies in place and myself logged in all sites I cared about (I set it up so that firefox restores a long-running, multi-windowed session at startup).

On a side note, I was always able to know whether my "cookies.sqlite" file had been rewritten by checking its size: if it had been just created, it would always be 512 Kb; the backup .bak file is instead 1.50 Mb.


Onto the problem at hand: after updating to 74.0 and finding that I lost all cookies and logins, I repeated the process highlighted above, as usual. It didn't resolve the problem though: I still didn't recover any cookie even though I switched the "good" .bak file with the newly created "cookies.sqlite". Upon starting firefox, instead of loading my 1.50 Mb .sqlite it keeps immediately renaming it .bak and creating its own cookies.sqlite. I even tried using a slightly older .bak, one that I had successfully switched before: the result was the same.

I am at my wits' end: I checked and tried various cookie and privacy settings, but since firefox updated it seems determined to shun my old cookie backup in favor of creating its own empty, useless file. There also doesn't seem to be any recent documentation on this problem I can find. I even considered opening and checking both .sqlite and .bak files for any obvious differences, but I'm afraid I just don't know how.


Those cookies are critical for my navigation. "Major Annoyance" wouldn't even begin to describe starting a session without those.

Asked by chibi95 2 months ago

Last reply by jscher2000 2 months ago

  • Archived

Firefox consuming more than 100% of CPU time

I have both Firefox and Dev edition on my notebook in a Windows 7 OS, and use the Firefox one as don't remembering history, while Dev edition remembers history. Both were… (read more)

I have both Firefox and Dev edition on my notebook in a Windows 7 OS, and use the Firefox one as don't remembering history, while Dev edition remembers history. Both were updated to the latest version, 63.0b8 (64bit), few days ago, and were running smoothly until yesterday when while running it with 3 tabs suddenly the notebook stopped, and I couldn't do anything as couldn't even move mouse, so after few minutes I could open the Task Manager and find out that the 3 Firefox processes were consuming like 110% of CPU, so took like 10min for the processes to go down and finally I could see that Firefox was really consuming such CPU processing time, so I uninstalled both versions, and re-installed then again, and then seems problem was still happening with high CPU usage, so I tried to install the previous 63.0b7 version and always it was updated automatically to the 63.0b8 version, even that on Options I kept the manual update. As during the re-install of both versions I didn't see that it was using a different profile, then at the end, I lost the bookmarks I had in one profile, so now I can't run any previous version, as both Dev and normal edition always update automatically. Any chances to keep using older version and not this latest one ? thanks,

Asked by vanderlei1 1 year ago

Last reply by Shadow110 1 year ago

  • Archived

your firefox profile cannot be loaded. it may be missing or inaccessible - AD multiple profiles

I have a new ubunutu 16.04 machine which I recently connected to my workplace domain where multiple users login to the same machine with there workplace account names. Wh… (read more)

I have a new ubunutu 16.04 machine which I recently connected to my workplace domain where multiple users login to the same machine with there workplace account names. When a user login to the machine it logins successfully but when try to open firefox get this message

your firefox profile cannot be loaded. it may be missing or inaccessible

I tried some suggested solutions:

sudo chmod -R 777 .mozilla/ rm -rf ~/.mozilla/ rm -rf ~/.cache/mozilla/ https://askubuntu.com/a/314915/304905

I tried all these but nothing worked. I wonder how I can fix this permanently from my machine local admin account so that when a new user logins to the machine for the first time firefox works without problems and without him having to do something?

Asked by fcis 1 year ago

Last reply by cor-el 1 year ago

  • Archived

Why do I get 'choose your profile'?

I keep getting a pop-up window telling me to 'choose your profile'. Then I lose my bookmarks. I've tried to asking this question & following instructions to recover m… (read more)

I keep getting a pop-up window telling me to 'choose your profile'. Then I lose my bookmarks. I've tried to asking this question & following instructions to recover my bookmarks. Is there anyone who will walk me through this? I'm not a techie & may cause myself more problems by trying to correct what's wrong. Please help me.

Asked by dopom9 3 years ago

Last reply by FredMcD 3 years ago

  • Archived

Every time I update Firefox, my entire browsing history is deleted.

I've tried 3 different updates (including the latest) now and it happens every time. I have to use time machine to go get my firefox profile back. How can I avoid this?… (read more)

I've tried 3 different updates (including the latest) now and it happens every time. I have to use time machine to go get my firefox profile back.

How can I avoid this?

Im running 49.0.2 on Mac 10.10.5

thanks!

Asked by djdunks 3 years ago

Last reply by FredMcD 3 years ago

  • Archived

firefox won't load; profile manager doesn't load either

My Firefox stopped opening. I tried entering the profile manager, but it says it is not available. Firefox is still shown in my installed programs. What's my next step?… (read more)

My Firefox stopped opening. I tried entering the profile manager, but it says it is not available. Firefox is still shown in my installed programs. What's my next step?

Asked by blgl109 2 years ago

Last reply by Shadow110 2 years ago

  • Archived

Profile Missing - Your Firefox profile cannot be loaded. It may be misscing or inaccessible

Hello, I can't open my Firefox, it says: Profile Missing - Your Firefox profile cannot be loaded. It may be missing or inaccessible. I already followed this manual: https… (read more)

Hello, I can't open my Firefox, it says:

Profile Missing - Your Firefox profile cannot be loaded. It may be missing or inaccessible.

I already followed this manual: https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible I changed profiles.iniOLD, and the folder Firefox, but it doesn't work.

Also I tried to acces the User profiles by Mac's Terminal according to this manual: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles But when I typed the code /Applications/Firefox.app/Contents/MacOS/firefox-bin -P it open's Firefox with the same error: Profile Missing - Your Firefox profile cannot be loaded. It may be misscing or inaccessible

Is there a solution to fix this? I also reinstalled Firefox, but same error.

Asked by Cicero83 1 year ago

Last reply by the-edmeister 1 year ago

  • Archived

Update made all history and passwords disappear. How to undo?

So a while back, like many people, I encountered the issue where I downloaded the cutting-edge Firefox in an attempt to get my extensions back during the failure. Then I … (read more)

So a while back, like many people, I encountered the issue where I downloaded the cutting-edge Firefox in an attempt to get my extensions back during the failure. Then I realized that none of my stuff carried over, and I panicked to re-install the original to get my stuff back.

(To clarify, "stuff" encompasses history, previous sessions, cookies, saved login credentials, and the like. My sessions are...quite large, admittedly, so I crash often.)

So tonight, it crashed again while I was trying to respond to someone on a chat client. I hit restore previous session as normal. Then the update window showed. No harm done there.

Except then it gave me the dead basic, on-install new tab screen. Checking revealed no history, no cookies or password retained, and an inability to rez my previous session.

As a uni student during summer with a lot to book, this is a major issue.

And while I have attempted to look for Old Firefox Files, they remain elusive.


Fair to note: I use Windows 10 on a bone-average Lenovo laptop.

Asked by Arrowtie 1 year ago

Last reply by FredMcD 1 year ago

  • Archived

I use a session manager, it was working fine. But now i have a problem - in a series of events my sessions became unavailible. Each time I have an error.

It's a long story, but to put it simply - I can't recover my sessions. Each time I do it a have an error - with each session, either backuped or saved. I know it's not to… (read more)

It's a long story, but to put it simply - I can't recover my sessions. Each time I do it a have an error - with each session, either backuped or saved.

I know it's not totally your profile, but if you can help me with this one - please do. I had encountered those earlier, but each time i had older backups that worked. Now I don't - and I have no other means to save my data. Please help me.

Each time I get this error log: (first line is translated from russian, but I guess it is pretty clear)

-Data on the session / window damaged:
JSON.parse: expected ',' or '}' after property value in object at line 1 column 11923 of the JSON data(SyntaxError)

this.Utils.JSON_decode@chrome://sessionmanager/content/modules/utils.jsm:713:16
Private.modifySessionData@chrome://sessionmanager/content/modules/session_data_processing.jsm:295:12
Private.restoreSession@chrome://sessionmanager/content/modules/session_data_processing.jsm:136:12
this.SessionDataProcessing.restoreSession@chrome://sessionmanager/content/modules/session_data_processing.jsm:36:10
Private.restoreSession/aWindow.__SM_restore/<@chrome://sessionmanager/content/modules/session_data_processing.jsm:128:6
this.Utils.runAsync/runnable.run@chrome://sessionmanager/content/modules/utils.jsm:665:5

Asked by Kagestorn 5 years ago

Last reply by guigs 5 years ago

  • Archived

Install fail. Says it can not find profile?

during a firefox refresh the process failed and firefox no longer worked. I did an uninstall so I could do a fresh install. All attempts to install fresh fail saying "p… (read more)

during a firefox refresh the process failed and firefox no longer worked. I did an uninstall so I could do a fresh install. All attempts to install fresh fail saying "profile" could not be located. So now I have nothing. All my data is missing. I do have a copy of the profile folder, but after the uninstall was performed? contacts, bookmarks, passwords and such all missing ;-( Please help.

Asked by ibbolton 1 year ago

Last reply by cor-el 1 year ago