Showing questions tagged: اعرض كل الأسئلة

Firefox takes 10+ times longer to load websites than Edge or Chrome

I'm at my wits end. I've tried every fix I could find and Firefox is dramatically slower then Edge or Chrome. This happens with loading sites, like Amazon. Also, it of… (read more)

I'm at my wits end. I've tried every fix I could find and Firefox is dramatically slower then Edge or Chrome. This happens with loading sites, like Amazon. Also, it often locks up/stops when typing (like right now) and it takes about 15 seconds for it to repond again.

First, I doubt it's a hardware or network issue, since it's happened on both my old archaic PC and now on my new PC (i9 CPU, Nvidia 2070 graphics card, 64gb RAM).

Here's some highlights of what I've tried so far: • Refreshing multiple times • Rebooting the PC • Doing all the Quick Tips on this website • Eliminating all extensions • Clearing all cookies and cash • ...

Also, I don't get any error codes. The tab icon just spins for a long time.

I'm hoping I'm missing something obvious, since I love Firefox.

Thanks and any help!

Asked by Olliesshop 2 weeks ago

Last reply by Olliesshop 3 days ago

I have updated my O/S from Ubuntu 18.04 to 20.10. Nothing else. Now Firefox is nearly useless

This is basically a copy of what I put in the Ubuntu forum. The problem is the same, no matter where I post it. Originally I was using Ubuntu 18.04 LTS. I thought it woul… (read more)

This is basically a copy of what I put in the Ubuntu forum. The problem is the same, no matter where I post it.

Originally I was using Ubuntu 18.04 LTS.

I thought it would be good to update to GG (20.10) though I did briefly try FF (20.04).

As the install was done on an existing 18.04 version things remained the same for programs, book marks, etc.

Ok, now the crunch: I USE Firefox ""A LOT"". When it loads, there are...... 8 x 6 windows of FireFox and each of those have anywhere from one to ""THIRTY"" tabs loading.

Believe me: ""It worked!!""

I could use it, also run other tasks as well - though a VM was pushing it with the RAM. But the entire machine worked.

Now, I am lucky if FireFox loads at all. Let alone let me browse.

When it loads some of the window's tops are flashing. A screen shot does not really show this. (I tried)

All that has changed is the O/S from 18.04 and Firefox from (what ever it was) to 83.0

I don't want this to be a finger pointing exercise between Mozilla and Ubuntu. I would prefer it is helpful to all.

What have I tried? I've tried starting FireFox with all addons disabled. Still happens.

I am going to try to remember to (next time) launch FireFox from a Terminal and pipe the output to a file to look for things.

The machine I am using has shown it is well up to being able to have this running. I have had it working for a few years like this.

This post is (for now) to establish there is a problem. I will post more information when I get it, rather than waiting to get it then post, as I feel there are a lot of people who have very similar problems and I want it known: ""You are not alone!""


Now a bit of extra stuff.

Other things which are weird: When I am watching stuff - youtube for example - the playback is/WAS jerky. I hadn't touched anything in the settings.

After digging around, I discovered that I had to turn ""OFF"" the hardware acceleration for the graphics. Question: How did it get turned on? (Semi rhetorical)

I have a lot of local pages I open with passwords. When I load them the CPU load goes through the roof and nearly invariably the program just exits. No crash report.

Which is a good 50% of how it happens. The other 50% is the machine just locks up and I have to power it down.

Asked by teeny_weeny 2 days ago

Last reply by teeny_weeny 16 hours ago

speeding up Firefox

I clicked on a popup link from Firefox to speed up my browser. Came back to my computer and everything's gone, all my fast links that I had at the top of my screen, like … (read more)

I clicked on a popup link from Firefox to speed up my browser. Came back to my computer and everything's gone, all my fast links that I had at the top of my screen, like Facebook, Gmail, everything I've saved for quick links over the past 2 years. I want my computer back, just the way I had it. This is a nightmare. I'd much rather my browser run slow (it really wasn't running slow). I tried a system restore, but it didn't restore things the way I had them. Please, what do I do to reverse this nightmare, and please don't ever offer to speed up my browser again.

Asked by ginchinchili 3 days ago

Last reply by ginchinchili 2 days ago

Firefox opens previous tabs on startup even though this setting is turned off

Whenever I open Firefox it opens a new tab for a brief moment then closes it and opens my previous tabs from my last session. I have this setting unchecked in the setting… (read more)

Whenever I open Firefox it opens a new tab for a brief moment then closes it and opens my previous tabs from my last session. I have this setting unchecked in the settings. I think that it is crashing and trying to restore my pages because of that, but there are no crash reports when I visit about:crash. I am running the latest version of Firefox and windows 10.

Asked by Luke Shuttleworth 2 weeks ago

Last reply by Luke Shuttleworth 5 days ago

Anyway to disable "A script from the extension" "is running on this page"

I am getting sick of the message "A script from the extension...is running on this page" It relates to Adblock Plus which is the extension. I watch a YouTube video and th… (read more)

I am getting sick of the message "A script from the extension...is running on this page" It relates to Adblock Plus which is the extension. I watch a YouTube video and then this message comes up on another YouTube tab I have open and Firefox switches to that tab and ruins my watching the video I was watching.

Is there anyway of disabling the message from ever coming up? I increased the values in dom.max_script_run_time and dom.max_script_run_time_without_important_user_input which was a possible solution I read but that does nothing.

Asked by davebesag 1 week ago

Last reply by davebesag 2 days ago

Firefox Hanging Then Speeding

Hello, I'm a Windows 7 user. For the past 3 weeks my Firefox browser (83.0) has been slowing down and then speeding up while visiting sites. I tried Safe Mode, Refresh, … (read more)

Hello,

 I'm a Windows 7 user. For the past 3 weeks my Firefox browser (83.0) has been slowing down and then speeding up while visiting sites. I tried Safe Mode, Refresh, and Reinstall but nothing seems to help. It's not being caused by anything on my computer (malware, viruses, etc) because I ran several scans using Malwarebytes Premium, CCleaner Premium, Microsoft Security Essentials, even Microsoft Safety Scanner and nothing turns up.
 Is there any other way to fix this issue on the browser?

Asked by purpledove 1 week ago

Last reply by purpledove 4 days ago

Problem - the "sub-window" prompts in FireFox Browser

Hello, The problem that occurs to me can be seen at the picture in the attachment. I have cleaned cash and cookies, but it did not solve the problem. Any idea how to sol… (read more)

Hello,

The problem that occurs to me can be seen at the picture in the attachment. I have cleaned cash and cookies, but it did not solve the problem. Any idea how to solve this??

Asked by mica_lekic 5 days ago

Last reply by mica_lekic 4 days ago

Firefox crashing frequently with Mozilla Crash Reporter

Firefox has been crashing daily. Need to reinstall every time it crashes. Have tried different versions of Firefox but it still crashes. The latest Crash ID: bp-aea83dc… (read more)

Firefox has been crashing daily. Need to reinstall every time it crashes. Have tried different versions of Firefox but it still crashes.

The latest Crash ID: bp-aea83dc4-ed3d-4298-8686-b149b0201126

Would appreciate help in fixing the problem. Thanks!

Asked by yuenhome 5 days ago

Last reply by yuenhome 5 days ago

Firefox - Frequent, frustrating hangs and lockups on new PC

I was lucky enough to be able to buld a new PC recently, Running Windows 10 Pro on a AMD Ryzen 9 5900X rig, Asus Crosshair VII Hero motherboard and 32gb of RAM. Nvidia Gf… (read more)

I was lucky enough to be able to buld a new PC recently, Running Windows 10 Pro on a AMD Ryzen 9 5900X rig, Asus Crosshair VII Hero motherboard and 32gb of RAM. Nvidia Gforce 1070 GPU (stand in until I can get better in the new year) Should easily be enough to run Firefox right? Apparently not.

Performance in Firefox is little better than it was on my old rig, (which was still lousy). The browser constantly freezes and locks up, not responding at all to mouse clicks between tabs or on the page. It is especially common when a website opens a file requester, such as when I'm working on my website in Wordpress, but it also happens when working with downloads or seemingly randomly too (my downloads folder is on the C drive and always accessble).

I've tried disabling all plugins (I only have 3, Privacy Badger, Facebook container and Sticky Password), I don't see what point there is in resetting the profile as I only got this computer 3 days ago.

Regards software that might conflict, I run Malwarebytes anti-malware and DisplayFusion but I've tried disabling the latter and still no joy.

I really don't want to Chrome but it's leaving me little choice here. Is there anything else I can try? Thunderbird on the same PC works perfectly.

Asked by matthewab20011 7 hours ago

Last reply by matthewab20011 2 hours ago

Slow Firefox for Deasktop!!!!!!!!!!

Hello, Can you tell me what happen with your browser in around last 1 year? My internet connection is: Download~1000 Mbps,Upload~600 Mbps. See attached photo what is my … (read more)

Hello, Can you tell me what happen with your browser in around last 1 year? My internet connection is: Download~1000 Mbps,Upload~600 Mbps. See attached photo what is my internet,when i test it with different browsers which i have installed on my PC. See what is the statistic for Firefox O.O WTF? I like your browser and use it from very long time,but if will it crash my connection,i will forget for it! Do something!

Asked by Angel Of Death 2 days ago

Last reply by Angel Of Death 2 days ago

sound when using firefox

Hi The other day i was watching a movie on Viaplay. I paused it, and when i started it again, there was no sound. Ive tried other websites, to see if there is any sound,… (read more)

Hi The other day i was watching a movie on Viaplay. I paused it, and when i started it again, there was no sound. Ive tried other websites, to see if there is any sound, but sadly no. Ive tried other browser, and there the sound works just fine.

ive tried reinstall mozilla, and seached for solutions, but cant get any answers.

Please is there som tec guru, that can help me

Best reggards

Michael

Asked by michael_sandberg87 6 days ago

Last reply by michael_sandberg87 5 days ago

Firefox keeps logging out me from all accounts

Since about a week Firefox logs me out of all accounts when I close the browser. I checked the many threads here and have done everything including: Made sure it's not pr… (read more)

Since about a week Firefox logs me out of all accounts when I close the browser. I checked the many threads here and have done everything including: Made sure it's not private browsing Made sure the history is not set to clear at exit Cookie settings are in default mode Remember history is on This problem started without me changing any settings on the browser. But I did a fresh install too, and that after clearing the Appdata too so that the install is absolutely fresh. It still continues. Facebook, Gmail, Yandex, and all other accounts are autocratically logged off which is absolutely frustrating. Can any Firefox developer please find a solution beyond "make sure the .... " etc. ?

Asked by dapokerista 2 days ago

Last reply by dapokerista 19 hours ago

Setting `delete cookies and site data when firefox is closed`

For our website we de use OAuth2 to login. For this to succeed we need to store some data in de localstorage or sessionstorage. But the data in the storage is cleared whe… (read more)

For our website we de use OAuth2 to login. For this to succeed we need to store some data in de localstorage or sessionstorage. But the data in the storage is cleared when we redirect back from our authenticator. This only happens when `delete cookies and site data when firefox is closed` is checked.

We are not closing Firefox, we are only redirecting the between two different domains. Is this intended?

Asked by joepheijnen1994 1 day ago

Last reply by joepheijnen1994 16 hours ago

Bluetooth headsets continuously toggling call mode when using microphone

In recent weeks, calls with audio have become buggy in Firefox. Whenever I engage in a call that accesses the microphone while I have a bluetooth headset connected, the h… (read more)

In recent weeks, calls with audio have become buggy in Firefox. Whenever I engage in a call that accesses the microphone while I have a bluetooth headset connected, the headset starts continuously toggling call mode on and off for an extended duration. This can be anywhere from 10 seconds/3ish toggles to never-ending (meaning I got tired of waiting after about 3 minutes/55ish toggles).

Today I finally decided to debug further. Here are my findings:

  • Problem only exists in Firefox. I tested with Safari, Chromium, Slack and Discord, with no trouble presenting itself in any of them
  • Problem relates to all bluetooth headsets. I have tested with Sennheiser Momentum 2 Wireless and Steelseries Arctis Pro Wireless, with both exhibiting the problem in Bluetooth mode. If I have no bluetooth headsets connected, the problem does not present itself. There is also no problem if I connect the Arctis using the wireless base station (which in turn is connected to the laptop by USB) instead of bluetooth. Using the base station, call and non-call are exposed to my mac as different/simultaneous channels — this may have something to do with it.
  • Problem persists with hardware acceleration toggled off
  • Problem persists in safe mode
  • Problem persists in private mode
  • Problem persists both on Whereby.com and Discord.com. On Whereby, it also interferes with the camera. This leads me to believe it might have something to do with WebRTC, as I think both websites use it.
  • Problem persists after reinstalling Firefox
  • On a possibly related note: if I end the voice chat session after it has stabilised, call mode toggles off slowly and always sends a "start playing media" signal to my Mac, even if it didn't pause anything when toggling call mode on.

In sum, this leads me to believe there is some sort of bug in Firefox causing this, but the lack of other topics on here with the same problem makes me skeptical. I am open to any suggestions with regards to further testing I can do. This is obviously very annoying, and I would like to have bluetooth calls working again.

Asked by Lemonous 9 hours ago

Last reply by Lemonous 3 hours ago

Firefox takes over 30 seconds to load a tab that I've already opened and seen before

Firefox takes over 30 seconds to load a tab that I've already opened and seen before. I mean tabs that have already displayed some content, I switch to a tab, then go ba… (read more)

Firefox takes over 30 seconds to load a tab that I've already opened and seen before.

I mean tabs that have already displayed some content, I switch to a tab, then go back to the tab I was previously on, and it takes over 30 seconds to load, sometimes over 3 minutes. This is making firefox unusable.

And because it doesn't happen all the time, it's not very reproducible for me, but it happens often. Is there a way to fix this?

Asked by desbest 1 month ago

Last reply by desbest 6 days ago

Realms (protected directory), FF 83.0, OSX 10.14.6

Since the update, I'm unable to access ANY protected directories on any sites (those where a small modal dialog box appears at the top of the page asking for a uid/pwd pa… (read more)

Since the update, I'm unable to access ANY protected directories on any sites (those where a small modal dialog box appears at the top of the page asking for a uid/pwd pair and displaying the name of the realm above that). The dialog box doesn't even appear, the page does not change from its previous location, and the "I'm thinking" animation in the tab continues forever without ever seeing an error message.

Any suggestions? Must I downgrade? (uck)

Asked by buggyisalreadytaken 1 week ago

Last reply by buggyisalreadytaken 5 days ago

Firefox makes system volume reduce to 50% when Tidal is playing music on Windows 10.

Firefox makes system volume reduce to 50% when Tidal is playing music on Windows 10. I can see this happening through the system mixer, activated via the icon in the lowe… (read more)

Firefox makes system volume reduce to 50% when Tidal is playing music on Windows 10. I can see this happening through the system mixer, activated via the icon in the lower right hand corner of the screen.

I am using a Steinberg UR22 mkII USB interface, but the behavior happens across all sound outputs.

Going into the properties of the USB device have proved unsuccessful.

Firefox does not trigger this behavior with other applications playing through the USB device. I'm wondering if there is some sort of setting left over from when I had Firefox Voice enabled?

A fresh install of Firefox did not do the trick. This happens with all sound outputs on Windows 10, not just through the USB device.

Does anyone have any ideas/solutions?

Asked by andrew124 6 days ago

Firefox crashing and breaking into pieces

In the last couple of weeks, when I start a game (RoyalGames.com) that uses adobe flash, Firefox goes haywire and starts breaking into pieces (the whole browser). Usuall… (read more)

In the last couple of weeks, when I start a game (RoyalGames.com) that uses adobe flash, Firefox goes haywire and starts breaking into pieces (the whole browser). Usually I can shut it down but tonight it crashed my whole system, my monitor went black, but the sound was still working. I had to manually shut down. I was able to get a screen shot of it before it completely crashed. See pic. The image should be an orange box with a black border but it's all broken into pieces. The games work fine on Chrome and Internet Explorer. A couple days ago I did a Windows refresh and just installed Firefox fresh but it still happens. Anyone have any ideas what would cause this? Thank you.

Asked by Jeanne 6 days ago