Showing questions tagged: اعرض كل الأسئلة

firefox private mode language error

I use firefox on fedora 38 and after update firefox about a month ago . i got this error when use private mode ,for thai languge it just error but in normal mode it ok . … (read more)

I use firefox on fedora 38 and after update firefox about a month ago . i got this error when use private mode ,for thai languge it just error but in normal mode it ok .

Asked by SD SD 1 month ago

Last reply by zeroknight 1 month ago

extensions.json key

Hello I want to use extension xpi's from a shared external folder over multiple Linux profiles. So i examined the profile folder and found extensions.json. Though i can'… (read more)

Hello

I want to use extension xpi's from a shared external folder over multiple Linux profiles. So i examined the profile folder and found extensions.json. Though i can't find any documentation to it's keys online.

There's "rootURI:" with a "jar:file://path/to/extension.xpi!/", so i tried just replacing the path with the shared one. Though i observed that just makes firefox replace the path with the current one. So i examined further and found the "location:" key with the default value "app-profile". So my guess is, there's other values for other usecases, right?

So, in summary, what i need is:

  • documentation to extensions.json keys or possible values to "location" key.
  • if that isn't intended/doesn't work, how i can achieve my goal otherwise.

And please don't suggest the sync feature, that doesn't work for my usecase.

Asked by dani.priv+moz 1 month ago

Last reply by cor-el 1 month ago

  • حُلّت

Netflix Error - F7355-1203

Hi, I was using FF on Ubuntu 22.04.4 LTS. Had version FF 120.x and playing video in Netflix worked fine. Then I updated to FF 124.x and playing video stopped with error… (read more)

Hi,

I was using FF on Ubuntu 22.04.4 LTS. Had version FF 120.x and playing video in Netflix worked fine. Then I updated to FF 124.x and playing video stopped with error F7355-1203.

I've checked the DRM setting and it is enabled, I checked addons and I have OpenH264 and Widevine installed, both set to always active.

I've checked installed codecs and I do have libavcodec58 installed. No update for that available via apt. I also have ffmpeg installed, no problem with that either. I can play Netflix videos in Chrome, but not in Firefox now. Something happened to Firefox when I updated from 120.x to 124.x. Today I updated to 125.x, same problem, Netflix video won't play.

I've unchecked the DRM setting and re-checked it, and that does reinstalled Widevine but does not fix the problem.

Any ideas what could be the cause?

Asked by mark545 1 month ago

Answered by mark545 2 weeks ago

when can we have firefox with the translator switches OFF?

hi, When can we have firefox with translation set OFF by default? I mean, it's pretty unfair that intelligent people have to keep turning off the dumb translator... al… (read more)

hi,

When can we have firefox with translation set OFF by default?

I mean, it's pretty unfair that intelligent people have to keep turning off the dumb translator... all the time... We need a setting, openly available, in the Edit/Settings menu, where it belongs, an option to switch it off. In fact, when it first asks if we want a page translated, we need an option: never ask this again...

All we can see is "go under the hood of firefox, config:option, go into the about:config section where 10 of 10 million people will ever get... and there find your way to disable this horrible translator". When can we expect an option in the pop-up: "never ask me this question again"?

The translator in this offensive form has been around since 2023... I seems high time we didn't have to bother with this anymore...

Peter

- - - Thank you for developing firefox and keeping it intelligent - - -

Asked by jepe69 1 month ago

Last reply by cor-el 1 month ago

Popups still appear despite blocking

Hi, Some websites still managed to smuggle in popups despite all the blockings. I use as add-ons: privacy badger, no-script, ublock origin and recently tried popup block… (read more)

Hi,

Some websites still managed to smuggle in popups despite all the blockings. I use as add-ons: privacy badger, no-script, ublock origin and recently tried popup blocker (strict) and even have the 'block pop-up windows' enabled. I also tried to fiddle around in ´about:config´ but nothing helps. I think it's a recent occurrence as I don't remember having this problem, let's say, a couple of months ago.

The funny thing is that this problem doesn't occur in opera-browser (in which I hardly use extensions).

The websites that this occurs are: arabicpost.net (a pop-up will occur about 10 sec after right-clicking a new tab). focus.de (a video pop-up will occur if there's a video in it). Again opera-browser blocks all of this. I expect there will be other websites to add in the future.

Please help. S.O.S. -> g.o.i.n.g..i.n.s.a.n.e!

Asked by b.hawassa 1 month ago

Last reply by zeroknight 1 month ago

Unintended scroll to top of page

browsing website (reddit or amazon for example), the window scrolls to the top every time I move the mouse. doesn't happen all the time though, and only in Firefox. I've … (read more)

browsing website (reddit or amazon for example), the window scrolls to the top every time I move the mouse. doesn't happen all the time though, and only in Firefox. I've serached the internet and can't find anything related. Please help

Asked by myblackfrog 1 month ago

Last reply by zeroknight 1 month ago

mouse pointer

mouse pointer is nice size in general but becomes VERY small when I go into websites. this happens when i use either floorp or firefox but is fine when i use chrome( woul… (read more)

mouse pointer is nice size in general but becomes VERY small when I go into websites. this happens when i use either floorp or firefox but is fine when i use chrome( would rat5her not use google). i just don't see where I can fix this in Firefox settings

Asked by bill morin 4 weeks ago

Last reply by zeroknight 4 weeks ago

What and where is my Security Key and how do I touch it?

Please see the attached image. Firefox believes I have a security key. What is a security key? Where do I find it? Why does Firefox think I have one? And why is the… (read more)

Please see the attached image.

Firefox believes I have a security key.

What is a security key? Where do I find it? Why does Firefox think I have one?

And why is there no helpful information to explain this confusing UX?

Asked by kurrent93 1 month ago

Last reply by zeroknight 1 month ago

  • حُلّت

Firefox browser starts flickering when maximized and when the theme is dark.

Hello, I'm using samsung odyssey g7 32' monitor connected to my laptop with a rtx 2060. The monitor is connected with a minidisplay port to display port cable. The proble… (read more)

Hello, I'm using samsung odyssey g7 32' monitor connected to my laptop with a rtx 2060. The monitor is connected with a minidisplay port to display port cable. The problem doesn't occur on the laptop screen but it does on the samsung screen. The flickering stops when i make the window a little smaller. I am using KDE plasma 6.0.3 but the problem was also present when i was using Hyprland as my desktop enviroment. I tried troubleshoot mode but nothing changed. I am seeking help. Thanks.

Asked by ersandemircan57 1 month ago

Answered by jonzn4SUSE 1 month ago

  • حُلّت

Security Concerns: Saved forms (across VMs) and password (after clearing all history).

v155.9.1esr Debian 12 I'm testing different Debian 12 on multiple VMs, it came to my surprise to see that my VPN hash I used on a website the day before was saved by Fir… (read more)

v155.9.1esr Debian 12

I'm testing different Debian 12 on multiple VMs, it came to my surprise to see that my VPN hash I used on a website the day before was saved by Firefox on the new VM.

The Sync was on but then which one saved my form (hash)?

  1. Numbered list item Logins & Passwords ? note: The hash was not a login but a form. If Firefox saves all the form, you should explicitly rename Logins by any forms/inputs.
  2. Numbered list item History? note: I hope this is only URLs.

If Firefox is savings "forms" (input fields) not just "logins" then it should be explicitly written. Is it an expected behavior?

Asked by debvmtesting 1 month ago

Answered by cor-el 1 month ago

  • حُلّت

Video without sound on some sites but work on another

I have: 125.0 (64-bit) Mozilla Firefox for Ubuntu canonical - 1.0 Video on Facebook plays without sound. The video plays, I see the image normally, but no sound. Video … (read more)

I have:

125.0 (64-bit) Mozilla Firefox for Ubuntu canonical - 1.0

Video on Facebook plays without sound. The video plays, I see the image normally, but no sound. Video on Youtube works perfectly.

Fresh install without addons or plugins. Switching to "Troubleshoot mode" does not change anything. Youtube with sound, Facebook without sound.

Any ideas where to look?

Asked by George Brink 1 month ago

Answered by cor-el 1 month ago

  • حُلّت

Arrow keys not working like normal

Twice in the past 2-3 weeks I have had to restart the computer, Linux Mint 21.2 Firefox 124(when updated in the past couple of days), due to the mouse freezing up and not… (read more)

Twice in the past 2-3 weeks I have had to restart the computer, Linux Mint 21.2 Firefox 124(when updated in the past couple of days), due to the mouse freezing up and not being able to move the mouse on the screen. That's not the current problem, but it might help direct things to the final solution.

After the most recent reboot last night now I'm having a rather problem. The up/down arrow keys are no longer scroll me up and down a webpage like they always have in the past. Instead of doing smooth scrolling like they always use to, now they are scrolling me up and down the links on a web page. For example, if I were to be on youtube it would first want to scroll me down the left side links before taking me through each and every video link, when the page goes to load in more videos than it wants to go back and scroll me down the left side links again. It acts like it is taking me through the html code, line by line, instead of scrolling me smoothly down the webpage. The only way I can scroll smoothly down the webpage is to use the mouse on the scrollbar on the right side. It does this both in normal mode and in Troubleshooting Mode.

I have checked and beret scrolling is false as well as beret_shortcut. Use autoscrolling, use smooth scrolling, show scrollbars and always underline links are all clicked on. Always use the cursor keys to navigate within pages is unclicked. I have tried different changes between clicking on and unclicking those options with no change being noticed.

How can I get this back to the way it used to run?

Asked by nayrdrofwarc 1 month ago

Answered by nayrdrofwarc 1 month ago

Firefox no longer warns about vulnerable passwords?

On the page listing passwords, it was possible to sort them by "Alerts". In settings, there is an option to enable checking the vulnerable passwords: https://support.moz… (read more)

On the page listing passwords, it was possible to sort them by "Alerts".

In settings, there is an option to enable checking the vulnerable passwords: https://support.mozilla.org/en-US/kb/firefox-password-manager-alerts-breached-websites

On my other laptop using Firefox v121, the alerts are properly displayed. But on my second laptop using Firefox v124, the alerts are gone. I can't sort password by "Alerts", the option isn't there. Both laptops share the same Firefox account and have password synchronized between each other.

Obviously, I ticked the "Show alerts about passwords for breached websites" box in the settings but it looks like it does not nothing. I also checked in "about:config" and everything seems good.

Is this feature gone?

Asked by ADGB 1 month ago

Trouble printing with Epson POS TM-T20 Thermal Printer

I am unable to get printing to work correctly using Firefox with Epson POS TM-T20 thermal printers we have a work. We're currently running Firefox on Debian 12. I've … (read more)

I am unable to get printing to work correctly using Firefox with Epson POS TM-T20 thermal printers we have a work.

We're currently running Firefox on Debian 12. I've tried both the ESR version that comes with the Debian repository and the latest Firefox as a flatpak.

When printing to the receipt printer, the only thing that is printed is the left-hand most part of the logo and a little part of the text and this occurs towards the right-hand side of the paper. I've changing all of the settings, resetting the settings for the print in about:config, but nothing seems to work.

I'd love to get this working so that staff could use Firefox. I'm attaching an image of what the print job looks like and a screenshot of what the print-preview shows.

Asked by Ron H. 4 weeks ago

Last reply by Ron H. 4 weeks ago

Videos automatically play after a short period of time after being paused (Ubuntu 22.04)

When I pause a video (any site) and go to another tab / stay on the site, after a seemingly random amount of time the video starts playing again. I'm using latest Firef… (read more)

When I pause a video (any site) and go to another tab / stay on the site, after a seemingly random amount of time the video starts playing again.

I'm using latest Firefox on Ubuntu 22.04 (snap).

I've tried (didn't work):

  • Disabling media hardware controls through about:config
  • Disabling autoplay through about:config

Asked by Pawel Len 1 month ago

Last reply by cor-el 1 month ago

Change Firefox filename pattern for Take Screenshots

Firefox can take screenshots of pages or screenshots of custom areas of pages. According to the documentation, when we download the image, the filename should follow the… (read more)

Firefox can take screenshots of pages or screenshots of custom areas of pages.

According to the documentation, when we download the image, the filename should follow the pattern: Screen Shot yyy-mm-dd at hh.mm.ss.png. If I use the :screenshot at the console, the pattern works as documented.

But Firefox is using a different pattern when I choose Take Screenshot from the context menu. The pattern includes the page's title. Example: Screenshot 2024-04-14 at 18-35-16 General ‹ Settings ‹ Geomaster Lda — WordPress.png.

Since the page title can have non common filename characters, I have problems with such filenames. My uploads to MediaWiki fails with such filenames. I know I can report or improve MediaWiki, but my question here is quite simple.

Can I change the Firefox's default pattern for Take Screenshot's downloads?

Asked by Jorge Gustavo Rocha 1 month ago

Last reply by jonzn4SUSE 1 month ago

  • حُلّت

Firefox displays the same name in the title bar for different profiles

In Linux Ubuntu I created 4 different launchers for 4 profiles. Firefox opens the different profiles correctly, but the name of Profile 4 is displayed in the title bar f… (read more)

In Linux Ubuntu I created 4 different launchers for 4 profiles.

Firefox opens the different profiles correctly, but the name of Profile 4 is displayed in the title bar for all windows. This causes confusion when I'm using the different profiles. Furthermore, the icon displayed in the icon bar is also the same for the 4 profiles, although I have configured a different icon for each profile. I ask for help as I need each instance to have its own name and icon displayed correctly.

The launchers look like this:

firefox-profile1.desktop: Name= Profile 1 Exec=firefox -P profile1 --no-remote Icon=~/.local/share/icons/profile1.png

firefox-profile2.desktop Name=Profile 2 Exec=firefox -P profile2 --no-remote Icon=~/.local/share/icons/profile2.png

firefox-profile3.desktop Name=Profile 3 Exec=firefox -P profile3 --no-remote Icon=~/.local/share/icons/profile3.png

firefox-profile4.desktop Name=Profile 4 Exec=firefox -P profile4 --no-remote Icon=~/.local/share/icons/profile4.png

Asked by Alex 1 month ago

Answered by Alex 4 weeks ago

Using the --new-tab and --search CLI options together doesn't work properly

When I use the `--search` CLI option, Firefox searches the supplied term in a new window. I want it to open itself in a new tab instead, so I tried out the following com… (read more)

When I use the `--search` CLI option, Firefox searches the supplied term in a new window.

I want it to open itself in a new tab instead, so I tried out the following combination of CLI options:

``` $ firefox --new-tab --search "example" ```

Firefox does search for the given term, but it opens itself in a new window instead of a new tab, thus ignoring the `--new-tab` option.

Am I doing something wrong?

Asked by wympo 3 weeks ago

Last reply by jscher2000 - Support Volunteer 3 weeks ago

Firefox Debian significantly slower page loads than Chromium Debian

Hello, have been scratching my head for a while on this one. Have a freshly setup install of Debian 12, using Sway (wayland) as my Window Manager. I am really struggling … (read more)

Hello, have been scratching my head for a while on this one. Have a freshly setup install of Debian 12, using Sway (wayland) as my Window Manager. I am really struggling with slowness in Firefox, page loads take easily 15 seconds whereas loading the exact same page in another window at the same time with Chromium Debian build has near instantaneous load times. I've tried the following troubleshooting steps: - Created a new firefox profile - Tried "Troubleshooting Mode" in Firefox - Disabled ipv6 in firefox about:config and in Debian - Tried different DNS servers - Tried different non-debian specific builds of Firefox - Tried Firefox Beta and Firefox Nightly for Debian

None of these steps made any difference, and Chromium has continued to be significantly faster. Am really stuck here and would love to get to the bottom of this as Firefox is the only browser that works with a HiDPI display in Sway without blurryness. Happy to provide any and all diagnostics and reports that are needed. Thanks in advance!

EDIT: It seems to be some kind of networking issue, using a VPN solves it. But still doesn't explain why Chromium would behave differently.

Asked by Samuel (+Uni) 1 month ago

Last reply by zeroknight 3 weeks ago

YouTube line spacing is broken on Firefox (but not on other browsers - eg Vivaldi)

For the last few months YouTube appears to have broken CSS and text in multi-line blocks is broken and overlaps. I'd guess this is only for text that auto line wraps. Th… (read more)

For the last few months YouTube appears to have broken CSS and text in multi-line blocks is broken and overlaps. I'd guess this is only for text that auto line wraps. The example screenshot is of a pseudo dialog but the problem is everywhere on multi-line text in YouTube.

I'm running Firefox 124.0.2 (64-bit) on Operating System: openSUSE Tumbleweed 20240419 KDE Plasma Version: 6.0.4 KDE Frameworks Version: 6.1.0 Qt Version: 6.7.0 Kernel Version: 6.8.7-1-default (64-bit) Graphics Platform: Wayland Processors: 32 × 13th Gen Intel® Core™ i9-13900K Memory: 62.6 GiB of RAM Graphics Processor: AMD Radeon RX 6650 XT Manufacturer: Gigabyte Technology Co., Ltd. Product Name: Z790 AORUS ELITE AX

Asked by noh.spam 4 weeks ago

Last reply by zeroknight 4 weeks ago