Showing questions tagged: اعرض كل الأسئلة
  • حُلّت
  • المُؤرشفة

Firefox seemed to "sync" the DisableAppUpdate policy from a Windows public comp to my Linux personal comp. I don't want that.

I normally use Firefox desktop on my Linux computer. Last week, I started using it on a public computer running Windows. I installed Firefox Portable and then logged/syn… (read more)

I normally use Firefox desktop on my Linux computer.

Last week, I started using it on a public computer running Windows. I installed Firefox Portable and then logged/synced into my Firefox account on this Win computer. I noticed that in the Firefox Portable Windows “about:preferences” page, it says “Your browser is being managed by your organization”, which links to about:policies. In that “about:policies” page, it shows this https://i.imgur.com/JmD8nXg.png Policy Name: DisableAppUpdate Policy Value: true. Now I’m back on my Linux desktop computer and it also has this “managed by your organization” message in “about:preferences” and the same “about:policies” stuff. In other words, it appears that this policy was copied from the Windows public computer to my personal Linux computer. I don’t want that.

How can I undo this? And how can I block this sort of policy syncing?

Asked by Mozilla cheese 2 years ago

Answered by jscher2000 - Support Volunteer 2 years ago

  • حُلّت
  • المُؤرشفة

Firefox Automatically Redirecting from HTTP to HTTPS (RESOLUTION)

As per this issue I reported a while back, I was experiencing odd issue with automatic redirect to HTTPS for some private development sites. I finally found a fix for th… (read more)

As per this issue I reported a while back, I was experiencing odd issue with automatic redirect to HTTPS for some private development sites.

I finally found a fix for the issue. The problem appears to be with DuckDuckGo Privacy Essentials Extension which apparently *may automatically redirect to the http site. In order to prevent this, I added my development sites to 'Unprotected Sites' and this prevented DuckDuckGo from doing the automatic redirect to https.

  • - Odd thing is that I had multiple domains pointing to the same web instance and only one of the domains was having this issue with the DDG extension. Both were going to the same IP through a HTTP proxy. The proxy and web server were not the issue. This symptom points to an maybe an issue in Firefox....

In summary, be wary of odd redirects and the DuckDuckGo Privacy Essentials extension if you are doing web development work.

Asked by Timothy C. Quinn 1 year ago

Answered by Timothy C. Quinn 1 year ago

  • حُلّت
  • المُؤرشفة

Some video content can not be displayed.

I use a laptop with Fedora 36 installed. Firefox is version 104.0.1 Until a few days ago, there were no problems with video display. But since a few days, video content … (read more)

I use a laptop with Fedora 36 installed. Firefox is version 104.0.1

Until a few days ago, there were no problems with video display. But since a few days, video content that is offered by the news site from NOS (Dutch television) is not displayed anymore. I only get this error: The media playback was aborted due to a corruption problem or because the media used features your browser did not support.

Also some content on Youtube aborts. For example loading https://www.youtube.com/watch?v=qq0BUiEs3JM results in this error: Er is een fout opgetreden. Probeer het later opnieuw. (Afspeel-ID: Ui0fzPxdSexgYcZ4).' (An error occured, try later again).

When using the Chrome Browser both websites can be used without giving errors implying that all the codecs are available.

How can I detect why video is blocked?

(Twitter also gives problems. After a fraction of a second, it stops displaying video)

Asked by Ben Engbers 1 year ago

Answered by Ben Engbers 1 year ago

  • حُلّت
  • المُؤرشفة

Import Certificates button not functioning

I am attempting to import server certificates into Firefox. But the "Import" button does nothing when viewing certificates. Any work around? I need to import our serv… (read more)

I am attempting to import server certificates into Firefox. But the "Import" button does nothing when viewing certificates. Any work around? I need to import our server certificates into the Authorities section.

Ubuntu 22.04 Firefox installed through snap. Version 104.0 just upgraded this afternoon.

Thank you, James

Asked by James Finnall 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • حُلّت
  • المُؤرشفة

Firefox using FIDO2 Security Keys

Firefox seems to have a problem on Linux using USB Security Keys. I have two Yubico Security Keys which I use for 2FA. The problem seems to be that Firefox cannot communi… (read more)

Firefox seems to have a problem on Linux using USB Security Keys. I have two Yubico Security Keys which I use for 2FA. The problem seems to be that Firefox cannot communicate with the USB port, as it doesn't make any difference whether the USB Security Key is plugged in or not, the error returned is always the same and the Security Key does not light up.

I believe Firefox's WebAuth code must be fine, as it works on Windows, which is why I think it's some kind of permissions problem. Chrome works perfectly with the Security Keys on my computer.

I've used a number of sites (I've listed a couple below) where you can test your Security Key with Firefox on KDE Neon and the error is always "UnknownError: The operation failed for an unknown transient reason":

https://www.token2.com/tools/fido2-test/ https://demo.yubico.com/webauthn-technical/registration

I cannot log into Bugzilla with GitHub as my GitHub login uses a Security Key as the second factor.

Asked by dave353 10 months ago

Answered by cor-el 10 months ago

  • حُلّت
  • المُؤرشفة

"Your browser can't play this video" on YouTube

Hello! Just installed Ubuntu 20.04.4 on my laptop and now find that I'm not able to watch some YouTube videos on Firefox 97. It seems mainly just live streams that I can'… (read more)

Hello! Just installed Ubuntu 20.04.4 on my laptop and now find that I'm not able to watch some YouTube videos on Firefox 97. It seems mainly just live streams that I can't watch. When I go to one it shows "Your browser can't play this video...Learn more" in the video window. Clicking Learn More takes me to a page that doesn't explain what the problem is. Any idea what the fix might be? The same videos play just fine on other devices on my network. Any help would be greatly appreciated.

Asked by kdpryor 1 year ago

Answered by kdpryor 1 year ago

  • حُلّت
  • المُؤرشفة

Unable to upload or download files

Hello all, For some reason, I can no longer upload or download files, with the pop-up window failing to appear entirely. I can upload folders through, for example, Dropb… (read more)

Hello all,

For some reason, I can no longer upload or download files, with the pop-up window failing to appear entirely. I can upload folders through, for example, Dropbox or Google Drive, but individual files don't work.

I've reset my browser, uninstalled and reinstalled it, opened it in troubleshooting mode, disabled enhanced tracking protection, but nothing seemed to work. I've tested another browser, and I was able to upload and download files just fine.

Is there anything I can do to fix this? I'm on Ubuntu 22.04 using Firefox 107.0.1.

Asked by Erika Campbell 1 year ago

Answered by jonzn4SUSE 1 year ago

  • حُلّت
  • المُؤرشفة

Unable to show File Picker

This was going to be a question about Firefox being unable to display the file picker dialog, but I managed to find a solution that worked for me along the way. Since it … (read more)

This was going to be a question about Firefox being unable to display the file picker dialog, but I managed to find a solution that worked for me along the way. Since it was nowhere near the top of Google's results, I thought I'll share my solution in the hopes that this would help someone facing this same issue.

The hardware:

  • Asus UM425IA Zenbook (AMD Ryzen 7 4700U CPU)

Worked in:

  • Ubuntu 20.04 LTS
  • Firefox provided by APT repository
  • Xorg display server

Not working in:

  • Ubuntu 22.04 LTS
  • Firefox 99.0.1 provided by snap
  • Wayland display server
  • File picker worked briefly on fresh install, but something (not sure what) quickly breaks file picker functionality

The symptoms:

  • Firefox stopped being able to open file picker dialogs
  • Right clicking an image and selecting "Save Image As..." does nothing
  • With forms that accept file upload (such as on this post question page "Add images (optional):"), clicking "Browse" does nothing
  • File downloads work correctly when set to "Save files to ..." under Settings, but nothing happens when set to "Always ask you where to save files"
  • No response to "Ctrl + O" open file shortcut

Similar questions and solutions:

Things I tried that did not work:

  • Disabling hardware acceleration
  • Starting with add-ons disabled
  • Troubleshoot mode
  • Clearing startup cache
  • Clearing cookies and site data
  • Clearing history
  • Refreshing Firefox
  • Creating and using a new profile
  • Deleting the `xulstore.json` file from the profile directory
  • Toggling all permissions under Ubuntu Settings > Applications > Firefox to off and then back to on
  • chmod 777 ~/Downloads
  • Disabling native file picker "ui.allow_platform_file_picker = false"

And finally, what fixed it for me was to go into "about:config" and change "widget.use-xdg-desktop-portal.file-picker" from "2" to "0". Credit to this post that clued me in.

I really hope this saves someone else 2 days of hair pulling and I would appreciate advice from someone more knowledgeable than me on:

  • Why this fixed the problem
  • Whether I should be opening a bug report either against Firefox, or Ubuntu
  • Whether I should also be changing "widget.use-xdg-desktop-portal.mime-handler" and "widget.use-xdg-desktop-portal.settings", both are currently set to "2"

Asked by James Fu 1 year ago

Answered by Kiki 1 year ago

  • حُلّت
  • المُؤرشفة

Unable to run 'flatpak install firefox' on chromebook

I was following this article https://support.mozilla.org/en-US/kb/run-firefox-chromeos Installed flatpak and repositories but when I try to use flatpak to install firefo… (read more)

I was following this article https://support.mozilla.org/en-US/kb/run-firefox-chromeos

Installed flatpak and repositories but when I try to use flatpak to install firefox I get "No remote refs found similar to ‘firefox’".

I have tried following a few other ways to get it installed, such as using sudo and using sudo su but that has not worked at all.

I followed to flatpak quick setup on Chromebook guide that is linked in the above help article and created the nested containers in crosh as well.

below is what happens if I go to flathub and copy-paste their recommended command to install firefox.

Remote ‘flathub’ found in multiple installations:

  1) system
  2) user

Which do you want to use (0 to abort)? [0-2]: 2 error: Nothing matches org.mozilla.firefox in remote flathub

Asked by Kili Luther 1 year ago

Answered by cor-el 1 year ago

  • حُلّت
  • المُؤرشفة

Is there a way to reset my Firefox password without losing my data?

I forgot my password to my Firefox account, and only just realized I haven't updated it in KeypassXC when I was trying to log in to a new machine. It seems that, even tho… (read more)

I forgot my password to my Firefox account, and only just realized I haven't updated it in KeypassXC when I was trying to log in to a new machine. It seems that, even though I am already logged in on my old computer and have full access to my account (including saved passwords, bookmarks, and browsing history) I can't find a way to reset my password without deleting all of my synced data. From the "Change Password" menu, it requires my old password if I want to change it without deleting everything. Also, I have 2FA enabled, so why isn't there the option to authenticate my identity in a password reset using 2FA instead of my old password? I know a similar thing already exists for recovery keys, but I only have 2FA. Is there any way for me to reset my password where I don't lose everything? Thank you.

Asked by Isaac Mellington 1 year ago

Answered by cor-el 1 year ago

  • حُلّت
  • المُؤرشفة

Firefox and WEBP images

Having just upgraded my Debian 9 machine to Mint 20, this has updated my firefox browser. Everything was going fine until I came across the problem where by all image do… (read more)

Having just upgraded my Debian 9 machine to Mint 20, this has updated my firefox browser.

Everything was going fine until I came across the problem where by all image downloads are saved as webp images, a format that my favourite image editing software cannot handle.

This is a bit of a pain and has made me start looking at alternative web browsers.

Just thought you should know how simple things can cause a loss of support.

Regards David

Asked by david_firefox1 1 year ago

Answered by david_firefox1 1 year ago

  • حُلّت
  • المُؤرشفة

Copy-pasting of files not working in Ubuntu 22.04

Hey there, Intro: I recently switched to Linux and (because Brave is so broken) also to Firefox and I am liking it so far. Problem: Unfortunately I can't copy-paste fil… (read more)

Hey there,

Intro: I recently switched to Linux and (because Brave is so broken) also to Firefox and I am liking it so far.

Problem: Unfortunately I can't copy-paste files from Ubuntu Files (Nautilus) to Firefox (I tested image files and also sounds files, neither is working).

Test with Firefox: 1. Download a random photo (e.g. from Unsplash) 2. Select the file and hit ctrl + c in Files/Nautilus 3. I go to the clipboard inspector 4. I hit ctrl + v 5. The image does not show up in the output (see screenshot)

Test with Brave: 1. Do the same as above 2. The image does show up in the output (see screenshot)

Notes: - I am using Linux Ubuntu 22.04 with Wayland - Firefox Version 107.0 (64-bit) for Ubuntu Canonical - 1.0 - I have no extensions installed - I am not using the snap version (so I can scroll smoothly) ... I think I used apt-get install but not 100% sure

Asked by Stephan 1 year ago

Answered by Stephan 1 year ago

  • حُلّت
  • المُؤرشفة

Firefox breaks my desktop environment's scrollbar style and (gradient) color and in version 98+ refuses css to approximate it

I work on kubuntu 20.04 with plasma 5.18.8 desktop environment. I have a QtCurve-based custom application style, which I almost match with css for GTK apps. Firefox has t… (read more)

I work on kubuntu 20.04 with plasma 5.18.8 desktop environment. I have a QtCurve-based custom application style, which I almost match with css for GTK apps. Firefox has to be an exception by itself! Not only that, but it changes my ability to customize its interface, from time to time and even changes access to such ability, on some updates.

My scrollbar customizations in userChrome.css and userContent.css do not work any more (other CSS changes still work, for menu/addressbar/tabbar/bookmarksbar orderint and tab styling). I had to resort to settings in user.js file, to get a 20px width scrollbar, suitable for my big screen, but... it gets very wide when I increase the focus, on some webpages and becomes very ugly! Furthermore, I cannot make sense of the proper use of "ui.themedScrollbar*" settings and the scrollbar and its slider result in the same color. These are my settings in user.js:

user_pref("widget.content.gtk-theme-override", "backwater"); user_pref("widget.non-native-theme.enabled", false); // Use GTK-3.0 gtk.css: set to false user_pref("toolkit.legacyUserProfileCustomizations.stylesheets", true); // Use userChrome.css & userContent.css: set to true user_pref("widget.gtk.alt-theme.scrollbar_active", true); user_pref("widget.non-native-theme.scrollbar.size.override", 20); // If nothing else works, fix scrollbar width to 20px user_pref("widget.non-native-theme.gtk.scrollbar.round-thumb", false); user_pref("widget.non-native-theme.gtk.scrollbar.thumb-size", 1.0); // originally 0.75 user_pref("widget.non-native-theme.gtk.scrollbar.allow-buttons", true); // it was true, anyway... user_pref("layout.css.cached-scrollbar-styles.enabled", false); user_pref("layout.css.color-mix.enabled", true); user_pref("widget.non-native-theme.scrollbar.style", 4); // wide scrollbar theme: set to 4 user_pref("ui.themedScrollbar", "#bad1f5"); user_pref("ui.themedScrollbarInactive", "#668cc4"); user_pref("ui.themedScrollbarThumb", "#e4e4e4"); user_pref("ui.themedScrollbarThumbHover", "#e4e4e4"); user_pref("ui.themedScrollbarThumbActive", "#668cc4"); user_pref("ui.themedScrollbarThumbInactive", "#bad1f5"); user_pref("browser.dom.window.dump.enabled", false); user_pref("extensions.ui.sitepermission.hidden", false); user_pref("fission.experiment.max-origins.qualified", true);

Either with the "ui.themedScrollbar*" settings or without them (and cleared from the prefs.js file), the scrollbar and its slider result in the same color, unless I (tryingly) click on some place on the scrollbar outside its slider; then I can see the slider, _only_ for the duration of the mouse-down event (which causes up or down page-hight scrolling).

The default, very thin scrollbar, as well as my modified wide scrollbar with invisible slider are both useless to me! I have even tried fx-autoconfig (https://github.com/MrOtherGuy/fx-autoconfig) to make the scrollbar CSS work, but no result. At this point, I am considering switching to another browser, despite the trust I have to mozilla, for my data and privacy.

Asked by kavadias 1 year ago

Answered by kavadias 1 year ago

  • حُلّت
  • المُؤرشفة

2FA login on web sites does not work with Firefox (Linux)

2FA login on sites works with Chromium but NOT WITH Firefox (Linux) Present setup: Does NOT work firefox 102.7.0esr on debian 11.6 bullseye 5.10.162-1 (x86-64) firefox … (read more)

2FA login on sites works with Chromium but NOT WITH Firefox (Linux)

Present setup:

Does NOT work firefox 102.7.0esr on debian 11.6 bullseye 5.10.162-1 (x86-64) firefox 110.0 on Ubuntu MATE 22.04 LTS 5.15.0-58 (x86-64)

Works chromium 109.0.5414.119 on debian 11.6 bullseye 5.10.162-1 (x86-64)

I am able to register and authenticate with security devices Yubikey NEO (without FIDO2) and Yubikey 5 NFC (FIDO2 compliant) on several sites (eg. pypi, google..) using Chrome or Chromium but now not with Firefox at all. It has not worked for at least the last few updates. Changing settings in about:config or plugging/unplugging keys, stopping every Firefox plugin etc. don't help. Neither does a fresh Firefox install without any super-security-settings.

Testing sites like Yubico's own or Okta's works fine using Chromium but not Firefox.

From what I can see this is not especially related to FIDO2 (Webauthn). pypi seems to use U2F which should work just fine with Firefox since way back.

I haven't tested Firefox for Windows but Chrome browser for Windows 10 works fine (which I tested first when Firefox didn't cut the mustard), I therefore expect it to work also on Chrome browser for Linux. Just to check if this was related to a debian bullseye package, I tested it on Ubuntu MATE too, which didn't do the trick. Haven't done any more testing than that on MATE.

This seems like a strictly firefox problem. -What to do?

Yours, Kaare

Asked by kaare 1 year ago

Answered by kaare 1 year ago

  • حُلّت
  • المُؤرشفة

Export all the bookmarks from a loads of profiles from a script

Hello everyone :) From a folder, I have loads of Firefox profiles from different eras. I am looking for a way to export all the bookmarks of each of the profiles to… (read more)

Hello everyone :)

From a folder, I have loads of Firefox profiles from different eras. I am looking for a way to export all the bookmarks of each of the profiles to an HTML file like the manual method (Library > Import and backup > Export bookmarks to formal HTML), but all in an automatic way by script. I like the HTML export from Firefox because it allows you to quickly navigate using keywords, either in links or in the folder names I gave.

Is there a simple solution that would reuse, for example, the same export code as Firefox ?

Thanks in advance With adelphity estebann

Asked by estebann 1 year ago

Answered by cor-el 1 year ago

  • حُلّت
  • المُؤرشفة

All tabs are crashing and show the message 'Gah. Your tab just crashed'

I am using firefox v104 on linux mint. This problem happened this evening. Every tab i open shows the same error. I tried the solutions suggested in other similar forum… (read more)

I am using firefox v104 on linux mint. This problem happened this evening. Every tab i open shows the same error.

I tried the solutions suggested in other similar forum posts like >safemode (tabs still crashed) >driver update (my drivers are up to date as far i can tell) >deleting cache and reinstalling firefox (tabs crash). I took a backup of my bookmarks and extensions as suggeated in another forum post. > one youtube video (https://youtu.be/F9VaXwSB_po) suggested toggling media.cubeb.sandbox in the config section. The tabs started loading after that but it wasnt that useful as i wasnt able to get any videos to play in the browser.

Also, i don't really know if the issue is related, but chrome tabs were also not loading or responding ('Page unresponsive' error).

Please help. Thank you :)

Asked by Vaghar 1 year ago

Answered by Vaghar 1 year ago

  • حُلّت
  • المُؤرشفة

Linux Dock Icon

I am using Pop OS, which is based off of Ubuntu. Somehow I did something, and it made the icon disappear for Firefox. I figured I could easily search the internet and fi… (read more)

I am using Pop OS, which is based off of Ubuntu.

Somehow I did something, and it made the icon disappear for Firefox. I figured I could easily search the internet and find a simple solution.

I temporarily fixed it last night, but here it is missing again.

I could upload a picture, but I don't see what difference that would make. The dock at the bottom has a spot for firefox, but no icon, literally an empty spot, In the application menu it is a blank spot with Firefox worded underneath.

I have uninstalled, reinstalled, purged, deleted the application data in my user folder..

Just annoying. not a huge problem.

Asked by cadearmstrong 1 year ago

Answered by cadearmstrong 1 year ago

  • حُلّت
  • المُؤرشفة

OpenH264 fails to install with HTTPS-Only mode enabled

"OpenH264 Video Codec provided by Cisco Systems, Inc." plugin will sit in the "will be installed shortly" status forever if you have HTTPS-Only mode enabled. I have been … (read more)

"OpenH264 Video Codec provided by Cisco Systems, Inc." plugin will sit in the "will be installed shortly" status forever if you have HTTPS-Only mode enabled. I have been pulling my hair out for the last few days trying to figure out why I couldn't play YouTube or many other sites videos.

Turns out the site that the library is downloaded from has a bad certificate installed: https://ciscobinary.openh264.org/libopenh264-2.3.0-linux64.6.so.bz2

``` Websites prove their identity via certificates. Firefox does not trust this site because it uses a certificate that is not valid for ciscobinary.openh264.org. The certificate is only valid for the following names: a248.e.akamai.net, *.akamaihd-staging.net, *.akamaihd.net, *.akamaized-staging.net, *.akamaized.net

Error code: SSL_ERROR_BAD_CERT_DOMAIN ```

OS: Fedora 36 Firefox Version: 104.0 (64-bit)

Asked by Nickolas Gupton 1 year ago

Answered by Nickolas Gupton 1 year ago