X
Tap here to go to the mobile version of the site.

منتدى الدعم

How Disable Plugin-Container.exe Permanently

Posted

How can I disable plugin-container permanently in firefox 28. Ive tried "dom.ipc.plugins.enabled" and it is set to false. I've tried : "Right click on your computer icon on the desktop and click properties

   Go to Advance system settings
   Click the button called "Environment Variables"
   Click the “New” button under User variables or System variables depending if you want the change to affect all the users on the system or just the one you are currently logged as
   Set the variable name to MOZ_DISABLE_OOP_PLUGINS and its value to 1

Ive tried running firefox in safe mode and the stupid plugin-container.exe is still running still eating CPU and making things slow..

How can I trash it? I don't need any explanations on how its "useful" I want it gone.. end of story..

How can I disable plugin-container permanently in firefox 28. Ive tried "dom.ipc.plugins.enabled" and it is set to false. I've tried : "Right click on your computer icon on the desktop and click properties Go to Advance system settings Click the button called "Environment Variables" Click the “New” button under User variables or System variables depending if you want the change to affect all the users on the system or just the one you are currently logged as Set the variable name to MOZ_DISABLE_OOP_PLUGINS and its value to 1 Ive tried running firefox in safe mode and the stupid plugin-container.exe is still running still eating CPU and making things slow.. How can I trash it? I don't need any explanations on how its "useful" I want it gone.. end of story..

Chosen solution

Ah-Ha!! I finally figured it out. I have disabled "plugin-container.exe" permanently.. C:\Program Files\Mozilla Firefox and deleted Plugin-container!!! how freaking imple.. and to answer peoples possible questions, everything still works fine.. and no laggy plugin-container slowing me down.

Read this answer in context 25

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 12.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • VLC media player Web Plugin 2.1.0
  • GEPlugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:28.0) Gecko/20100101 Firefox/28.0

More Information

jscher2000
  • Top 10 Contributor
8695 solutions 71076 answers

The old preference was removed a long time ago, so definitely that doesn't work.

The environment variable method supposedly has been working up to now, but I haven't tried it myself.

The way Firefox is designed, there is no other way to force plugins to run inside firefox.exe instead of being run in plugin-container.exe.

I know you don't want it hear it, but I suspect the problem is that relevant plugin is running slowly, and that it really won't make much difference to run it in firefox.exe instead of plugin-container.exe. Either the content, or the way the plugin interacts with your Firefox settings/system environment, likely is the real problem we need to solve.

The old preference was removed a long time ago, so definitely that doesn't work. The environment variable method supposedly has been working up to now, but I haven't tried it myself. The way Firefox is designed, there is no other way to force plugins to run inside firefox.exe instead of being run in plugin-container.exe. I know you don't want it hear it, but I suspect the problem is that relevant plugin is running slowly, and that it really won't make much difference to run it in firefox.exe instead of plugin-container.exe. Either the content, or the way the plugin interacts with your Firefox settings/system environment, likely is the real problem we need to solve.
jscher2000
  • Top 10 Contributor
8695 solutions 71076 answers

Helpful Reply

While you are troubleshooting this, it might be helpful, to avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

When you visit a site that wants to use the Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

Not a solution, but hopefully will help a bit.

While you are troubleshooting this, it might be helpful, to avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it. To set "Ask to Activate", open the Add-ons page using either: * Ctrl+Shift+a * orange Firefox button (or Tools menu) > Add-ons In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate". When you visit a site that wants to use the Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page. Not a solution, but hopefully will help a bit.

Chosen Solution

Ah-Ha!! I finally figured it out. I have disabled "plugin-container.exe" permanently.. C:\Program Files\Mozilla Firefox and deleted Plugin-container!!! how freaking imple.. and to answer peoples possible questions, everything still works fine.. and no laggy plugin-container slowing me down.

Ah-Ha!! I finally figured it out. I have disabled "plugin-container.exe" permanently.. C:\Program Files\Mozilla Firefox and deleted Plugin-container!!! how freaking imple.. and to answer peoples possible questions, everything still works fine.. and no laggy plugin-container slowing me down.