X
Tap here to go to the mobile version of the site.

منتدى الدعم

numbers showing in arabic not english v29 beta 5

Posted

when i open view image info, all numbers show in arabic this problem with firefox v29 beta only i tried v28 and works fine

http://img809.imageshack.us/img809/4203/s0z1.jpg

when i open view image info, all numbers show in arabic this problem with firefox v29 beta only i tried v28 and works fine http://img809.imageshack.us/img809/4203/s0z1.jpg

Additional System Details

Installed Plug-ins

  • Google Update
  • Next Generation Java Plug-in 11.0.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 12.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1
  • Facebook Video Calling Plugin
  • 5.1.20913.0
  • Yahoo Application State Plugin version 1.0.0.7

Application

  • Firefox 29.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
  • Support URL: https://support.mozilla.org/1/firefox/29.0/WINNT/en-US/

Extensions

  • Add-on Compatibility Reporter 2.0.3 (compatibility@addons.mozilla.org)
  • Flagfox 5.0.1 ({1018e4d6-728f-4b20-ad56-37578a4de76b})
  • Google Redesigned 2.1.2 ({cc85cd4e-5a5b-4eda-a25c-bdaffa93b406})
  • IDM CC 7.3.72 (mozilla_cc@internetdownloadmanager.com)
  • Linkification 1.3.9 ({35106bca-6c78-48c7-ac28-56df30b51d2a})
  • SearchPreview 7.0 ({EF522540-89F5-46b9-B6FE-1829E2B572C6})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • X-notifier 3.3.12 ({37fa1426-b82d-11db-8314-0800200c9a66})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 650 Ti BOOST
  • adapterDescription2:
  • adapterDeviceID: 0x11c2
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 3-4-2014
  • driverDate2:
  • driverVersion: 9.18.13.3523
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 650 Ti BOOST Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 6
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140403132807
  • browser.startup.homepage_override.buildID: 20140403132807
  • browser.startup.homepage_override.mstone: 29.0
  • browser.tabs.onTop: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 29.0
  • font.internaluseonly.changed: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1396603666
  • places.history.expiration.transient_current_max_pages: 78583
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.offlineApps: True
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1394965964

Misc

  • User JS: No
  • Accessibility: No
John99 971 solutions 13138 answers

I think you are correct as I can also see that problem on your screenshot of the page info relating to the home page.

What is the language used in your version of Firefox and your Windows & OS. (I do note my prefs include the language as a value in general.useragent.locale and intl.accept_languages )

I will leave it for others to comment further, as I do not know where Firefox picks up these fonts from.

I think you are correct as I can also see that problem on your screenshot of the ''page info'' relating to the home page. What is the language used in your version of Firefox and your Windows & OS. (I do note my prefs include the language as a value in ''general.useragent.locale'' and ''intl.accept_languages'' ) I will leave it for others to comment further, as I do not know where Firefox picks up these fonts from.

Question owner

i use en-US Firefox and English windows 7 64bit with Arabic support

i use en-US Firefox and English windows 7 64bit with Arabic support
John99 971 solutions 13138 answers

Presumably you still have the problem and are looking for a solution. This comment will bump the thread but please post back yourself.

Presumably you still have the problem and are looking for a solution. This comment will bump the thread but please post back yourself.

Question owner

ya i still have the problem until now, now i use Firefox v29 beta 6

ya i still have the problem until now, now i use Firefox v29 beta 6
John99 971 solutions 13138 answers

I will tag this as escalate, HelpDesk or someone knows more about this may join in within the next day or so.

I will tag this as escalate, HelpDesk or someone knows more about this may join in within the next day or so.

Question owner

thanks

thanks
cor-el
  • Top 10 Contributor
  • Moderator
17541 solutions 158614 answers

You could try the DOM Inspector to see if that gives some clues.

The DOM Inspector (DOMi) has a menu item (Edit > Select Element By Click) and a toolbar button "Find a node to inspect by clicking on it" (left icon on the toolbar in the DOMi).

  • open the browser window in the DOMi (File > Inspect Chrome Document) and choose the first entry from the drop-down list.
  • click the "Find a node to inspect by clicking on it" button and use the keyboard (Alt Tab) or the Task bar to go back to the browser window (do not click in the browser window other than the title bar).
  • click that element with the mouse and keep the button pressed until you see a red border to indicate the the DOMi has located that element in the DOM tree.
You could try the DOM Inspector to see if that gives some clues. * DOM Inspector: https://addons.mozilla.org/firefox/addon/dom-inspector-6622/ * https://developer.mozilla.org/en/DOM_Inspector/Introduction_to_DOM_Inspector The DOM Inspector (DOMi) has a menu item (Edit > Select Element By Click) and a toolbar button "Find a node to inspect by clicking on it" (left icon on the toolbar in the DOMi). * open the browser window in the DOMi (File > Inspect <b>Chrome</b> Document) and choose the first entry from the drop-down list. * click the "Find a node to inspect by clicking on it" button and use the keyboard (Alt Tab) or the Task bar to go back to the browser window (do not click in the browser window other than the title bar). * click that element with the mouse and keep the button pressed until you see a red border to indicate the the DOMi has located that element in the DOM tree.

Question owner

can you do it with team viewer ?

you can check the browser and language i use too

can you do it with team viewer ? you can check the browser and language i use too
guigs 1072 solutions 11697 answers

Hi BALTAGY, The Dom inspector mentioned above will show if there is an encodding coming from the server of the page you are showing the information on. Since you have windows 7 64bit with Arabic support, does this mean that the properties should be in english? Is there an issue with stored page info, I do not know. However with the steps taken already, its not an add on or extension, with the preferences general.useragent.locale and intl.accept_languages turned to true this is reproducible. You could remove the country language code for arabic and see if the issue continues, but they may affect other pages you request with that language.

In the page source of the page this image is on, is there a attribute specifying the language? For example:

lang="en-GB"

Is is only that website?

Hi BALTAGY, The Dom inspector mentioned above will show if there is an encodding coming from the server of the page you are showing the information on. Since you have windows 7 64bit with Arabic support, does this mean that the properties should be in english? Is there an issue with stored page info, I do not know. However with the steps taken already, its not an add on or extension, with the preferences general.useragent.locale and intl.accept_languages turned to true this is reproducible. You could remove the country language code for arabic and see if the issue continues, but they may affect other pages you request with that language. In the page source of the page this image is on, is there a attribute specifying the language? For example: <br> '''lang="en-GB"''' Is is only that website?

Modified by guigs

Question owner

i used every firefox versions in same system with no problems only v29 and higher have this problem

this problem with all websites not only one site

i used every firefox versions in same system with no problems only v29 and higher have this problem this problem with all websites not only one site
John99 971 solutions 13138 answers

Rachel, Note my comment above, this is even being seen in properties of a protocol page about:home so it is not just webpages involving an external server.

Arabic numerals can be seen in the Dimensions 192px is displayed in Middle east Arabic numerals not European/American Arabic numerals.

Rachel, Note my comment above, this is even being seen in properties of a protocol page ''about:home'' so it is not just webpages involving an external server. <img src="https://support.cdn.mozilla.net/media/uploads/images/2014-04-05-06-27-53-911af7.png" width=450 > Arabic numerals can be seen in the Dimensions 192px is displayed in Middle east Arabic numerals not European/American Arabic numerals.

Helpful Reply

in the download also, some numbers English and some Arabic !!

in the download also, some numbers English and some Arabic !!
John99 971 solutions 13138 answers

I am not sure I understand how the DOMi extension or the built in Inspector can shed light on this, at least the part where the Interface results are in Arabic. Hopefully Guigs or one of the others will comeback with ideas.

Meanwhile as it is the UI that is misbehaving it would seem worthwhile to try a clean reinstall of Firefox. That involves deleting the program files (NOT the profile files)


Clean Reinstall,
Note:
You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from mozilla.org/firefox/all/ and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default: (Windows: )
    • C:\Program Files\Mozilla Firefox
    • C:\Program Files (x86)\Mozilla Firefox
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING: Do not run Firefox's uninstaller or use a third party remover as part of this process, because that could permanently delete your Firefox data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot easily be recovered unless they have been backed up to an external device!

I am not sure I understand how the DOMi extension or the built in Inspector can shed light on this, at least the part where the Interface results are in Arabic. Hopefully ''Guigs'' or one of the others will comeback with ideas. Meanwhile as it is the UI that is misbehaving it would seem worthwhile to try a clean reinstall of Firefox. That involves deleting the program files (NOT the profile files) --------- '''Clean Reinstall, <br /> Note:''' You might want to print these steps or view them in another browser. #Download the latest Desktop version of Firefox from mozilla.org/firefox/all/ and save the setup file to your computer. #After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu). #Delete the Firefox installation folder, which is located in one of these locations, by default: ('''Windows:''' ) #*C:\Program Files\Mozilla Firefox #*C:\Program Files (x86)\Mozilla Firefox #Now, go ahead and reinstall Firefox: ##Double-click the downloaded installation file and go through the steps of the installation wizard. ##Once the wizard is finished, choose to directly open Firefox after clicking the Finish button. More information about reinstalling Firefox can be found [https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems?esab=a&s=troubleshooting&r=3&as=s#w_5-reinstall-firefox here]. <b>WARNING:</b> Do not run Firefox's uninstaller or use a third party remover as part of this process, because that could permanently delete your Firefox data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. <u>These cannot easily be recovered unless they have been backed up to an external device!</u>
cor-el
  • Top 10 Contributor
  • Moderator
17541 solutions 158614 answers

The idea would be to use the DOMi to check if the same font is used for all the text or a different font for the Arabic glyphs.

This could be a bug that Firefox is checking the Windows system locale for some metrics and falls back to Arabic glyphs in some cases.

The idea would be to use the DOMi to check if the same font is used for all the text or a different font for the Arabic glyphs. This could be a bug that Firefox is checking the Windows system locale for some metrics and falls back to Arabic glyphs in some cases.
John99 971 solutions 13138 answers

Cor-el,
Some if not all of these Arabic Glyphs are in the page info results.

Is there any way in which DOMi can look at those glyphs ?
I installed DOMi myself but could not see any method to do that.

I suspect OP BALTAGY saying (upthread)

it happen with all images 

Means this happens with page info results for all images on all websites.

BALTAGY
Can you clarify this please.
Are you seeing Arabic glyphs unexpectedly on web pages ?
Or are you only seeing these unexpectedly on the Firefox User Interface such as page info pages of image properties ?

Cor-el, <br />Some if not all of these Arabic Glyphs are in the '''''page info''''' results. Is there any way in which DOMi can look at those glyphs ? <br />I installed DOMi myself but could not see any method to do that. I suspect OP ''BALTAGY'' saying [/questions/993357#answer-553286 (upthread)] ''it happen with all images '' Means this happens with page info results for ''all images'' on all websites. BALTAGY<br /> Can you clarify this please. <br />Are you seeing Arabic glyphs unexpectedly on web pages ? <br /> Or are you only seeing these unexpectedly on the Firefox User Interface such as ''page info'' pages of image properties ?
cor-el
  • Top 10 Contributor
  • Moderator
17541 solutions 158614 answers

You only need to select the correct window via the File > Inspect Chrome Document in the DOMi to inspect elements in this window. The built-in Inspector can't do this, but no problem to do this with the DOMi.

You only need to select the correct window via the File > Inspect Chrome Document in the DOMi to inspect elements in this window. The built-in Inspector can't do this, but no problem to do this with the DOMi.
John99 971 solutions 13138 answers

OK thanks, I can now inspect the page info Chrome with DOMi by following your instructions.

OK thanks, I can now inspect the '''page info''' Chrome with DOMi by following your instructions.

Question owner

- i see Arabic in user interface only, and only in firefox 29 and 30 with the new interface

- i tried v28 and 29 and 30 in a new system in Vmware and the problem only in v29 and 30 with clean install and v28 works perfect

- if anyone of moderators want to try DOMi by teamviwer let me know i will let you try it in my computer and in a clean system in vmware

i think the problem in the new interface not with my language, when i tried all Firefox versions i tried a clean install with no addons and no other programs installed in the system

- i see Arabic in user interface only, and only in firefox 29 and 30 with the new interface - i tried v28 and 29 and 30 in a new system in Vmware and the problem only in v29 and 30 with clean install and v28 works perfect - if anyone of moderators want to try DOMi by teamviwer let me know i will let you try it in my computer and in a clean system in vmware i think the problem in the new interface not with my language, when i tried all Firefox versions i tried a clean install with no addons and no other programs installed in the system

Modified by BALTAGY

guigs 1072 solutions 11697 answers

Baltagy, is v 29v? what are the sub-versions of 29 you start to see this?

Baltagy, is v 29v? what are the sub-versions of 29 you start to see this?

Question owner

i don't remember i think from beta 1, but I'm sure it's when i saw this new interface

i don't remember i think from beta 1, but I'm sure it's when i saw this new interface