ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox cant diplay captcha panels, fails with modem config

more options

Having many problems since migrating to Firefox since v21. Am continually forced to go back to IE.

1. The Captcha panel that many websites use to verify humanity does not display at all when using firefox.

2. When updating configuration settings in D-Link modems/routers or Netgear managed switches pages do not refresh correctly, and only work properly with IE and Chrome. (For example, www.vicroads.vic.gov.au, change address)

3. On a couple of websites I have to delete the cookies from that site before attempting to open a webpage. Then delete the cookies again before clicking on any links on the pages. Firefox complains that a redirection failed; Attempting to redirect that will never complete. Sometimes it works, most of the time it doesn't.

All Replies (16)

more options


Starting in Firefox 23, if a secure page includes certain types of insecure content, Firefox blocks the insecure content and a shield icon will appear in the address bar. See this article for more information about the new mixed content blocker: Mixed content blocking in Firefox

To temporarily allow the mixed content to be displayed:

  • Click the shield icon Mixed Content Shield in the address bar and choose Disable Protection on This Page from the dropdown menu.


To allow insecure content to be displayed in all secure pages, enter about:config in the address bar and double-click on this preference, to toggle it from true to false:


You can also use this add-on instead, to toggle the preference:

You may want to do this only for the current session, then reset the preference back to "true" and check back with the site to see whether it's been fixed, since this is a global setting that exposes you on all sites, not just the one you care about.

Let us know if this helps!

more options

Modified by cor-el

more options

Many users have recently become more aware of privacy and either made changes to their cookie settings or installed extensions that stop some information from reaching websites. While this reduces tracking, it also can cause some site functions to break.

A lot of CAPTCHA challenges are embedded into pages from Google's ReCAPTCHA site using an iframe. If you are restricting third party cookies in general, or if Google Disconnect is limiting the information sent to Google, or if you have somehow disabled iframes (perhaps to limit advertising?), that might explain why those boxes do not appear.

As a test, try some of the problem sites in Firefox's Safe Mode in a Private Browsing window. This will help bypass restrictive cookie settings, as well as other filtering behaviors of extensions, to see whether those are a factor.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the small dialog that should appear, click "Start in Safe Mode" (not Reset)

Then open a private browsing window using either:

  • Ctrl+Shift+p
  • File menu > New Private Window
  • orange Firefox button > New Private Window

In that window, try one or more of the sites displaying a CAPTCHA challenge. Any difference?

more options

You can also check the Media tab in the "Tools > Page Info" window, also accessible via the "Site Identity Button" (globe/padlock) on the location bar and the More Information button.

more options

Hello All. Thank you for your replies.

@quigs2: I am not seeing this blocked content shield, but thanks for the info and suggestion.

@cor-el: The tips in neither of the links solved the problem. As soon as the site recreates the cookies, the problem resurfaces. It makes no difference how I access the site (from a book mark, via Google, or by directly typing the URL).

@jscher2000: Thanks for the info. This solved all problem. Run in safe mode and a new private window makes everything work.

However, this is clearly not a preferred option as it's about as insecure as things can get.

I am running the various "disconnect" plugins and AdBlock+. The modem and captcha problems I have had since the day I started using Firefox), IIRC, around v15.

The website redirect that will never complete only started two weeks ago, and I've been running the plugins for many, many months.

So, (she asks fearing the answer), is there a way I can prevent sites tracking me, and surf securely, without purchasing third party software (if that is even an option?)

thanks Tanya

more options

It is possible that the cookies.sqlite file that stores the cookies is corrupted if clearing cookies doesn't work.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

You can inspect and manage the permissions for all domains on the about:permissions page or for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location bar
  • Click "More Information" to open "Tools > Page Info" with the Security tab selected
  • Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab

Delete the permissions.sqlite file to reset all permissions.

more options

Hi Tanya, that test indicates that either a cookie issue or an extension is most likely responsible for the issue. If you try the problem sites in Safe Mode in a regular (non-private) window and they work better, one of your extensions would be the most likely candidate.

more options

Ok, I have just reinstalled Windows 7 x64 from scratch. I installed FireFox 27, Microsoft Office 2010 and my typical media applications (like DVDFab, AVCHDCoder and so on). The collection of applications has been fairly stable for the last few years.

I have not installed Adblock or any extensions or plugins. many of the applications I typically use haven't even been installed yet. I have installed Java x86 v7 u51.

I haven't even got as far as installing my virus software yet.

Other than my homepage and "tell sites I do not want to be tracked" I haven't changed any settings. And of course, I'mm getting popups all over the place that AdBlock used to block.

All problems persist unless I run in safe mode.

I can't edit my modem config (pages don't save or refresh) I can't see captcha challenges I can't visit this one website that works the first time (when it creates it's cookies), and then fails to work again until I delete those cookies.

more options

Note that some software may include unwanted extras.

Does it work properly in a Private Browsing mode window?

Do a malware check with several malware scanning programs on the Windows computer.
Please scan with all programs because each program detects different malware.
All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

Cor-El, thanks for your continued support. I must apologize if I am coming across as a complete noob. Despite appearances, I actually am an experienced computer user. I worked in I.T. for 35 years before being forcefully retired.

This is not a virus or malware issue. I am very security conscious and have only ever had one infection once since 1981. Despite that, I will run the scanners you have suggested except the spybot one as I do not trust that program. Malwarebytes is my usual program. I purchased the pro version.

All programs I use are legal. They are either retail, Technet or from trusted sources (such as Firefox).

Regarding safe mode...

The captcha challenge I am testing with is at http://www.vicroads.com.au - Change your address. In safe mode the captcha challenge is visible. In normal mode it is not. I have tried this without adblock plus and with adblock plus.

In the modem configuration page (DLINK 2870b, Wireless 2.4g setup), clicking apply results in failure in normal and private browsing mode, with or without adblock plus installed.

For the TV Episodes web site, in normal mode it fails. In private mode it appears to be working. I tried a search, as well as changing pages, and a refresh. So far so good - in private browsing mode.

I will get back to you with the results of the scans. Give me 24 hours.

Modified by Yanta

more options

The form is framed. If you launch it independently, does it work?


more options

You can also try to create a new profile to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem

more options

Ok, I have tested the set up with a myriad of virus, malware and rootkit tools. The system comes up clean.

Re: Profiles: I am starting with a clean system. There are no profiles created, either in the form of files on the drive, or registry entries. I am starting from a fresh Windows install.

I created an image using Macrium reflect free, with only the OS and M$ updates installed. After each test I restored to the image to eliminate any leftover stuff. So every test was done from a completely clean environment. Tests were first done with no services, extensions or add-ins.

The problems persisted (even in private browsing mode). The modem and captcha were fine in safe mode, but the "redirect that will never complete" cookie problem persisted even in safe mode.

I then installed adblock plus 2.5.1 and tried all tests again. Same results.

I then installed MS Office 2010 which installed a few addons. Repeated tests again and same results.

Eventually through a combination of changing the order in which I installed things I managed to get Captcha working. I have to install Java 7u51 BEFORE I installed shockwave/flash. I have to install Firefox after java but before flash.

But the modem config problems and the infinite-cookie are not resolved. So I contacted D-Link about the modem. They stated it is a problem with Firefox, not their firmware (of course they would say that)

I then repeated the tests (from a clean starting point), with IE 8 and the latest cumulative update from M$. No problems with anything. I set privacy settings to High.

I'm at my wits end with this..

Modified by Yanta

more options

Previously, you said the the combination of safe mode (deactivates extensions) and private browsing (accepts all cookies for the duration of the private session) were successful in resolving all 3 issues.

Regarding your modem: When you say the pages do not refresh correctly, is the problem that Firefox is showing a cached page with old data rather than an updated page?

Regarding the "redirect" issue: are you blocking third party cookies, either in Firefox's settings or in any of your extensions?

more options

I'm sorry, I seem to have confused you. What I meant was that the cookies issue seemed to be "so far so good". But it didn't last. This issue is not resolved at all. In my original post I said "it works some times, but most of the time it doesn't". The private broswing success was a red herring and short lived.

The modem issue is only resolved in safe mode.

The catcha issue is now resolved completely, via a trial and error combination of installation sequence changes, which I have documented for future installs. Though my last comment on this issue was "it only works in safe mode". (3/4/14 1:02pm).

The image attached is for the modem config page. After clicking apply it redisplays with the top half of the page blank, and no settings will update. The only way to get it to work is in safe mode or use IE.

Sorry for any confusion. Tanya

more options

For the modem page display glitches, could you try disabling Firefox's use of hardware acceleration for graphics? This is a workaround for incompatibility with graphics card drivers, and is one of the differences between safe mode and normal mode.

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This takes effect after you exit and restart Firefox.