X
Tap here to go to the mobile version of the site.

منتدى الدعم

Secure Connection Failed An error occurred during a connection to www.google.co.in.

Posted

Problem:-

Secure Connection Failed

An error occurred during a connection to www.google.co.in. SSL peer rejected a handshake message for unacceptable content. (Error code: ssl_error_illegal_parameter_alert)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.



I have tried every possible aspect provided by the Mozilla Firefox Support Team

These are the Steps followed:-

Check your SSL settings

   In the Location bar, type about:config and press Enter.
       The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise! to continue to the about:config page. 
   Type security.enable in the Search field.
       If both security.enable_ssl3 and security.enable_tls are set to true, skip to the next section.
       If both security.enable_ssl3 and security.enable_tls are set to false, double-click each of them to set it to true. 

Try to access a secure site again. If it still doesn't work, continue in the next section.


Check your proxy settings

Some computers are configured to access the Internet through a proxy.

   Click the menu button New Fx Menu and choose Options
   .
   Select the Advanced panel.
   Click the Network tab.
   Click Settings….
       If Manual proxy configuration is selected, you are using a manually configured proxy server. Verify that all protocols listed in the dialog box are pointing to the address of your proxy server. Contact your network administrator if you don't know this address.
       If Manual proxy configuration is not selected, this section does not apply. You can skip to the next section. 
   Make any changes, and click OK to close the Connection Settings window.
   Click OK to close the Options window . 

Try to access a secure site again. If it still doesn't work, continue in the next section.


Please suggest a proper solution as my 100 employees are suffering with it...

Problem:- Secure Connection Failed An error occurred during a connection to www.google.co.in. SSL peer rejected a handshake message for unacceptable content. (Error code: ssl_error_illegal_parameter_alert) The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site. I have tried every possible aspect provided by the Mozilla Firefox Support Team These are the Steps followed:- Check your SSL settings In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise! to continue to the about:config page. Type security.enable in the Search field. If both security.enable_ssl3 and security.enable_tls are set to true, skip to the next section. If both security.enable_ssl3 and security.enable_tls are set to false, double-click each of them to set it to true. Try to access a secure site again. If it still doesn't work, continue in the next section. Check your proxy settings Some computers are configured to access the Internet through a proxy. Click the menu button New Fx Menu and choose Options . Select the Advanced panel. Click the Network tab. Click Settings…. If Manual proxy configuration is selected, you are using a manually configured proxy server. Verify that all protocols listed in the dialog box are pointing to the address of your proxy server. Contact your network administrator if you don't know this address. If Manual proxy configuration is not selected, this section does not apply. You can skip to the next section. Make any changes, and click OK to close the Connection Settings window. Click OK to close the Options window . Try to access a secure site again. If it still doesn't work, continue in the next section. Please suggest a proper solution as my 100 employees are suffering with it...

Modified by Viratthakur

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers

Application

  • Firefox 30.0a1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:30.0) Gecko/20100101 Firefox/30.0
  • Support URL: https://support.mozilla.org/1/firefox/30.0a1/WINNT/en-US/

Extensions

  • avast! Online Security 9.0.2013.75 (wrc@avast.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • BuenoSearch 1.6.0 (ffxtlbr@buenosearch.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Standard VGA Graphics Adapter
  • adapterDescription2:
  • adapterDeviceID: 0x2582
  • adapterDeviceID2:
  • adapterDrivers: vga framebuf vga256 vga64k
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 6-21-2006
  • driverDate2:
  • driverVersion: 6.1.7600.16385
  • driverVersion2:
  • info: {u'AzureContentBackend': u'cairo', u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedDriver']
  • numTotalWindows: 1
  • webglRendererMessage: [u'blockedDriver']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 327680
  • browser.places.smartBookmarksVersion: 6
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140204030201
  • browser.startup.homepage: http://www.google.com/
  • browser.startup.homepage_override.buildID: 20140204030201
  • browser.startup.homepage_override.mstone: 30.0a1
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 30.0a1
  • font.internaluseonly.changed: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1391677619
  • places.history.expiration.transient_current_max_pages: 34819
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 2
  • plugin.state.nppdf: 1
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.disable_button.openCertManager: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1390035863

Misc

  • User JS: Yes
  • Accessibility: No

Question owner

Here Is the Image that i have attached which the 100 of my employees are facing what should we do its very critical...

Here Is the Image that i have attached which the 100 of my employees are facing what should we do its very critical...
cor-el
  • Top 10 Contributor
  • Moderator
17466 solutions 157836 answers

You can try to modify the security.tls.version.min and security.tls.version.max prefs to set which TLS versions are enabled.
You may have to close and restart Firefox after changing these prefs.

security.tls.version.min = 0
security.tls.version.max = 2
0 means SSL 3.0, 1 means TLS 1.0, 2 means TLS 1.1, 3 means TLS 1.2, etc.
You can try to modify the security.tls.version.min and security.tls.version.max prefs to set which TLS versions are enabled.<br /> You may have to close and restart Firefox after changing these prefs. security.tls.version.min = 0 security.tls.version.max = 2 *http://kb.mozillazine.org/security.tls.version.* 0 means SSL 3.0, 1 means TLS 1.0, 2 means TLS 1.1, 3 means TLS 1.2, etc.

Modified by cor-el

Question owner

This also did not resolve the issue.

Please i request the firefox team and the users of firefox to please give me the better solution to get rid of this....

Awaiting for your responses????????

This also did not resolve the issue. Please i request the firefox team and the users of firefox to please give me the better solution to get rid of this.... Awaiting for your responses????????
cor-el
  • Top 10 Contributor
  • Moderator
17466 solutions 157836 answers

No problems here with the current Nightly (30) and Aurora (28) build (TLS 1.0 and TLS 1.2 enabled)

www.google.co.in: Connection Encrypted: High-grade Encryption (TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256, 128 bit keys)

What kind of connection do you use?
Are you connecting via a proxy or a direct connection?

You can try to log the connection.

No problems here with the current Nightly (30) and Aurora (28) build (TLS 1.0 and TLS 1.2 enabled) www.google.co.in: Connection Encrypted: High-grade Encryption (TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256, 128 bit keys) What kind of connection do you use?<br /> Are you connecting via a proxy or a direct connection? You can try to log the connection. *https://developer.mozilla.org/en/The_Necko_HTTP_module *https://developer.mozilla.org/en/HTTP_Logging

Question owner

we are using direct connection behind a firewall, The interface is followed like this

Router->Firewall->Systems

we are using direct connection behind a firewall, The interface is followed like this Router->Firewall->Systems

Question owner

No Solution For this error???????????

No Solution For this error???????????
guigs 1072 solutions 11697 answers

Hi Viratthakur,

I am sorry for the frustration, however we will do our best to help you investigate the issue. Please keep in mind, the Firefox version is a beta version that updates on a different cycle than Firefox 27.

In order to better understand the issue:

  • When did this start happening?
  • Are you using a nonstandard port for the ssl? is your default port 443?
  • Do all certificates utilize one dedicated ip?
  • If using Apache2 check your vhost config. Some users have reported changing <VirtualHost> to _default_ resolved the error.

Reference http://stackoverflow.com/questions/11.../ssl-error-rx-record-too-long-and-apache-ssl

  • Is the intermediate certificate at the server side (apache SSLCertificateChainFile)?
  • you can test the direct connection with no proxy (turning the proxy setting off on the computer's security settings)

We look forward to your reply.

Hi Viratthakur, I am sorry for the frustration, however we will do our best to help you investigate the issue. Please keep in mind, the Firefox version is a beta version that updates on a different cycle than Firefox 27. In order to better understand the issue: *When did this start happening? *Are you using a nonstandard port for the ssl? is your default port 443? *Do all certificates utilize one dedicated ip? *If using Apache2 check your vhost config. Some users have reported changing <VirtualHost> to _default_ resolved the error. Reference [http://stackoverflow.com/questions/119336/ssl-error-rx-record-too-long-and-apache-ssl] *Is the intermediate certificate at the server side (apache SSLCertificateChainFile)? *you can test the direct connection with no proxy (turning the proxy setting off on the computer's security settings) We look forward to your reply.