ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox freezing while watching youtube videos or using anything flash

  • 7 ردود
  • 65 have this problem
  • 5665 views
  • آخر ردّ كتبه nickm25

more options

I have exhausted all options. I have reinstalled everything I have updated firefox to the 27 beta I have updated flash to the 12 beta I have disabled hardware acceleration on flash and firefox I have made sure there is no viruses. I have tried a new profile disabled my add ons only a few there anyway, I have done the reset firefox. Nothing works. I am at my wits end and really dont know what else can be done. I cannot enable the hardware acceleration on firefox due to the fact it makes my text go crazy and I tried some about:config tweaks but nothing has resolved the text issue they just made things worse. I have already tried another profile also. I do not know what to do. I dont want to lose everything because my fast dial is set up how I want it and I tried before to get it back like that and cannot. Its just convenient. Any ideas on how to stop my youtube videos from freezing? my cpu usage and memory for firefox.exe spikes. I am on windows 7 64 bit I have 8 gb of ram. I refuse to switch back to IE or Google Chrome dont like them I am faithful to firefox lol. But this issue has me puzzled. All drivers are up to date as well.

All Replies (7)

more options

hello, maybe it's an issue with the protected mode in the flash plugin - you could try if disabling protected mode makes a difference.

more options

If you haven't tried disabling the protected mode feature of the Flash Player plugin, I recommend trying that. The following pages provide information on how to disable the feature.

more options

In case the problem is created by one of these two extensions, have you tested with both of them disabled?

  • Download videos and MP3s from YouTube 4.5.3.1206 (DVDVideoSoft?)
  • YouTube High Definition 7.3 (Add-ons Site)

You can manage them on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions. Then use their respective Disable buttons.

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

more options

Protected mode is already disabled on Flash I just verified that. Disabling all extensions still does not help I have tried it all. I dont even have a theme anymore I used to use a persona but I got rid of that because I thought it was the cause.

Modified by nickm25

more options

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

What are the full contents of this file?

C:\Windows\SysWOW64\Macromed\Flash\mms.cfg

Note: to keep line breaks in this forum, add a space to the beginning of each line after pasting it into your reply.


Currently your setting for when to show the "script is slow continue/stop" dialog is basically never, so Firefox can hang indefinitely. You might want to return that setting to the default of 10 seconds so you can stop scripts when necessary.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste max and pause while the list is filtered

(3) Right-click the dom.max_script_run_time preference and choose Reset to restore the default value of 10 seconds.

Or maybe that will be even more annoying...


I don't know whether it will help, but Youtube uses the DASH method of sending videos in small bits. The YouTube Center extension will revert to the older method of sending the whole video as one giant file. Maybe that will work more smoothly?

https://addons.mozilla.org/en-us/firefox/addon/youtube-center/

more options

SilentAutoUpdateEnable=1

AutoUpdateDisable=0

ProtectedMode=0

Thats what my mms.cfg file has in it.

The dom.max_script_run_time was set to 0 I changed to 10. I will give this youtube center a try and report back. I will try boot pc in safe mode and report back on that as well. Bad thing is this issue is random because there are times it works fine, other times it freezes and cpu usage spikes. But right now with all that its staying at 6 cpu usage for firefox.exe watching a 720P HD Youtube Video

Modified by nickm25