X
Tap here to go to the mobile version of the site.

منتدى الدعم

Website not appearing on Firefox for Mac?

Posted

My company has just launched our new website www.robotandspark.com - which loads correctly the first time you view it, but if you close the window, open a new one and type the URL, the page appears blank (white). Is this a Firefox or a website issue? Thanks

My company has just launched our new website www.robotandspark.com - which loads correctly the first time you view it, but if you close the window, open a new one and type the URL, the page appears blank (white). Is this a Firefox or a website issue? Thanks

Additional System Details

Application

  • User Agent: Mozilla/5.0 (iPhone; CPU iPhone OS 7_0_4 like Mac OS X) AppleWebKit/537.51.1 (KHTML, like Gecko) Version/7.0 Mobile/11B554a Safari/9537.53

More Information

iamjayakumars 489 solutions 5951 answers

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

Hello, Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: ''This will temporarily log you out of all sites you're logged in to.'' To clear cache and cookies do the following: #Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history. #Under "Time range to clear", select "Everything". #Now, click the arrow next to Details to toggle the Details list active. #From the details list, check ''Cache'' and ''Cookies'' and uncheck everything else. #Now click the ''Clear now'' button. Further information can be found in the [[Clear your cache, history and other personal information in Firefox]] article. Did this fix your problems? Please report back to us! Thank you.

Question owner

Hi Jaya,

Sorry but this has not worked. The issue does not appear on safari, ie, chrome or even firefox on PC.

Thanks

Hi Jaya, Sorry but this has not worked. The issue does not appear on safari, ie, chrome or even firefox on PC. Thanks
iamjayakumars 489 solutions 5951 answers

If the problem only with MAC then try in safemode

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

If the problem only with MAC then try in safemode '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.

Question owner

Hi,

The issue is still present in safe mode :(

Hi, The issue is still present in safe mode :(
jscher2000
  • Top 10 Contributor
8695 solutions 71066 answers

Does the page appear if you reload (Command+r)?

Could you check a couple of variables:

  • Is hardware acceleration enabled or disabled? This setting is under Firefox > Preferences > Advanced > General mini-tab
  • What is your zoom level for the site? You may know this intuitively, but you also can check the multiplier using the Web Console (Tools menu > Web Developer > Web Console). Next to the caret (») type or paste window.devicePixelRatio and press Enter.

The blank page reminds me of a problem some users are having on Google with higher zoom levels: When I go back to Google search results page, it takes me to a blank Google screen. The temporary workaround is to disable some of the "fast back forward cache" feature. You might want to test and see whether it affects the issue you're having. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

(3) Double-click the browser.sessionhistory.max_total_viewers preference and change it to 0 (that's a zero).

Any difference?

Does the page appear if you reload (Command+r)? Could you check a couple of variables: * Is hardware acceleration enabled or disabled? This setting is under Firefox > Preferences > Advanced > General mini-tab * What is your zoom level for the site? You may know this intuitively, but you also can check the multiplier using the Web Console (Tools menu > Web Developer > Web Console). Next to the caret (») type or paste '''window.devicePixelRatio''' and press Enter. The blank page reminds me of a problem some users are having on Google with higher zoom levels: [https://support.mozilla.org/en-US/questions/970863 When I go back to Google search results page, it takes me to a blank Google screen]. The temporary workaround is to disable some of the "fast back forward cache" feature. You might want to test and see whether it affects the issue you're having. Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''sess''' and pause while the list is filtered (3) Double-click the '''browser.sessionhistory.max_total_viewers''' preference and change it to 0 (that's a zero). Any difference?

Question owner

Hi Jscher2000,

Hardware acceleration is enabled, pixel ratio is 1.

I changed the browser.sessionhistory.max_total_viewers to 0 but still no luck.

on the web developer tools i noticed an error message at the bottom of the page, but it doesnt mean anything to me (am not a developer):

uncaught exception. cannot tween a null target

Hi Jscher2000, Hardware acceleration is enabled, pixel ratio is 1. I changed the browser.sessionhistory.max_total_viewers to 0 but still no luck. on the web developer tools i noticed an error message at the bottom of the page, but it doesnt mean anything to me (am not a developer): uncaught exception. cannot tween a null target
jscher2000
  • Top 10 Contributor
8695 solutions 71066 answers

Thanks for checking that. I don't know what "tween" means. Hopefully a Mac user can get hands on with the site.

Thanks for checking that. I don't know what "tween" means. Hopefully a Mac user can get hands on with the site.
Roland Tanglao
  • Administrator
72 solutions 783 answers

Hi Robertjamesgibbs

This is not a user support question. It is web developer question and therefore it's not what support.mozilla.org is aimed at. support.mozilla.org is focused on user support.

In the future, if there are developer issues like this, please ask them on stack overflow and tag them 'firefox':

http://stackoverflow.com/questions/tagged/firefox+or+firefox-os+or+html5-apps

'tween' is a graphics term.

I tried your website on Firefox 25.0.1, Firefox nightly (currently 28) and Firefox 26 beta 10 for mac and it works fine for in FF 26 beta but not in Firefox 25.0.1

So this problem will be fixed in Firefox 26 which is scheduled to be released on December 10, 2013.

If there any developer issues like this in the future again please post them on stack overflow and tag them firefox

http://stackoverflow.com/questions/tagged/firefox

Hope that helps!

...Roland

Hi Robertjamesgibbs This is not a user support question. It is web developer question and therefore it's not what support.mozilla.org is aimed at. support.mozilla.org is focused on user support. In the future, if there are developer issues like this, please ask them on stack overflow and tag them 'firefox': http://stackoverflow.com/questions/tagged/firefox+or+firefox-os+or+html5-apps 'tween' is a graphics term. I tried your website on Firefox 25.0.1, Firefox nightly (currently 28) and Firefox 26 beta 10 for mac and it works fine for in FF 26 beta but not in Firefox 25.0.1 So this problem will be fixed in Firefox 26 which is scheduled to be released on December 10, 2013. If there any developer issues like this in the future again please post them on stack overflow and tag them firefox http://stackoverflow.com/questions/tagged/firefox Hope that helps! ...Roland