Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Save as" dialog box doesn't come up, even though I have "Always ask me where to save files" selected (email attachments)

  • 10 replies
  • 13 have this problem
  • 12879 views
  • آخر ردّ كتبه jscher2000

more options

Recently, the "save as" dialog box quit appearing when I attempt to download email attachments. I have the "always ask me where to save files" box checked in the tools/options/general/downloads area. The box still appears when I use Chrome, but not when I use Firefox.

Chosen solution

Is it a Yahoo! mail attachment? Common issue in recent weeks. Try:

  • Copy the address from the Chrome address bar to the Firefox address bar, and bookmark that new address, and delete your old bookmark

Any luck?

Read this answer in context 👍 0

All Replies (10)

more options

Hello,

Can you please follow these steps and provide the value for the configuration 'browser.download.useDownloadDir'

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.

Can you please provide the values for the following keys

  1. browser.download.useDownloadDir
  2. browser.download.lastDir

Thank you

more options

You can try to delete the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

gnittala:

browser.download.useDownloadDir;  user set  boolean  false
browser.download.lastDir   user set   string   I:\Excel\Rampart\Monterrey Village

Modified by cor-el

more options

The browser.download.useDownloadDir setting as false would mean that Firefox needs to prompt you for download actions. I will suggest you to try the option of deleting the mimeTypes.rdf file as suggested by cor-el. Please try that and let us know if it helped in resolving the issue.

Thank you

more options

I deleted the mimes.rdf file and it didn't help. I reset firefox on the troubleshooting page and it didn't help.

/
more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options

I started Firefox in safe mode and attachments still wouldn't download. I get a brief message saying "scanning an attachment" but then it goes away and nothing happens. As far as I can tell, nothing is downloaded, nothing is opened.

What really has me puzzled is that some days, it will work just fine for a couple of attachments, then it goes back to doing nothing. I assume it is a Firefox issue since I can still download email attachments on Chrome.

more options

Hello,

Is there an anti-virus running on your machine? If there is one running can you please check its activity log to see if it is deleting any of the downloaded files.

Thank you

more options

Chosen Solution

Is it a Yahoo! mail attachment? Common issue in recent weeks. Try:

  • Copy the address from the Chrome address bar to the Firefox address bar, and bookmark that new address, and delete your old bookmark

Any luck?

more options

Actually, instead of a bookmark, your home page address might be out of date, so you would need to update that. These articles have tips on that: