ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox 24.0 started crashing after I restarted my computer

  • 23 ردًا
  • 28 have this problem
  • 2238 views
  • آخر ردّ كتبه jscher2000

more options

I haven't used firefox since the update before this broke everything, I updated a few days ago and found it worked great like it did before on a site that is rather flash heavy. yesterday I restarted my computer and ever since then firefox has resumed hanging to the point of crashing on that site (and several others I use) like it did before.

I've already checked all my add-ons, extensions and theme, I checked to make sure all things that could possibly affect that are up to date, I've read everything I could find on here but they never help for more then a few minutes. I really REALLY like using firefox and hate the idea of having to use chrome again, help please? :(

All Replies (20)

more options

Hello,

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

Please report back to see if this helped you!

Thank you.

more options

Can you try to disable hardware acceleration, also before you ask, doing a clean reinstall keeps your bookmarks etc. since those are located in another folder in the system.

DISABLING HWA:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

more options

One thing that sometimes happens when you restart your computer is that some Windows updates or other deferred changes kick in.

If you haven't already, you may need to disable the Flash player plugin's protected mode. See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

more options

After updating to 24.0, Firefox crashes when I enter f.ex. Google Maps or similar sites. I'm supposed to remove Firefox and reinstall ?? No way. Mozilla must fix this problem ASAP !!But if I have to, how do I export bookmarks ?? Until you do, I´ll use IE :-)

more options

Hi Svenne, you may not have to reinstall at all.

Can you start a new thread with some additional information about your system and crashes? When you submit crash reports to Mozilla, code are created that you can post here so volunteers can see more information about the crashes and hopefully gain insight into how to stop them.

more options

Here is the code :

AdapterDeviceID: 0x0166 AdapterVendorID: 0x8086 Add-ons: %7B2D3F3651-74B9-4795-BDEC-6DA2F431CB62%7D:2014.5.1.4,%7BBBDA0591-3099-440a-AA10-41764D9DB4DB%7D:12.0.0.380%20-%201,%7B080955ad-b8bb-4500-806f-d2b9ad73d72e%7D:2.0.20,%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D:2.3.2,langpack-en-GB%40firefox.mozilla.org:24.0,en-gb%40flyingtophat.co.uk:1.19.3 AvailablePageFile: 30243119104 AvailablePhysicalMemory: 13946314752 AvailableVirtualMemory: 3430060032 BuildID: 20130910160258 CrashTime: 1380697658 EMCheckCompatibility: true Email: svend80@gmail.com InstallTime: 1380614538 IsGarbageCollecting: 1 Notes: AdapterVendorID: 0x8086, AdapterDeviceID: 0x0166, AdapterSubsysID: 00000000, AdapterDriverVersion: 9.17.10.3040 Has dual GPUs. GPU #2: AdapterVendorID2: 0x10de, AdapterDeviceID2: 0x0fd2, AdapterSubsysID2: 00000000, AdapterDriverVersion2: 9.18.13.546D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384} ProductName: Firefox ReleaseChannel: release SecondsSinceLastCrash: 710 StartupTime: 1380697402 SystemMemoryUsePercentage: 18 Theme: walnut2 Throttleable: 1 TotalVirtualMemory: 4294836224 URL: https://maps.google.dk/ Vendor: Mozilla Version: 24.0 Winsock_LSP: MSAFD Tcpip [TCP/IP] : 2 : 1 :

MSAFD Tcpip [UDP/IP] : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
MSAFD Tcpip [RAW/IP] : 2 : 3 :  
MSAFD Tcpip [TCP/IPv6] : 2 : 1 : %SystemRoot%\system32\mswsock.dll 
MSAFD Tcpip [UDP/IPv6] : 2 : 2 :  
MSAFD Tcpip [RAW/IPv6] : 2 : 3 : %SystemRoot%\system32\mswsock.dll 
RSVP TCPv6-tjenesteudbyder : 2 : 1 :  
RSVP TCP-tjenesteudbyder : 2 : 1 : %SystemRoot%\system32\mswsock.dll 
RSVP UDPv6-tjenesteudbyder : 2 : 2 :  
RSVP UDP-tjenesteudbyder : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
MSAFD RfComm [Bluetooth] : 2 : 1 : 

Denne rapport indeholder også teknisk information omkring programmets tilstand da det brød ned.

It crashes all the time. However no problem, I use IE instead :-)

more options

Hi Svenne, that's very hard to read. Can you post the crash ID codes instead? Those link up your crash data with data on other users' crashes and the bug tracking system.

If necessary, start Firefox in its Safe Mode. To start Firefox in Safe Mode (a standard diagnostic tool to bypass interference by extensions and some custom settings, see Troubleshoot Firefox issues using Safe Mode), hold down the Shift key when starting Firefox.

In the dialog, click "Start in Safe Mode" (not Reset)

By the way, if you have any Norton extensions, there are known problems, so disable them here:

orange Firefox button (or Tools menu) > Add-ons > Extensions category

Also, you might want to edit out your email address from that last post, as spambots may discover it here.

more options

Where do I find them ??

more options

Hi Svenne, try the about:crashes screen as mentioned in this section of the article: https://support.mozilla.org/en-US/kb/firefox-crashes-troubleshoot-prevent-and-get-help#w_get-help-fixing-this-crash

more options

OK here they are :-)

bp-bf9a8376-4917-4ede-bdb8-639a72131002 02-10-2013 19:40 c9ef9960-54b0-48c2-b022-3ff869ce3dcf 02-10-2013 19:36 bp-bd8fa3d2-00f0-4167-aa25-e2cae2131002 02-10-2013 18:30 bp-da3fa444-d4c4-4e69-b354-566d02131002 02-10-2013 17:49 bp-33c0b191-ad0e-46ae-b287-d84ac2131002 02-10-2013 16:44

more options

Hi Svenne, thank you for those. Maybe I should have answered your question "Where do I find them" with respect to your Norton extensions. Open the add-ons page using either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions and you should find them and be able to Disable them here.

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.


Some of the crash reports refer to scripting related issues, but rather than tryh to change a bunch of things at once, please see whether the above is helpful.

more options

turning off hardware acceleration has slowed down how fast it starts to hang, but it still hangs to the point of crashing

I shall try disabling the safety thing with flash before doing a clean install

more options

Hi Jefferson. First of all. We have a sort of "saying" here in Denmark ; Don't get stressed up over things, that aren't important, and things you cannot do anything about here and now". Such as bad weather, heavy traffic or a delayed train. It's not good for your health! I'm sure, that the problem will be solved, eventually, and everybody will be happy. However, I have no intention to turn off Norton, or any other application, for that matter. I've used Norton and Firefox side by side for ages, and will continue to do so. The problem is Firefox, not Norton. They have been "together"on my computer for as far back as I can remember. And finally, Firefox crashed maybe once or twice a year before I got the 24.0 update. Yesterday and the day before, Firefox crashed 24 times !!, after I got the update ! So, take it easy, solve the problem, when you can. Meanwhile I will use IE, if I want to make a close study over places I've been in Google Maps. Imagine. I got this silly app (my routes) on my phone. It tells me where I've been - in Google Maps ?? I know where I was, I know the places - good memories in my head, so what's the point ?? No more of this silly app. :-)

more options

Hi Svenne, I'm not suggesting you disable your Norton software at the system level, just the Norton add-ons in Firefox. Or you can upgrade to the 2014 version of your Norton software.

If you are not in a rush to use Firefox, you can wait for Norton to update them. You can monitor this thread for updates: Re: Firefox 24 still crashes when the NIS toolbar is enabled - Page 14 - Norton Community (status the evening of 10/2/2013: "The fix for the FF24 crash is so far only posted for the 2014 products. We are working on a patch for 2013, 2012 and the standalone product. They shoudl be available shortly.")

Modified by jscher2000

more options

Hi Jefferson. I've updated Norton 360 just a few minutes ago, as I did Monday or Tuesday. It seems that they have launched several updates in that short period of time. The result ? I'm running Google Maps, and no crashes !! I want to thank you (and the team) for your patience. You have really helped. I have bookmarked the Norton page - just in case. Thank you, case closed (?) and have a very good day :-)

more options

I've returned with something I found after I went through my add-ons again. I realized that I only checked the add-ons that I myself had added.

I disabled the skype click to call add-on that came with firefox 24.0 and found that it was to blame for the instability I was experiencing.

I have not had an issue with hanging to death since I disabled it and my firefox is now functioning the way it used to :)

I hope what I figured out helps others with the same issue and that maybe mozilla can figure out it's cause

thanks for all your help :D

more options

Hi KnightBlade, thank you for reporting back.

Firefox doesn't include Skype Click to Call, but you may have the Skype application on your system. Applications like Skype can add extensions to Firefox by placing files in certain shared folders or by adding entries in the Windows registry. Firefox may warn you when this happens so you are aware of a new extension being added, but it seems this doesn't happen in every case.

more options

I had had skype at one point, but was fairly certain I removed all of it

sneaky programs >__>

more options

This issue started for me yesterday - consistently. Nothing new was installed. The only Flash in operation is Google ads, yet they are constantly crashing FF. I open Chrome, I have no issues.

I've always preferred FF because of the development tools however these buggy things are getting to be a PITA. :(

Modified by bcr8tive

more options

Hi bcr8tive, in another thread, some users reported a persistent issue with the new Flash 11.9. You could try rolling back to Flash 11.8. Please see: Flash player keeps giving error.


When Firefox or a plugin crashes, you have the option to submit data to Mozilla. If you've done that, then a forum volunteer usually can review your crash data if you can post a crash ID. The last section of this article describes how to find those crash IDs: Firefox crashes - Troubleshoot, prevent and get help fixing crashes.


More generally, the Flash Player plugin may suddenly start failing due to changes in your graphics drivers or Windows updates. This is some standard guidance that addresses the most common issues with the Flash Player plugin. I'm sure you've seen some of it before, but just in case:

(1) If you have any recorders/downloaders that interact with Flash media make sure they are as up-to-date as possible, or disable them temporarily.

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista and higher)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

Any luck?

Modified by jscher2000

  1. 1
  2. 2