ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Seemingly weird behaviour of awesome bar.

  • 11 ردًا
  • 4 have this problem
  • 111 views
  • آخر ردّ كتبه John99

more options

I want to use the awesome bar to go to a webpage if the address given is a valid one or in other case search the selected search engine (much like google chrome's awesome bar). This seems to work fine in some cases. Like, if I type "search bar", it takes to google web page. If I type "what", it says "Requested URL could not be retreived". How is it that it behaves differently for two different queries?

الحل المُختار

Did you check the settings for searching via the location bar?

In Firefox 23 versions and later the keyword.URL pref is no longer supported and it is no longer possible to specify the search engine for the location bar via the keyword.URL pref.

For one word searches Firefox will try a DNS look up, so that fails and keyword.enabled is false and the web page can't be resolved then you get this error message.

Read this answer in context 👍 1

All Replies (11)

more options

Hmm go to addons.mozilla.org and install the "omnibar" addon, works just like chrome.

more options

My problem is not to imitate the omnibar of chrome. Why is it that awesome bar is behaving differently for two different queries? Is it some bug? Or is it intended? P.S: Until recently I used the same addon. Today, I disabled it just to check the awesomeness of the awesome bar.

more options

The search engine that is used on the location bar and on the about:home page is the search engine that is selected in the search Bar on the Navigation Toolbar.

You can install the Keyword Search extension to specify with search engine to use for the location bar and which search engine to use for the about:home page via the Options/Preferences windows of this extension, accessible via the about:addons page.

Also check that the keyword.enabled pref is set to true on the about:config page.

more options

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • Open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Please report back soon.

more options

The problem persists in Safe Mode also. What does this imply?

more options

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.


Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

more options

Sorry, I use Ubuntu and I don't have any problems with any other things. Even now, other things work fine with Firefox except this. And this came out only when I disabled Omnibar extension. So, doesn't that mostly rule out the chance of virus affection?

more options

I even tried to reset firefox and still the problem persists.

more options

الحل المُختار

Did you check the settings for searching via the location bar?

In Firefox 23 versions and later the keyword.URL pref is no longer supported and it is no longer possible to specify the search engine for the location bar via the keyword.URL pref.

For one word searches Firefox will try a DNS look up, so that fails and keyword.enabled is false and the web page can't be resolved then you get this error message.

more options

Yeah, you are right. Every two word query works fine and every one word query gives the error.

more options

I think you are getting the expected behaviour, as explained in corel's posts. There is probably no need to think about looking for malware.

Maybe if you previously used an add-on you did not notice the change but it is new in Firefox 23 that the location bar uses the search selected in the search bar.

Some of these comments are probably of more use to other readers of this thread.
If you wish to change how the search works try using an addon. It is possible to change the situation so it behaves more the way it did prior to Firefox 23