Search Support

Keyword.url + Browse By Name is broken in FF23

  • 23 replies
  • 54 have this problem
  • 4120 views
  • آخر ردّ كتبه YanMetal

more options

My Mac's Firefox is notifying me that it wants to be updated to v23. But the keyword url string breaks in FF23 on Windows and as I use both mac and Pc, I need it to work on both every time.

Keyword.url and Google's Browse By Name is how I use the internet, it's not a feature, it's a requirement.

What can be done to resolve this?

Thanks!

Chosen solution

https://addons.mozilla.org/en-US/firefox/addon/keyword-search/ has been updated to support browse by name, please uninstall any other add-ons you installed to replicate this functionality and use this.

Read this answer in context 👍 0

All Replies (20)

more options
more options

The keyword search addon brings such functions back.

more options

Starting with Firefox 23 the keyword.URL pref is no longer supported and it is no longer possible to specify the search engine for the location bar that way.

The search engine that is used in the location bar is the search engine that is selected in the search Bar on the Navigation Toolbar.

See also:

more options

Its... close but not completely solved yet.

keyword search only works for one word which is only half of what I do.

I need multi-word browse by name.

more options

A possibility is to disable keyword search (keyword.enable = false) and use a (one letter) keyword search for searching via the location bar.

You can set a keyword for an installed search engine via Manage Search Engines (click the search engines icon on the search bar).

See also:

more options

It doesn't work, same error:

The address isn't valid The URL is not valid and cannot be loaded. Web addresses are usually written like http://www.example.com/ Make sure that you're using forward slashes (i.e. /).

more options

I'm not sure what your reply is referring to.

When do you get this error?

What are you typing or pasting in the location bar?

more options

I know it better as the address bar, but in a brand-new mint Fox 23 with the addons suggested. If I use one word, it works fine, but when I add a second, the URL error happens. (see photo)

In FF 22, Browse by Name would take me straight to http://discussions.apple.com

more options

Do you have the keyword.enabled pref set to true?

more options

Yes, it is set to true.

more options

Chosen Solution

https://addons.mozilla.org/en-US/firefox/addon/keyword-search/ has been updated to support browse by name, please uninstall any other add-ons you installed to replicate this functionality and use this.

more options

The setting to use the Browse by Name feature isn't on the initial screen you get when you install the add-on. Instead, go here:

orange Firefox button (or Tools menu) > Add-ons > Extensions category

Click the Options button for the Keyword Search extension

Then toward the bottom of the pane, you can change from the default Google search to Browse by Name.

Any luck?

more options

Updating the Keyword Search puts browse by name in the little google bar to the right. (inconvenient on high-res screens)

But the Awesome Bar (URL Bar) still doesn't support multi-word BBN queries.

Mozilla, why did you make this so hard?

more options

You can disable automatic searching via the location bar by setting keyword.enabled to false and use a (one letter) keyword search to use a specific search engine instead to search via the location bar.

You can set a keyword for an installed search engine via Manage Search Engines (click the search engines icon on the search bar).

You can also set a keyword to a bookmark.

That also allows to switch easily between search engines when searching via the location bar and you also do not have a problem with one word searches.

Modified by cor-el

more options

Never mind, didn't read everything.

Modified by jscher2000

more options

Cor-el,

I need this to be a set-once and never have to worry about again kind of setting. The number of BBN queries I do every day for my job/personal/research is very high.

I can't add a g to everything I type in the URL bar to make this work, my queries go really deep on websites, (contact, calendars, forum sub-levels, etc.)

I need help to reconfigure FF23 to work like it did in version 22, but being that I don't know what was changed, I don't know how to configure it to use BBN natively.

That's all I need, just to restore full BBN in the URL Bar and I will be happy.

Otherwise, I will be forced to use 22... forever.

more options

Hi chattphotos, what settings do you have in the extension's options? These work for me (Google in search bar, BBN in address bar): https://support.mozilla.org/questions/967523#answer-469514

more options

After a restart of the computer it's working now.

Attached is my settings that run how 22 did.

Thanks for the followup :)

Fingers crossed this never happens again!

more options

I have a problem like this in my version of FF for Mac If I do a search for just one word, like "house" in the address bar I fall into a dns error pages of my web server. If I try to search for two words, it looks perfectly in google. This has bothered me a lot and it does not happen in the Windows version. I'm almost moving to safari or chrome pro because this bummer.

I tryed instal keyword Search but problem persist

more options

Hi YanMetal, unless your regular DNS servers are truly amazing, you could consider using other ones, such as:

  • Google Public DNS
  • OpenDNS

Also, it's odd that Mac and Windows behave differently on the same network. I wonder why that is?

  1. 1
  2. 2