ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Tools and Help is missing from my menu bar.

  • 15 ردًا
  • 15 have this problem
  • 31435 views
  • آخر ردّ كتبه pfrancis

more options

All I can find is how to add the Menu bar which I have; what I'm missing are the Tools and Help menus. I have updated to version 21, and it's still missing. How do I find those 2 missing menus?

الحل المُختار

jscher2000: I tried your suggestions, but still doesn't work.

I chose Reset when Shift & double-clicking on the desktop icon (and not Safe Mode) and that worked. Someone had previously mentioned not to do this, but there didn't seem to be any other option.

I have lost all my add-ons, but my bookmarks are there.

Main thing is that it worked!!! I've never experienced so much grief trying to get something fixed. I think I might move on to a different browser.

Read this answer in context 👍 0

All Replies (15)

more options

You do have the menu bar, with File Edit View History Bookmarks... , but the two items - Tools and Help - are missing? Do I understand it correctly?

Modified by smo

more options

Please update to the current Firefox 22.0 release.

  • Help > About Firefox

The Firefox 21 version that you currently run is no longer supported with security updates.

  • It is important to update Firefox and add-ons to the latest version to get all security fixes.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

You get the orange Firefox menu button when the menu bar is hidden.

  • Firefox menu button > Options
  • View > Toolbars (press F10 to display the menu bar)
  • Right-click empty toolbar area

See also:

more options

Yes, that's correct.

more options

I have updated to version 22.

I'm unable to start in Safe Mode as I don't have the "Help" menu, which is what my issue is.

'Help' and 'Tools' are missing from the Menu Bar. (I have File, Edit, View, History, and Bookmarks.)

more options

You can enter the Firefox SafeMode by holding the Shift key when double-clicking on the desktop shortcut for Firefox. Don't select anything except Open in SafeMode.

more options

Thanks for the tip the-edmeister for Open in SafeMode.

I tried all the suggestions, but still can't locate the two missing menus, Tools and Help, when not in Safe Mode.

What happens if I reset? Will I lose my bookmarks?

more options

Hi pfrancis, you should still have your bookmarks after a reset. Check out this article for more details: Refresh Firefox - reset add-ons and settings. Your old settings will be archived to a folder on your desktop. (I recommend keeping that around for a few weeks in case you need to rescue anything from it.)

If you want to try one other thing first, you could clear your toolbar customizations file. This file might affect the menu bar as well. Here's how:

Open your current Firefox settings folder (AKA Firefox profile folder) using

Help > Troubleshooting Information > "Show Folder" button

Switch back to Firefox and Exit

Pause while Firefox finishes its cleanup, then rename localstore.rdf to something like localstore.old

Restart Firefox. Is the menu bar better?

If not, and you want to restore your customizations, you can reverse the above process (delete the newly created localstore.rdf and rename localstore.old to localstore.rdf).

more options

I have 2 problems: 1. I have no menu bar at all (no help, edit, file, view.history, tools) NONE If I right in blank space - no navigation toolbar appears; if right click there is no customise or no menu bar. NONE OF THESE SHOW

2. When I installed firefox, there is an index which has attached to the url of a company website which I desperately need to access, but I cannot, because when I type in company url, an index appears instead- how can I get rid of this index?

I tried uninstalling whole program, then reinstalled - I still have the same page/problems ?

more options

Hi anniespahic, if you have no menu or toolbar area at all, you might be in full screen mode. The F11 function key switches between regular and full screen views. You might also get a menu to exit full screen view if you slide your mouse all the way to the top of the screen and right-click.

If you have a toolbar area but no menu, try tapping the Alt key to show the menu bar temporarily. Then you can re-display the menu bar using

View menu > Toolbars > Menu Bar

(I'm assuming Windows; this might work differently on other operating systems)

Can you get your menu bar back?

Regarding #2, I'm not sure what you mean by index. Is the problem that the page lacks the normal styling (i.e., shows raw text instead of menus)?

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

more options

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

more options

I've attached a screenshot.

more options

Hi pfrancis, if I understand everything so far, the menu is normal for you in Firefox's Safe Mode, but not in normal mode.

I assume you did not try the Reset yet.

If you prefer a little more pre-Reset troubleshooting, can you access your settings folder as follows? Open a new tab and type or paste about:support into the address bar and press Enter, you should have the option to "Open Folder". This will display the contents of your currently active Firefox profile folder (personal settings folder).

  • Check for a userChrome.css file (an optional file of style rules that can modify the Firefox UI). This would be in an optional chrome subfolder. If the folder doesn't exist, or if it doesn't contain a file named userChrome.css, then we can rule out this theory.

If the menu is still modified, it could be due to one of your extensions. You can review and disable ALL nonessential or unrecognized extensions by opening a new tab to about:addons then clicking into the Extensions category.

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does any of that fix it?

more options

الحل المُختار

jscher2000: I tried your suggestions, but still doesn't work.

I chose Reset when Shift & double-clicking on the desktop icon (and not Safe Mode) and that worked. Someone had previously mentioned not to do this, but there didn't seem to be any other option.

I have lost all my add-ons, but my bookmarks are there.

Main thing is that it worked!!! I've never experienced so much grief trying to get something fixed. I think I might move on to a different browser.

Modified by pfrancis

more options

Hi pfrancis, I'm glad you got it fixed.

The Old Firefox Data folder on your desktop (created by the Reset feature) might be useful for recovering add-on data or settings, although we have to be very selective in copying files from it to avoid causing the problem all over again. Anyway, I recommend hanging onto it for a while until you're sure you won't need it again.

more options

Hi jscher2000.

Yes, you did mention that previously, thanks, I had forgotten.

I'll just add them back manually so I don't recreate the problem again, but at least I can see which ones I had.

Thanks.