ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

My firefox is huge all of a sudden, why?

  • 38 ردًا
  • 10 have this problem
  • 670 views
  • آخر ردّ كتبه EPS23

more options

My firefox has been fine, then all of a sudden last night i went ot open it and everything is huge, i goto facebook and the facebook logo is half cut off, the font is huge, and its annoying, how can i fix this?

الحل المُختار

Hi jcit89, after further testing, I think there is a problem specific to Facebook (I only checked the home page). I only discovered this after using Ctrl+Shift+r to reload the page bypassing cached files.

If I set layout.css.devPixelsPerPx=1.25, then I have to zoom down twice (Ctrl- twice) and hard reload the page (Ctrl+Shift+r) in order to fix the layout.

If I set layout.css.devPixelsPerPx=1.0 AND use Facebook without ANY zoom, then there is no problem after a hard reload. However, using zoom also breaks the layout. I think this might be a new issue.

Read this answer in context 👍 1

All Replies (18)

more options

this is what it looks like.

more options

how it should look..

more options

jcit89, I am with you on this all the way! It is an annoying problem with no apparent simple solution and it should have been set up as an option, not as a forced default.

I've spent too much time today already trying to find and test solutions and it is just annoying.

I have tried two add-ons, but with disappointing results:

- Default FullZoom Level 5.8, but you have to use it on every new site you click on to. I can do THAT faster by using the ctrl -/+ keys.

- NoSquint: You have to do a LOT of trial and error with the controls and I have not liked any of the results. Also, if I go off of a page (go to a different tab) and come back to that page (tab), the page display has returned to the unwanted large default setting and I have to refresh the page to get it to go back to the NoSquint setting.

While there have been previous Firefox changes I have not liked, this is the first time that I have been so annoyed that I am considering going to a different browser.

This change/update should not have been a forced default. It should have been set up as an EASY option.

Or, if this change is truly advantageous to so many people, then it should have come with an EASY to apply global option for those of us who don't want to adjust the settings every single time we go to a web page.

GT :-|

more options

agreed gt, now we are expected to turn into home made developers in messing with all these codes and addons, and yes it is very annoying to change the zoom level for every website, i would go back to chrome, but the tabs never load correctly on there.

more options
more options

ive tried htat, it fixes the font but not the layouts of the sites.

more options

Refresh Firefox - reset add-ons and settings then change. Fx22layout.css.devPixelsPerPx again.

Sorry to have to put you up through this mess but trying as hard as i can.

more options

Please make this DPi scaling detection optional guys.

more options

if you want to give feedback use

You may even discover a forum where such a subject is considered on topic and where a developer may read the comments.

I am sure Firefox could have handled this change better, but all we do on this Forum is try to help users with problems.

more options

Thank you John99.

more options

jcit89,

The first reply in this thread should have resolved this. Did you try the fix suggested.

more options

yes, i tried everything in this thread to no avail.

more options

Modified by kobe

more options

I have the exact same issue.... only not all the pages are that huge.... Facebook is the worst, Google is quite large and mozilla pages are larger than they should be. I checked out a few others that seemed normal, but chances are others would show up eventually that are huge. I agree with annoying to have to change the setting each time, and with the Facebook it does't seem to hit where I had it before, it's either too large or too small. If it stays this way I will be forced to use something else. IE only as a last resort....lol I love Firefox, have used it for a very long time, but the only way something like this should "have been in Firefox years ago" is if it was as an option. They are still millions of monitors out there that are not high res.... heck they are still many corps out there running 2003 programs. Nothing wrong with that, they work fine. It is too annoying of an issue to "just implement it and for those that it bothers, to find a fix for. I would rather not have to find a different browser, but I may have to

more options

Hi jcit89, another user posted a similarly messed up Facebook screen: https://support.mozilla.org/en-US/questions/959696?page=5#answer-451659

However, while it was fine in a new profile, we still haven't discovered what is breaking that layout (I think you're the third user to report it).


One of the differences between Firefox's safe mode and regular mode is that any userContent.css file is ignored in safe mode. Can you check whether you have such a file? If you do it would appear in your personal settings folder, which you can open using:

Help > Troubleshooting Information > "Show Folder" button

Is there a folder named chrome? If so, look in there for a userContent.css file. If you find one, what rules do you have?


Another possibility is that somehow the logo is especially zoomed up because it is on a content distribution network that has its own much too high zoom level. If you open this graphic and reset zoom using Ctrl+0 (that's a zero) does it make any difference?

https://fbstatic-a.akamaihd.net/rsrc.php/v2/yh/r/xQ0DwmqUr-m.png

Actually, your CDN may vary, so you can check the URL using the Page Info dialog. Either:

  • right-click the page > View Page Info > Media tab
  • Tools menu > Page Info > Media tab
more options

الحل المُختار

Hi jcit89, after further testing, I think there is a problem specific to Facebook (I only checked the home page). I only discovered this after using Ctrl+Shift+r to reload the page bypassing cached files.

If I set layout.css.devPixelsPerPx=1.25, then I have to zoom down twice (Ctrl- twice) and hard reload the page (Ctrl+Shift+r) in order to fix the layout.

If I set layout.css.devPixelsPerPx=1.0 AND use Facebook without ANY zoom, then there is no problem after a hard reload. However, using zoom also breaks the layout. I think this might be a new issue.

more options

Thank you. My entire "overlarge" font and images problem was fixed completely when I used the "control and 0" option. Now I wonder what the pixel setting was before I changed it to 1.0? As I might need to revert to it. Thanks again. My site looks just fine now! EPS23

  1. 1
  2. 2