X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 22 running very slow on windows 7 but no problem in linux. Help

Posted

Firefox 22 is running very slow ( rather stalling forever) on windows 7. I tried resetting option from the "Troubleshooting information" menu and also tried disabling "Hardware acceleration" but still having the problem. Takes almost a minute ( "New window not responding"..) just to try any option..like opening a new tab.

I have same version on linux mint and but FF runs smoothly.

Additional System Details

Installed Plug-ins

  • Java plug-in for NPAPI-based browsers.
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version: 4.0.3.0
  • This plugin provides integration with Cinnamon for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • Shockwave Flash 11.2 r202
  • The Videos 3.6.3 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

It is possible that your security software (firewall, anti-virus) blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

mfjames 1 solutions 11 answers

Same problem here. Loading FF22 takes just under 4 .5 minutes!!! Loading FF21 on the same machine takes 7 seconds.

Combinie that with the wacky decision to play around with the screen resolution, so that either I can't read any of the UI text because it's too small, or I have to stand at the end of the street to read the main window because it's too big -- and FF232 is simply a disaster. I have given up, gone back to 21 and turned off automatic updates. It may only be a matter of time before I say good-bye to Firefox for ever. I think it's lost the plot.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Modified by cor-el

mfjames 1 solutions 11 answers

Helpful Reply

Sorry, not an option. As I said, I have binned FF22 and gone back to 21 -- and it works just as fast as it always did, corrupt profile or no corrupt profile.

woojohn 2 solutions 13 answers

Helpful Reply

the problem is the flash player, not firefox. To fix the problem:

1. to go to a website that have a flash video, such as youtube 2. right click on the video then select "global settings", this will open up the flash player setting manager 3. click on the advance tab 4. under "browsing data and settings", click "Delete All".

that is it , u will notice firefox wil run smoothly once again. if after some time firefox slow responding again, just do the same thing to fix it. goodluck!!!