ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Pages and icons (in the tabs and navigation bars) are too big due to 22 upgrade

  • 63 ردًا
  • 90 have this problem
  • 17365 views
  • آخر ردّ كتبه FunkyB

more options

Due to FF22 upgrade (from 21), all my icons (from webpages, addons and regular buttons) and tabs have got bigger and that's really ugly because of the low resolution of the images. Also considering I have a rather big number of tabs I can just see a smaller number of them and it's annoying. The zoom of the page is now bigger (given that I has already zoom in in version 21, now the pages are too big and I have to zoom out a page that was correctly zoomed in 21) Surprisingly the menu bar is intact !

Is that a new graphic convention ? Is there an update of something like GTK+ in this new version that could be responsible of this bug ? And mainly is there anyway to fix it ?

My screen resolution is 1920*1080. And for example with chromium or FF21 the menu have the perfect size.

PS: Sorry for my poor English.

Modified by flofl0

الحل المُختار

hello, firefox 22 is now respecting the pixel density you've set on a system level in the windows control panel > appearance > display. more information about that is availbale at http://windows.microsoft.com/en-us/windows7/make-the-text-on-your-screen-larger-or-smaller

if you want to set the text size/pixel density in firefox different from that of your system's settings like it was handled in prior versions, enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named layout.css.devPixelsPerPx. double-click it and change its value to 1.0 (or any other zoom factor that fits your purpose; -1.0 is the default value and will adhere to the system settings).

Read this answer in context 👍 25

All Replies (20)

more options

hello lovelac7, i'm not aware of any particular existing bugs that would cover this, but if there is a genuine issue with the display change not working as intended (firefox not scaling according to the system settings or UI & web content scaling differently after setting layout.css.devPixelsPerPx to 1.0 for example) it is certainly possible to follow that up with a bug report.

however in such a long thread it is hard to troubleshoot individual issues & separate between users who just want to voice their discontent with the new default behaviour or who might observe a real bug (as you've described above) and to diagnose that properly.

therefore i'd ask you to open a new question including your system's dpi/scaling settings, you monitor's resolution, the common troubleshooting information that is requested during the process and maybe also screenshots that show the difference between layout.css.devPixelsPerPx at -1.0 and 1.0.

more options

Hi jlford001, you wrote:

Media queries are not the answer to this - they target the display size of a window, not the zoom level of a browser.

The specification for media queries has been extended: the demo pages I linked use dpi ranges as the criteria for applying style rules. Perhaps that is impractical for your current sites, but I suspect this will be increasingly important going forward.

Regarding a banner, if a site has a horizontal scroll bar, I don't think users would be too annoyed by an infobar mentioning that they can adjust the window page or the zoom level to get rid of the scrolling. But yes, a responsive layout would be better.

more options

Until now, i actually thought that my computer had somehow messed up firefox or maybe there was a bug during the update. xD Seems everyone got this issue. Wow... i almost cannot believe this! Doing that config+font changer thing got it back to looking acceptable, but i'd really like it to look good out of the box! What if i forget how to change the settings and something (new update, whatever) screws it up again? Meh...

Btw, i got my windows zoom set pretty high (not sure on what setting) and i used to zoom in pages too, but i still dislike this change. ._." They should rather make some sensible options people can set in firefox's settings than switch around sizes all randomly.

edit: Huh? Did the text really get a little blurry now? Maybe it's just my imagination... ôo

Modified by Saikoro

more options

Please do not make changes to font sizes etc. when giving us upgrades of Firefox. I use the internet +/- 12 hours a day and sudden changes like that is freaking annoying. Thanks for a wonderful product.

more options

My solution is to uninstall FF 22 and go to filehippo.com and download FF 21 and install it. Then in Options, Options, Advanced choose "Never check for updates". One drawback is that FF 21 is no longer supported, therefore you could choose to use FF 17.0.7 ESR available here http://www.mozilla.org/en-US/firefox/organizations/all.html which is supported until December 3rd, 2013.

more options

One of the main criteria I use in choosing a web browser is its ability to properly render the web pages that I go to most. If FF doesn't make it EASY to render pages properly, I may be forced to use Google Chrome or Internet Explorer. I've used FF for many years and would like to keep it as my main browser, but this one issue may force me to switch from FF. For now, I'm sticking with FF version 21 but this is not a long-term fix. Maybe the development team doesn't care about users like me or the market share that FF has. But, if users are required to jump through hoops in about:config to properly display a web page, most people will not bother. Instead they will switch to Chrome or IE, set the magnification to 125% and start browsing without any problems and FF will lose another user.

more options

In FF options, there is a box that when UNCHECKED, prevents individual web pages from adjusting your preferred font sizes. This way, you can set your browser to meet your wants & needs. Individual web page creators can't mess around (and we all know they do that). Firefox > options > Content tab > click the ADVANCED button > UNCHECK the box that says "Allow web pages to choose their own..."

In this same area - the fonts section of the content tab in FF options - you can set the default font size AND the maximum & minimum font size, as well.

I also installed the NoSquint add-on. Go to FF add-ons & search for NoSquint & install it. After restarting FF, go to the page that has the problematic display size (mine was gmail). In the lower right of the FF window, click on the magnifying glass. It opens the zoom settings. Adjust the full-zoom & text-zoom until the page displays as you like. Note the levels you just set. Then click on the Global button in the lower section of the same area. Make the Global settings to match what you just did to the individual page.

Installing NoSquint is MUCH easier than any other fix I tried - and I tried a bunch.

Modified by CynthiasHere

more options

This was a terrible idea on Mozilla's part. How many people have high density displays right now? 1% of the population? 10% maybe? I understand wanting to move forward with technology, but wait until it has a high adoption rate before implementing sweeping changes that affect all your users. EVERY page I look at now looks like it was designed for 640x480 and has been upscaled to 1920x1080. I'm sure there are a ton of furious designers out there because your browser just made their websites look like absolute crap BY DEFAULT. Instead of suggesting that the MAJORITY of users change their settings to make things look right and instead change the default back and make the FEW with the high density displays change their settings? I can't believe this was implemented and released without at least ONE person on the staff thinking this was a horrible idea.

more options

[mis-post deleted]

Modified by FunkyB

more options

"it is hard to troubleshoot individual issues & separate between users who just want to voice their discontent with the new default behaviour or who might observe a real bug"

The "new default behavior" is a bug in and of itself because now either web pages or the GUI don't display properly -- you can only have one or the other and you have to hack the browser just to get that far.

Also, it is incorrect to call this "default" behavior because that implies that there is a way to disable it. If that was the case, this would not be an issue.

There are dozens of threads now documenting many different ways in which people are affected by the bug, but a bug it is. Please realize that and give us a way to properly disable the offending code. My web browsing experience is just not the same without FF.

more options

if you don't want elements to be zoomed then set the windows display size to 100% in the control panel. upcoming versions of IE and chrome will adopt the same behaviour too...

more options

I've been watching this thread since the release of version 22 and it just keeps getting more confusing. I had to go back and re-install version 21 in the hopes that another new version would make it so I don't have to screw up my PC trying to get the screen right.

If fixing version 23 is a matter of adjusting the windows zoom, does that mean the problem I was experiencing with version 22 would go away?

I don't want to get left in the dust and I don't want to change my browser, but I can't go along with version 21 forever. I didn't even install version 23 yet for fear it would make the previous problems even more difficult to overcome.

I'm an old lady that just likes to spend time browsing and playing a few word games. I can use the drop down menus for the commands they offer, but when it comes to entering code into command windows, that's where I have to draw the line. I can't believe the purpose of the new versions of FF are intended for this to be necessary. So, does anyone know what would happen if I went ahead and installed version 23?

Thanks for any help offered.

@funkyb- thanks for the reply below

Modified by delilah

more options

Setting the Windows display size to 100% makes Windows Explorer and other applications too small. The problem is the way that FF uses the system DPI; it forcibly blows up everything by that percent with no easy way to reset the zoom, or independently adjust the GUI and workspace zoom. This causes webpages to be unpleasant or even difficult to use.

In contrast, menus and icons in other applications don't become blurry when the DPI is 125%, nor is the default zoom of the workspace affected. That goes for everything from Word 2010 to the GIMP. I doubt that IE and Chrome will implement DPI awareness without any way to reset the zoom to native 100%, or tie the GUI zoom to the default page zoom.

The bottom line is that in practice, the current implementation in FF is a disaster for most users and there needs to be a way to disable it or better yet turn it off by default without voiding the warrantee. I mean, how many posts are there from people who think the new behavior is a plus?

more options

@faith552: Version 23 handles zoom the same as 22, so it shouldn't make any difference. Adjusting the Windows zoom, however, will make everything else on your system a different size, and is a non-answer to the problem. If the Windows zoom was good at 100% then we wouldn't have changed it in the first place.

more options

you can test it yourself in the IE 11 preview or chrome 30

you can change the appropriate setting in firefox through about:config (which isn't a command line but another more technical interface for the firefox preferences). the part about voiding your warranty while entering about:config is a joke - firefox is free software and doesn't come with a warranty. the message should just remind you to know what you're doing and not to change any random preferences.
setting layout.css.devPixelsPerPx to 1.0 is well documented here in the support foum and shouldn't cause any issue.

more options

Window zoom IS set to 100%, in Chrome and IE, everything displays at a 1:1 ratio. Even single images that are not inside webpages are affected, for instance, I have an image that is 100px wide. In Chrome and IE, it displays at 100px but in Firefox, it's 120px wide and looks crappy and upscaled. No amount of CTRL 0 will fix it, and CTRL - only seems to downscale the upscaled image, and STILL doesn't display it at exactly 100px. Something is broken.

more options

please double-check in the windows control panel that (depending on your version of windows) the default display size of elements is set to 100% or 96dpi: http://windows.microsoft.com/en-us/windows/make-screen-text-larger-smaller

more options

Faith I truly promise that I had the same problem & did the same as you - went back to version 21. Here's my solution, which I have done and it's working beautifully: Install version 23 of FF. Go to the Firefox tab (upper right) click the down arrow & select add-ons. In the left, click on Get Add-ons. In the upper right, search for NoSquint and install it. Restart FF. Go back to FF add-ons & click on Extensions. Find NoSquint in the list and click on the options button. In the zooming tab, change the increment to 5% and close the NoSquint Global settings. In a new FF tab, go to one of those favorite pages that appears too big. In the lower right corner of the browser window, click on the magnifying glass to open the zoom. In the upper right of the zoom settings, down adjust full-zoom & text-zoom until that page is good. Then click Global Zoom button & adjust to match what you just did to the individual. Click OK. Click OK.

more options

Try the NoSquint add-on =^). It allows you to adjust the zoom & it's VERY easy to work with.

more options

Try the NoSquint add-on. It allows you to adjust the zoom on a per page basis, and it also has global settings. Plus if you go to a new site that looks funky, you can easily adjust the zoom for that page, and NoSquint will remember the setting.

  1. 1
  2. 2
  3. 3
  4. 4