ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Icons don't show on Wordpress

  • 7 ردود
  • 1 has this problem
  • 69 views
  • آخر ردّ كتبه jscher2000

more options

Icons do not appear on my Wordpress blog. They did for years until a few days ago. I followed all the tips in this article but no change https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently#w_clear-the-cookies-and-cache

Wordpress thinks it is a Firefox setting..........please help.

الحل المُختار

I fixed it. In Firefox Tools Options Content Fonts & Colors Advanced check Allow pages to choose their own fonts

Read this answer in context 👍 0

All Replies (7)

more options

Does it look normal in Internet Explorer?

You might have visited this second article, but if not, it might be helpful: Fix problems that cause images to not show.

more options

If images are missing then check that you aren't blocking images from some domains.

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

Make sure that you do not block third-party images, the permissions.default.image pref should be 1.

There are also extensions like Adblock Plus (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content.

See also:

more options

Yes they appear when using Windows Explorer. I just tested on a coworkers computer.

more options

I've done everything in the bulleted list in your answer and all was OK.

Where exactly do I check this? Make sure that you do not block third-party images, the permissions.default.image pref should be 1.

I don't have AdBlock plus and no firewall. Just standard ani-virus McAfee

Icons show fine in Internet Explorer.

Here is a screen shot showing the page with no icons and Firebug showing no errors.

more options

My webmaster looked at the code for the icons and says it seems to be coded for Windows Explorer 8 and perhaps Firefox can not read it properly?

more options

الحل المُختار

I fixed it. In Firefox Tools Options Content Fonts & Colors Advanced check Allow pages to choose their own fonts

more options

Ah... Some "icons" actually are characters in a custom font. I'm glad you thought of that because it didn't cross my mind before.