ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Untrusted connection Error when using google search field in top line. Ok with other search engines

  • 7 ردود
  • 65 have this problem
  • 4759 views
  • آخر ردّ كتبه wyorocks

more options

When opening www.google.dk and searching from the page, everything is ok When using Google search engine in the address line search bar the error is present When changing to Yahoo, bing or another search engine in the search bar, the error is not present So, the error "www.google.com uses an invalid security certificate. The certificate is not trusted because no issuer chain was provided. (Error code: sec_error_unknown_issuer)" is only present when using google search engine in the search bar Have tried to delete the files cert8.db and key3.db with no success Read about firewall settings, but Bullguard firewall was not covered

All Replies (7)

more options

In your "More system details" it says your address bar search provider is Babylon, not Google. Perhaps that's the problem? Or are you using a shortcut to force the address bar search to Google?

This add-on will reset your address bar search to Google: https://addons.mozilla.org/firefox/addon/searchreset/

That might not stick if you have an add-on which reverts the setting. You can disable nonessential and unrecognized extensions here:

orange Firefox button (or Tools menu) > Add-ons > Extensions category

Also, you might need to edit or delete your user.js file to prevent your settings from being overridden at the next startup. This article has info on that: How to fix preferences that won't save.

Any luck?

more options

Thanks for the answer, but no luck

Where do you see the Babylon search engine? I cannot find any reference to this. In the search bar I have the choices to use Google, Yahoo. Bing, Amazon.com, Ebay, Twitter and Wikipedia as search engines. The error only appears when I use Google as search engine. My default home page is set to Google, and when I search form this page (not the search bar) the error does NOT appear

more options

Thank you for the screen shot. I mis-read your original post to refer to searching in the address bar rather than the search bar.

The certificate I get for www.google.com was issued as of 5 June 2013. Did this problem just start in that time frame?

The server is sending a correct chain up to a trusted root, according to this test page: http://www.networking4all.com/en/support/tools/site+check/report/?fqdn=www.google.com

If you check your "Authorities" tab, do you have the "Equifax Secure CA" certificate?

orange Firefox button (or Tools menu) > Options > Advanced > Encryption > "View Certificates" button

more options

No, the problems started way before that, Maybe 2-3 month ago, i do not remember exactly Yes, I do have the Equifax certificate. Although it looks a bit different from the one you posted Using the networking link it says "SSL Certificate correctly installed"

more options

Where did you find the certificate on the right? I think that blocks a security exploit that was diverting Google traffic to a bogus phishing server. You should not encounter that certificate in normal browsing. If you do, you might need to check your system and/or network router's DNS settings to make sure you are using trusted servers. These might be servers supplied by your ISP or others (e.g., OpenDNS, Google Public DNS).

more options

By the way, if you prefer your search bar to go to google.dk instead of google.com you can download a search plugin for that here: http://mycroftproject.com/google-search-plugins.html

more options

Check your system date.