ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

make firefox default browser for all users without firefox checking for default browser

  • 7 ردود
  • 3 have this problem
  • 283 views
  • آخر ردّ كتبه ideato

more options

Hi,

we have 2 citrix servers in the same farm . We want to make firefox the default browser for all of our users.We also want to ignore the settings that they decide themselves influencing the default browser.
Now the citrix forum suggested that i made a gpo that edits the folowing register keys:

HKCR\http\shell\open\command Change the value in the default key to firefox.exe location.
HKCR\http\shell\open\ddeexec Change the value in the default key to Firefox HKCR\https\shell\open\command Change the value in the default key to firefox.exe location.
HKCR\https\shell\open\ddeexec Change the value in the default key to Firefox

so i did that , and all our links now open through firefox.
However we still get the question to make firefox our default browser while it already is defined as default browser since it opens links using firefox.

the 2nd strange thing we encountered is when we open pdf's using firefox , firefox opens but the pdf's won't open untill we make firefox default browser using the provided popup window when we start firefox
i have googled this for days now without a proper answer . i even tried to run the "firefox.exe -silent -setDefaultBrowser" command to fix it on my personal profile without any luck.that's why i am relying on your answer

Hi, we have 2 citrix servers in the same farm . We want to make firefox the default browser for all of our users.We also want to ignore the settings that they decide themselves influencing the default browser.<br /> Now the citrix forum suggested that i made a gpo that edits the folowing register keys: HKCR\http\shell\open\command Change the value in the default key to firefox.exe location.<br /> HKCR\http\shell\open\ddeexec Change the value in the default key to Firefox HKCR\https\shell\open\command Change the value in the default key to firefox.exe location.<br /> HKCR\https\shell\open\ddeexec Change the value in the default key to Firefox so i did that , and all our links now open through firefox.<br /> However we still get the question to make firefox our default browser while it already is defined as default browser since it opens links using firefox. the 2nd strange thing we encountered is when we open pdf's using firefox , firefox opens but the pdf's won't open untill we make firefox default browser using the provided popup window when we start firefox<br /> i have googled this for days now without a proper answer . i even tried to run the "firefox.exe -silent -setDefaultBrowser" command to fix it on my personal profile without any luck.that's why i am relying on your answer

Modified by cor-el

All Replies (7)

more options

Just in case, check this article for the missing information

Setting Firefox as the default browser does not work - What to do

more options

Hello timtorfs, try to lock the preference :

pref("browser.shell.checkDefaultBrowser", false);

http://kb.mozillazine.org/Locking_preferences


thank you

more options

hi smo, this has also been tried , however these settings will only adjust the settings for the user that is currently logged on , for our entreprise we need this to force it to all our users.

more options

@ideato , the locking did the trick i think. thx

more options

you are welcome

more options

ok, the check browser doesn't pop up anymore, but whenever i try to follow a link in my mail ,i only get the default page from firefox instead of the clicked link is this related to the registry settings? what should i do to fix it? if i manually make it default browser via options-advanced-make ff default then my links open normally , if ie is default in the background then he doesn't open the link but just the default page of my firefox

more options

if i manually make it default browser via options-advanced-make ff default then my links open normally if ie is default in the background then he doesn't open the link but just the default page of my firefox

yes, that is correct, because it is firefox the default browser