ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox (21.0) won't accept the security certificate for Twitter & won't let me add an exception.

  • 1 (رد واحد)
  • 43 have this problem
  • 1 view
  • آخر ردّ كتبه cor-el

more options

My mother was having problems with her computer on the Internet and had to reset the modem. Problem was, I was on the Internet at the time using Twitter. She reset the modem, I thought everything was okay, but now Firefox isn't letting me access Twitter at all because of the security certificate. Here's the error message:

This Connection is Untrusted



         You have asked Firefox to connect

securely to twitter.com, but we can't confirm that your connection is secure.

         Normally, when you try to connect securely,

sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.


         What Should I Do?
         
           If you usually connect to

this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.

twitter.com uses an invalid security certificate.

The certificate is not trusted because the issuer certificate is not trusted. The certificate is only valid for gateway.2wire.net

(Error code: sec_error_untrusted_issuer)



gatway.2wire.net is the default error page for my modem, if the Internet is not working at all. I think the problem here is that now Firefox thinks the legitimate site for Twitter is the error page and not, well, Twitter.com. Also, I'm not getting any "add exception" option. How do I fix this?

All Replies (1)

more options

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"