ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot change the default search engine for Firefox 20

  • 5 ردود
  • 14 have this problem
  • 15729 views
  • آخر ردّ كتبه jscher2000

more options

I'm using Windows 20, and recently install Freemake Video Downloader. I remember that I had not checked the "Make Freemake my default search provider" when installing the product. But still, Firefox use it as the default search engine. I've did some research, which tell me to go to the search box, choose the drop-down arrow, and click "Manage Search Engines". The thing is, the Freemake search engine was not there. So I just delete every search engine except only one I like, and resart the browser. Surprisingly, it has change to the homepage and search engine I want, except for one thing. If you type in the address bar, it STILL use Freemake search engine. So I have search in Control Panel > Uninstall a problem (which I didn't found anything I don't install myself). I want to keep the program, but is there a way to reset this? I can do this in Chrome and Opera, why not Firefox?

Thank you.

الحل المُختار

Firefox has 3 completely unconnected search providers set in different places, so fixing the address bar search requires a different approach than the search bar. This article describes how or, if you prefer, there's an extension that does a quick reset:

Read this answer in context 👍 4

All Replies (5)

more options

الحل المُختار

Firefox has 3 completely unconnected search providers set in different places, so fixing the address bar search requires a different approach than the search bar. This article describes how or, if you prefer, there's an extension that does a quick reset:

more options

Try to use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

more options

I'm having the exact same problem. I downloaded software and I specifically deselected the box that said make Ask your default search engine. I have gone to "Manage Search Engines" and deleted Ask (and others). I have also downloaded the Search/Reset extension. Still, when I enter a search term in the address bar, the search still defaults to Ask.

The only thing I haven't done is close and reopen Firefox.

Please let me know how I can fix it.

Thanks!

more options

Hi kiminalto, starting in Firefox 23, the address bar search engine is the same one you select on the search bar. In Firefox 22 and earlier, it is a separate setting. You can try this extension to reset your search providers back to Google:

https://addons.mozilla.org/en-US/firefox/addon/searchreset/

Two notes:

(1) If you notice your change sticking until you exit and restart Firefox, there could be a user.js file overriding your preferences at startup. See this article for more information on how to check and fix that: How to fix preferences that won't save.

(2) When you enter a single "word" search in the address bar, Firefox will check your DNS service provider to see whether it is a valid server name. Some DNS service providers, rather than return an honest "no", will send a page of search results. Thus, you may see different results for one word vs. multiple word searches in the address bar.

more options

Hi kiminalto, do you have an add-on toolbar from Ask? If you need to remove that, check here:

orange Firefox button (or Tools menu) > Add-ons > Extensions category

Usually after disabling or removing an extension, Firefox shows a link to restart the browser to complete the process.