ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox freezes entire system then everything resumes running again

  • 59 ردًا
  • 46 have this problem
  • 61 views
  • آخر ردّ كتبه drakaran

more options

As above.Started occurring since v20 came out.Seems like many people have this error.

Reverted to v19.Problems occurs as well.

Tried everything ( starting FF in safe mode , creating a new profile, resetting FF, uninstalling and a fresh install, booting in safe mode Windows). Nothing seems to work.

It freezes again and again only to resume normal service only to freeze again. On and on and on. Really frustrating.

Can someone point to me if this FF's problem or is there a problem with my system itself?

My system doesn't seem to freeze when FF isn't running though.

الحل المُختار

Hi all.Thought I'd share my revelations on my problem

For my case, it was a result of my system not running 8 cpu processors,basically causing FF to run like a snail. FF runs fine now in general, still a little sluggish sometimes but by and large the freezes have stopped.

On a more serious note, I need to figure out what or why my system was running on 1 processor. Could be a malware or virus of sum sort. Need to suss it out more. I've never ever changed my cores ever on my system. Took me a while to get around this possibility though. I guess it's something worth looking at from another angle.

Cheers

Read this answer in context 👍 0

All Replies (20)

more options

Yes, I did the reset... I'm running 10.6.8 As for finding a better thread, I try, but the layout & navigation of this forum leaves a lot to be desired. I put in Mac, and the version of FF, but when I ask a question, I get results from all over the place, mainly Windows, and often older versions of FF, etc. I don't understand why it's not laid out more simply & clearly... I followed your link, and it just took me to the usual place, and when I asked the question, there was nothing for me to click on to confine it to Mac users, or to Version 22 users, why not? Wouldn't that makes some actual sense?

I'm getting the slowness after waking, and slowness when opening it, & slowness way too often. Facebook especially shows the slow script window, and even when I hit to kill the script, it keeps trying to continue.

more options

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options

Same problem here.

Problem occurs on both my PCs (Win 7, FF22), even with add-ons turned off.

I use my browser normally and all of the sudden the "loading" cursor appears, blocks my Firefox window and it goes away after 4-5 seconds. After that I can use my browser normally for 4-5-10 minutes and the freeze happens again.

more options

I've done that, no difference. I've also changed various setting on the Cache Management preference, first setting figures, 350, then 250, then tried leaving on "automatic", and now wonder how high the automatic setting allows, since I just checked & my cache was already up to 300mb. Does anyone know? I've had FF freeze up on me, sometimes when I hit the Clear Cache button, which is why I thought maybe letting it go back to Automatic might help, but since the automatic level is at least above 300 mb, I doubt it.

more options

can you reproduce this in a new profile.

more options

الحل المُختار

Hi all.Thought I'd share my revelations on my problem

For my case, it was a result of my system not running 8 cpu processors,basically causing FF to run like a snail. FF runs fine now in general, still a little sluggish sometimes but by and large the freezes have stopped.

On a more serious note, I need to figure out what or why my system was running on 1 processor. Could be a malware or virus of sum sort. Need to suss it out more. I've never ever changed my cores ever on my system. Took me a while to get around this possibility though. I guess it's something worth looking at from another angle.

Cheers

Modified by knnthsm

more options

I believe you may have found the solution to my particular problem, Waka. After turning off Hardware Acceleration in the Firefox settings I didn't encounter any freezing yesterday. If I don't post again in this thread, then my issue has been resolved.

more options

esus, you may have to upgrade your graphics drivers, if possible

more options

There have been some new beta Nvidia drivers released last week, but this particular problem has me superstitious and I'll simply leave Hardware Acceleration off unless I run into the problem again. No point in attempting to fix a something I'm currently satisfied with.

more options

In the article about updating drivers (which mine are), it says besides disabling graphics acceleration, to also disable WebGL, but of course, doesn't mention what that is, and what disabling it means. Do you know, do you advise disabling it?


My FF is operating worse & worse, running up memory, and inactive memory (curiously), until it freezes constantly & requiring me to restart it, or it freezing completely & requiring a forced restart...

more options
more options

I'm all up to date on all my Apple software. However, in reading about WebGL it says that in Safari, " Mac OS X Snow Leopard implemented support for WebGL, which is disabled by default."

So, perhaps for my OS, it would be wise for me to disable it in Firefox, does that make sense?

Also, when I do an update check on my FF plugins, it says that my QT & Java Applet ones are outdated. However, they are the most updated versions for my OS. So, I can't update them any further, unless I update my entire OS. Does that mean FF is going to run like crap on all Macs with Snow Leopard, since none of us can update beyond what works with it?

more options

Also, when I do an update check on my FF plugins, it says that my QT & Java Applet ones are outdated. However, they are the most updated versions for my OS. So, I can't update them any further, unless I update my entire OS. Does that mean FF is going to run like crap on all Macs with Snow Leopard, since none of us can update beyond what works with it?

Not the case, refer to https://addons.mozilla.org/en-US/firefox/blocked/

more options

What's "not the case"? What is that list supposed to be telling me?

more options

They are click to play (blocked from being played automatically) not sure why it says outdated.

more options

Exactly, so I have no idea why it keeps telling me they are outdated. Plus, I still can't play some streaming audio, I click on play, but there is no grayed out plug in to click, it just sits there not playing, leaving me with no visible options. Plus, I keep having to shut & re-open FF, as it rapidly just won't do anything until a minute or two of "unresponsive script" & spinning ball... Plus, when I click on "kill script", often it just keeps going on trying to load the page, as if it makes no difference which I click on....

And, I've just rebooted it again, have maybe twenty tabs open, none using flash, yet the CPU usage is above 90%,, moving down a little, then up even more, just as it sits there.....

Modified by StevenCee

more options

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

more options

I've already done the reset, and it improved nothing. And honestly, I can't use this anymore. It's slow, can't even type without it slowing or stopping, and maybe I'll try the Beta version until a better update comes out. This is ridiculous....

more options

Please fix this. Firefox is my favorite browser. I can't stand chrome or I.E. I get these random freezes since version 20. I have tried everything from fresh install of windows and no add ons or anything in firefox added or changed, but once I start firefox, the freezes begin. I tried safe mode and resets of firefox as per this forum ideas .. nothing works.

Please fix.

Cheers.

Modified by JackDawson69

more options

I see you deleted most of your response Jack, that's too bad, as it was quite eloquent...

  1. 1
  2. 2
  3. 3