ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Always enjoyed being able to open new windows in a tab. However, after upgrading found I was no longer able to do this.

  • 6 ردود
  • 7 have this problem
  • 1715 views
  • آخر ردّ كتبه cor-el

more options

Have search all over web and tried every solution I could find; explored addons, restored, even reinstalled 19.0 but I am still unable! It is very frustrating. Would appreciate suggestions (never thought I'd say this but Safari is looking good!). Thank you.

All Replies (6)

more options

You can check for problems with the localstore.rdf file


Create new profile and delete your old profile

Taking Backup of Old profile date and Restore

Modified by iamjayakumars

more options

Thank you. Have tried all of these and unfortunately nothing has worked. When I update to 20.0 I noticed that when I clicked onto email links it started running another firefox program (a seperate icon opened up at the end of the toolbar). Does that mean I somehow have two programs in my system?

more options

Let me see if I understand the original problem. You can checked the preference on the following tab to divert new windows to tabs instead:

Firefox menu > Preferences > Tabs

And that was not working correctly, either on all sites or a few particular sites.

Note that by default, sites that open a new window with particular specifications, such as the size, bypass that setting. To force even those windows into a new tab, you can use the about:config preference editor.

In a new tab, type or paste about:config and press Enter. Click the button promising to be careful.

In the filter box, type or paste link.o and pause while the list is filtered.

Double click these and set the value as desired:

(A) browser.link.open_newwindow

3 = divert new window to a new tab (default) (checked*)
2 = allow link to open a new window (unchecked*)
1 = force new window into same tab

* First checkbox in Options > Tabs

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

0 = apply the setting under (A) to ALL new windows (even script windows)
2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

-1 = apply the setting under (A) to external links (default)
3 = open external links in a new tab in the last active window
2 = open external links in a new window
1 = open external links in the last active tab replacing the current page

Sorry, that's a lot of data, but hopefully it's reasonably clear.

more options

Thank you for your thoughts. I did what you said and will add an image of my config screen below. It didn't work but I think I need to give up and stop being so demanding.

more options

Sorry to hear that didn't work.

Can you tell whether the two windows are in the same session of Firefox? For example, after you close the window launched by the email, it should appear on the History menu > Recently closed windows in your other window.


Has anything changed in how you start/run Firefox? For example, using a sandboxing program or other VM-like technology? Or starting up with a command line switch that chooses a particular Firefox profile?

If those are gibberish to you, the answer likely is "no" and "no."

more options

I'm not sure what you experience.

Do you mean that clicking a link in an external program open in a new window and in the same window and not in a new tab?

This can happen if you are in Private Browsing mode and have a Private Window open.
If this is the case then external links always open in a new normal window.

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Firefox > Preferences > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"