ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I load the url to my website, a different website loads.

  • 9 ردود
  • 4 have this problem
  • 360 views
  • آخر ردّ كتبه jscher2000

more options

Hello,

I was navigating through my website last night (www.roxxsterclub.com), when I suddenly was taken to a page which said something along the lines of, "This page is untrusted. Get me out of here." However, since I was navigating through MY OWN website, I thought everything was secure so I created an exception and allowed access to the page. Ever since then, whenever I navigate to the url of my site in Firefox 16.0, I am taken to a different website about a Cricket Club. This is not a redirect, since my url remains in the url bar. This seems to be a Firefox-only issue, because when I am able to access my site under different browsers. I cleared the cookies, cache, and history, but that didn't fix the problem. Suggestions?

Thanks, Ethan Rocker

All Replies (9)

more options

I attached a screenshot of what I see in Firefox 16.0 when I load my site, www.roxxsterclub.com

I would prefer to not have to re-install firefox, as I have saved & organized important bookmarks

more options

If you right-click (or Mac equivalent) on the alien content, does the context menu have a "This Frame" entry? if so, select View Frame Info for the true URL. This may be a clue to how to uncover the source of the problem.


In case one of them is altering your pages, try disabling all your extensions here:

Tools menu > Add-ons > Extensions category

After restarting Firefox, do you see any difference?

more options

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry (Show All History or History sidebar) or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.
You can't recover from that 'forget' unless you have a backup of the affected files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

more options

Hi jscher2000--

Unfortunately, when I right-clicked on the alien content, there was no option for "This Frame". I am using a Mac computer. Also, I disabled all extension, but the problem remains. Any other suggestions?

Thanks, Ethan

PS.. I attached a screenshot of the options that appear on the page when I right-click

more options

Hi cor-el--

I followed all of your suggestions, but the problem wasn't fixed. Any more advice? Maybe it's something in the Firefox files?

Thanks, Ethan

more options

A few other thoughts.

(1) Could you test with all plugins disabled, too.

Tools menu > Add-ons > Plugins category

(2) Could you check for any unusual proxy setting here:

Firefox menu > Preferences > Advanced > Network > "Settings" button

Choosing "No proxy" or "Use system proxy settings" usually bypasses anything peculiar to Firefox.

(3) Does the site's behavior change if you disable JavaScript

Firefox menu > Preferences > Content

Modified by jscher2000

more options

Hello,

Thanks for the quick reply. Just tried all of your suggestions and the problem remains. I'd like to say that it happened right after I downloaded a Wordpress plugin, WooCommerce, onto my site. They may be a coincidence, but I figured I'd mention it. I'd also like to reiterate that there was a security message that said something along the lines of "This page is untrusted. Get me out of here." However, since it was my own site, I figured everything was secure and allowed a security exception to advance to the next page on my site. Ever since then, the problem has occurring. Looking forward to your reply.

Thanks, Ethan

more options

Why you only see the problem under such limited circumstances is unclear... unfortunately, you're limited to Firefox 16 because of your OS version.

Because it's a popular platform, WordPress is subject to a variety of attacks. You might try this WordPress plugin to see if there is a problem on the server side: http://wordpress.org/extend/plugins/exploit-scanner/. Interpreting the output is beyond the scope of this forum, but I'm sure anything truly alien will pop out at you.

more options

Also, try removing the certificate exception you saved. I haven't done this myself, but I see a couple threads you could consult: