ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I was able to change keyword.url to http://www.google.com.my/search?q=, but when I close the browser is reverts back to google.com

  • 6 ردود
  • 9 have this problem
  • 19244 views
  • آخر ردّ كتبه cor-el

more options

my little sister installed a lot of games that changed all my setting, I have managed to fix all of them except this in the About:config page.

I have changed the keyword.url to http://www.google.com.my/search?q= and it works perfectly until I close the browser, at which point it changes back to www.google.com, so when I try to search,it just adds the letters to the end of the google url

الحل المُختار

I erased everything in the user.js notepad, it didn't help. the website that seems to have caused the problem was funmoods.com or something like that.

anyways, thanks for your help, I ended up reinstalling it and its all good now, just wish I could have fixed it without deleting all of my bookmarks.

Read this answer in context 👍 4

All Replies (6)

more options

hello, please see How to fix preferences that won't save - especially the part about the user.js file in your profile folder...

more options

Hi zeke_lord,
the same also happens if you change the value of preference browser.startup.homepage to http://www.google.com.my/search?q=  ?

more options

الحل المُختار

I erased everything in the user.js notepad, it didn't help. the website that seems to have caused the problem was funmoods.com or something like that.

anyways, thanks for your help, I ended up reinstalling it and its all good now, just wish I could have fixed it without deleting all of my bookmarks.

more options

Hi zeke_lord,
you could have kept a backup of your bookmarks:
Restore bookmarks from backup or move them to another computer
You could also have kept your whole profile:
Back up and restore information in Firefox profiles

more options

I had the same problem. Yahoo search overtook google, and I couldn't get it back. Changing keyword.url helped only until I reopened Firefox. Solution for me was: type about:config in address bar then type yahoo in search return all changed values to default (I had to change 2 them)

more options

If you do not keep changes after a restart, see: