ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

my firefox will close when i close the window but the process doesn't shutdown ever since i had firefox updated

  • 11 ردًا
  • 35 have this problem
  • 18164 views
  • آخر ردّ كتبه crazyboy1711

more options

Ever since I updated firefox 2 days ago it has a problem restarting. When I close the firefox window it closes like it normally does but whenever I try to restart firefox it shows the notification that firefox is still running and I first need to shutdown the previous process before I can start a new one. At last after I manually shutdown the firefox process it will restart again.

الحل المُختار

That fixed it for me but I'm running v.15 because of other issues. I have to say I tried a hundred things and nothing helped. I did notice it never shutdown , even hours later, if I forgot to go into task manager to end process. It didn't seem to matter whether I had extensions or add-ons running or not. I tried all of it before now. My graphics driver updated a couple of months ago. Anyway, THANK YOU for this, finally something is going right.

Read this answer in context 👍 0

All Replies (11)

more options

How are you manually shutting it down?

Ctrl/Alt/Delte > Task Manager > Processes > End Task > End Now if needed? This is more of an actual issue with your OS itself rather than FF. Your plugins or extensions could be causing a slow down where after closing FF the plugins or extensions are causing your PC to delay in closing it out of running processes due to one or more of them being active, thus waiting on their response times to shut down fully.


Also try disabling graphics hardware acceleration:

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Upgrade your graphics drivers to use hardware acceleration and WebGL

Did this fix your problems? Please report back to us!


Please select the appropriate response "Solved/Solution" to close out this thread & mark issue as solved. Thank You.

Modified by Donnie

more options

First of all thnx for the posibility but none of these solutions work for me. I turned of hardware acceleration, I restarted FF in safe mode, and I shutdown every extension I used. Still no luck. I did however notice that it doesn't happen every time so I tried some more and I discovered that it only occurs when i've downloaded something. Since i've been downloading mods for this game i've been playing the problem occured almost daily but then I tried something else that requires my desktop to download something and the problem even occurs when I watch a video on youtube because it buffers the vid I believe it also downloads a temp file so I think the issue lies there. Also I do indeed shut the proces down by means of the task manager like you discribed

Modified by crazyboy1711

more options

Hi after following the proposed process (uncheck hardware acceleration) the problem disappeared. I checked again to verify and the problem is not ther anymore...for the moment. In addition this prevented to have additional toolbars such as Norton tool bar, and the pop up windows did not open when required by a link... thahks Rgds JD

more options

Hi pop-up windows still do not open

more options

I am using the new Firefox 20 on a MacBook and I am having the same issue with it not shutting down and when I reopen it my previous tabs are listed as error msg "having trouble reopening windows" Well they were supposed to be closed to start with. Can this be fixed?

more options

Hi BrowserlessMac

Firefox seems to have crashed if you get this window.

If you have submitted crash reports then please post the IDs of one or more crash reports that have this format:

  • bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

You can find the IDs of the submitted crash reports on the about:crashes page.

  • You can open the about:crashes page via the location bar, like you open a website.

See:

You can check for problems with the sessionstore.js and sessionstore.bak files in the Firefox Profile Folder that store session data.

Delete the sessionstore.js file and possible sessionstore-##.js files with a number and sessionstore.bak in the Firefox Profile Folder.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost, so you will have to create them again (make a note or bookmark them).

more options

This has been going on for *years* for me. It's not an extension - so don't even drop that crap. Across multiple computers and operating system - Firefox has sucked ever since v4.0. I'm tired of exiting it and 25% of the time having to kill it in the task manager. I finally just snapped and installed Chrome. It's been a nice run FF, but you've turned into bloatware. Goodbye.

more options

Hi BrowserlessMac, what you were experiencing in Firefox 20 on Mac turned out to be a bug that was fixed in Firefox 21, so hopefully that's no longer a problem.

Hi JDP91, did you get your issue solved? Turning off hardware acceleration of graphics shouldn't affect add-on toolbars or pop-up windows, so there probably is something different going on there. I suggest starting a new question with your current configuration info and a summary of the current status if things are not going well.

Hi crazyboy1711, did you ever figure out what was preventing Firefox from shutting down normally? Since the major download window change in Firefox 20, I wonder whether you have noticed any difference?

Hi joshua850, it appears you've never posted here before under this username, so you didn't give us a chance to address your issue. If you decide you don't like Chrome, please start a new question with your details.

more options

Hi thanks jscher2000. Iam nom running firefox 21.0 and not experiencing problems for a while. To joshua 850; I dislike google invading policy and wont use Chrome!

more options

الحل المُختار

That fixed it for me but I'm running v.15 because of other issues. I have to say I tried a hundred things and nothing helped. I did notice it never shutdown , even hours later, if I forgot to go into task manager to end process. It didn't seem to matter whether I had extensions or add-ons running or not. I tried all of it before now. My graphics driver updated a couple of months ago. Anyway, THANK YOU for this, finally something is going right.

more options

Hi jscher2000, as you expected by updating to the next version of ff my problem was solved. But I never really fixed the problem itself so I couldn't say what others could do to solve the problem besides updating their ff. Thx for your help everyone.

Grtz crazyboy