ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I try to download from a website, I am taken to the address but the page is blank and the document doesn't download.

  • 5 ردود
  • 85 have this problem
  • 1 view
  • آخر ردّ كتبه extremejor

more options

Mac OS 10.6.8, Firefox 14.0.1

الحل المُختار

Taking a cue from a someone who had the same problem some time ago, I went to Tools, clicked on Add-Ons, chose plug-ins, and disabled the Adobe Acrobat NPAPI Plug-in version 10.1.4.

Now, downloading works as it used to.

Big Q: Why install something - the Adobe Plug-in - that completely prevents the Adobe Reader user from obtaining documents to read?

Other questions: 1. Why can't the Adobe Acrobat NPAPI Plug-in be removed? 2. Why doesn't it show up when searching the hard-drive?

Read this answer in context 👍 43

All Replies (5)

more options

Maybe your Firefox or Mac security policies don't alllow to perform downloads. Does this happen in all websites or just in some of them? Try for example to download the Firefox Installer (you don't need to install it, it's just to test if download feature works).

Also try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "Continue in Safe Mode." To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

more options

الحل المُختار

Taking a cue from a someone who had the same problem some time ago, I went to Tools, clicked on Add-Ons, chose plug-ins, and disabled the Adobe Acrobat NPAPI Plug-in version 10.1.4.

Now, downloading works as it used to.

Big Q: Why install something - the Adobe Plug-in - that completely prevents the Adobe Reader user from obtaining documents to read?

Other questions: 1. Why can't the Adobe Acrobat NPAPI Plug-in be removed? 2. Why doesn't it show up when searching the hard-drive?

more options

You can set the plugin.expose_full_path pref to true on the about:config page to see the full path of plugins on the about:plugins page.

It is best not to leave that pref set to true as it exposes that full path to web servers via the navigator.plugins object, so reset that pref to false after you are done with the about:plugins page.

See "Manually uninstalling a plugin":

more options

Thanks for that. I'm surprised I didn't find these pages when I was trying to troubleshoot.

At this time, since things are working as they should, I'm not going to try to fix it.

more options

Unfortunately, I cannot uninstall this plugin because I may need it for DRM code documents from API (Digital Rights Management & the American Petroleum Institute) for my work.

Also, these instructions appear to be for explorer - they are not working for the Mac version of Firefox.

The old standby is to use Safari instead, but, it would be nice if Firefox were updated to be compatible with the NPAPI plug-in for those of us who need it.