Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 14 User Interface font size wrong and can't be changed

  • 35 replies
  • 29 have this problem
  • 2171 views
  • آخر ردّ كتبه DAOWAce

more options

Following auto-upgrade to Firefox 14, all the Firefox user interface strings are in Times New Roman pt 8 or 9 (way too small). I cannot change them any which way, I have tried Settings, no change (including restart and reboot). I have used the Restore function. No change.

System is Windows XP Pro.

Modified by akerbeltz

All Replies (15)

more options

@jscher2000: Yeah I should've probably specified, but Segoe UI isn't available on Windows XP, so I would hope people would understand regardless.

I set my Vista to the default font that comes with Windows XP for most of the UI (minus a few since it seems to break them for some reason), which is MS Sans Serif.

I don't use 7 because of all the needless UI changes, and because ClearType is/was forced on. I used a CRT when I beta tested it and I could not look at the text on the screen because of ClearType and there was NO WAY TO TURN IT OFF.

I use an LCD now and still hate ClearType and it STILL bothers my eyes when I look at it. I don't see how anyone can tolerate it.

Modified by DAOWAce

more options

I have the same problem as akerbeltz: UI font of FF has changed probably to MS Serif (or Times New Roman?) on Win XP after upgrading FF to 14.0.1. No personas installed, i.e. default.

I have Verdana as default font for UI of XP, so the FF UI should be also with Verdana.

I have verified instaled fonts and they are OK. Theme Font & Size Changer helps but why I have to instal the add-on when FF should read XP setting?

Further interresting thing is that after upgrading Thunderbird to 14.0.1, its UI font has changed to some sans-serif font (Arial or MS Sans Serif?) on the same PC.

Peculiar coincidence, isn't it?

more options

There is a similar discussion on the Mozillazine forums: FF14 UI font change? - mozillaZine Forums. One of the fonts specifically identified as a problem is MS Sans Serif, but further testing suggests that the main point of note is a problem with certain "raster" fonts. One poster was able to fix the problem on one system by updating graphics card drivers and re-enabling hardware acceleration.


Hmmm, going out on a limb now: I found a bug indicating that a change in Firefox 14 may cause certain "bitmap" fonts to render incorrectly, which in the appearance comparison causes many of them to be substituted with Times New Roman (Bug 749139 – MS bitmap fonts are not rendered as expected even if Hardware Acceleration disabled).

Test page: https://bug425336.bugzilla.mozilla.org/attachment.cgi?id=311969

Image showing expected fonts: https://bug425336.bugzilla.mozilla.org/attachment.cgi?id=311971

Firefox 15
The fix has already been incorporated into the code base with the expectation that it will be released in Firefox 15, but I don't know whether the change is present in the current beta. Anyone want to test?


Optional: MS Sans Serif isn't in the above test page, but you can inject it using the Web Console. After opening the page, press Ctrl+Shift+k to open the web console. Copy the following line of code, then paste it into the web console after the caret (>) and press Enter to run it. The Arial line should change to Times New Roman after you set it to MS Sans Serif (the color should change to red to confirm that the style was applied):


document.querySelector('span').setAttribute('style','font-family:"MS Sans Serif";color:red');

Modified by jscher2000

more options

After implementing Firefox 14 all and fonts under Windows XP Professional were almost unreadable. I upgraded to the Firefox 15.0 Beta and now everything is fine. Unfortunately I don't care what *my* page looks like, I worried about what users are seeing. I hope they implement the fix in Firefox 14 soon. Anyone know a replacement font that would be more stable? Is there a way to avoid this problem? Ironically I hit a similar problem in IE several versions and two? years ago.

more options

Hi bgomes, what is the URL?

more options

Is ClearType enabled on Windows XP?

more options
more options

HI bgomes, for what it's worth, my Firefox 14 substitutes Times New Roman for MS Sans Serif on Windows 7. (My system doesn't seem to have that font at all.) I haven't checked your page on Windows XP yet.

Is there a special reason to use MS Sans Serif? If not, you can find/replace it with the "generic" font family name sans-serif, which should work in all browsers. (In most cases, the user will show either Helvetica or Arial as the sans-serif font.) Or you could find another common font that you like.

more options

Thanks for the suggestion, and given that I'm normally averse to anything with the letters MS in it that sounds like a particularly good idea. If testing proves that works I'm migrating over!

more options

You can also check this registry key:

  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes
more options

Tested with Sans Serif and it also doesn't render properly under Firefox 14... Elsewhere it was noted that perhaps one should siwtch to style sheets and avoid the entire font issue. Not sure if that corrects the problem either.

more options

With regards to checking a registry key, or for that matter changing any setting on my desktop (windows 7 but with a VM running under it running XP for testing purposes) or laptop (XP) keep in mind I am not trying to correct the problem for *me*, I'm trying to correct the problem for *everyone* else using the web site and hence I want to change my HTML in a way that prevents the problem, preferably permanently! Thanks for any and all replies through!

more options

It is much easier to maintain if you use a stylesheet and a class name to specify which font-family to use than specifying it in every element like the HTML editor that you've used does (assuming that you didn't do it yourself).

Then you can also specify more fall back fonts to use when MS Sans Serif isn't present on the computer.

more options

Hi akerbeltz and all,

I also have been fighting for this issue since long and now I found out the solution which actually worked for me. Answer was available on Mozilla Support itself!!

Turn off hardware acceleration

With some graphics card and graphics driver setups, Firefox may crash or have trouble showing text or objects on pages when using hardware acceleration. You can try turning off hardware acceleration to see if it fixes the problem.

   -At the top of the Firefox window, click on the Firefox button (Tools menu in Windows XP) and then click Options
   -Select the Advanced panel and the General tab.
   -Uncheck Use hardware acceleration when available.
   -At the top of the Firefox window, click on the Firefox button (File menu in Windows XP) and then click Exit
   -Start Firefox the way you normally do. 

If the problem is no longer happening, then hardware acceleration was likely the cause. You can try updating your graphics drivers to see if that fixes it or simply run without hardware acceleration. Otherwise, your problem is likely related to extensions or themes.

more options

Old thread, and I think you're confusing webpage font rendering with the UI font, which was resolved in an update (or v15, I don't remember).

As for webpages, I think we'd all like the ability to use hardware acceleration and not be forced to look at the terribly rendered font.

  1. 1
  2. 2