Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 10.0.1 doesn't play MPEG-4 Files with Quicktime Plugin-in 7.7.1

  • 2 replies
  • 3 have this problem
  • 645 views
  • آخر ردّ كتبه cor-el

more options

Ok I have a mpeg4 video create with Camtasia. The video is inline and plays in the IE Browser and Chrome however with FF 10.0.1 the loading icon just spins for ever.

All Replies (2)

more options

1. Update Firefox to the latest version (13), also update your add-ons and disable what you dont need.

2. Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

3. If the issue still isnt fixed, I recommend you try installing VLC media player, it comes with a plug-in that supports many media formats and codecs: http://www.videolan.org/vlc/

You can then experiment and disable Quicktime as it may be the root of some performance problems as well.

more options

Does Firefox request the video file if you open the Web Console (Web Developer > Web Console;Shift+Ctrl+K) and do a hard reload (Ctrl+F5)?