ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Flash plugin races ahead, has no sound, since Ubuntu upgrade, why?

  • 3 ردود
  • 6 have this problem
  • 3 views
  • آخر ردّ كتبه John99

more options

After upgrading Ubuntu from 11.04 to 12.04 (64 bit), embedded videos handled by the Flash plugin race ahead at download speed, totally ignoring the clock. They also are silent.

الحل المُختار

Found the problem. It's an odd one. Looking in the Volume Control app (not sure if it's a Gnome or Xfce thing - desktop is Xfce), it showed that it has been defaulting to trying to play the audio stream through "Redwood HDMI Audio" on account of seeing a Radeon video card in the system. Turning that off under the Configuration tab and having Built-in Audio set to the appropriate (in my case) Analog Stereo Audio not only restores sound, but it fixes the Flash-video-racing-ahead problem.

What's insane is that video should race ahead because of a non-functioning audio output. How could Adobe have ever programmed Flash with that dependency?

In any case it appears that in the upgrade cycle Ubuntu insisted on bringing HDMI audio back into play. That had been set correctly - off - before the upgrade. I do have HDMI to my monitor, but its speakers are analog.

Read this answer in context 👍 0

All Replies (3)

more options

At the moment, to me, it seems likely the problem is something specific to your machine, rather than a general problem with Firefox and Ubuntu.

I can not give a specific, answer, but this is a day with a lot of experts on the forum, so you may get a better answer later.

Go through the troubleshooting ssteps and suggestions in that article, see if that helps, and then post back with how you get on.


I would point out that FlashPlayer 11.3 has been troublesome, there will be a lot of forum posts, but most of those problems relate to MS Windows systems.

I have 12.04 LTS (64bit) and I have no problems with Flash Player on Firefox 15.0a2 for Ubuntu, or on the standard Mozilla Firefox 13.01 when used on Ubuntu 12.04.


P.S.

Trying Firefox in a new clean profile is well worth trying. Make a new profile and check it is clean then install Flash Player into it.

Firefox 13 has an easy method of doing that but I personally see possible downsides ( certainly in likely future implementations of the feature)

Modified by John99

more options

الحل المُختار

Found the problem. It's an odd one. Looking in the Volume Control app (not sure if it's a Gnome or Xfce thing - desktop is Xfce), it showed that it has been defaulting to trying to play the audio stream through "Redwood HDMI Audio" on account of seeing a Radeon video card in the system. Turning that off under the Configuration tab and having Built-in Audio set to the appropriate (in my case) Analog Stereo Audio not only restores sound, but it fixes the Flash-video-racing-ahead problem.

What's insane is that video should race ahead because of a non-functioning audio output. How could Adobe have ever programmed Flash with that dependency?

In any case it appears that in the upgrade cycle Ubuntu insisted on bringing HDMI audio back into play. That had been set correctly - off - before the upgrade. I do have HDMI to my monitor, but its speakers are analog.

Modified by wytcld

more options

An odd one as you say, but thanks for posting back with the solution.