ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google Earth Plugin Outdated Version

  • 13 ردًا
  • 633 have this problem
  • 39790 views
  • آخر ردّ كتبه ribroast

more options

I checked my plug-in and was told the Google Earth Plugin was outdated. I clicked on the "Update" option but nothing happened. Usually when I clicked on that option, it'll open the developer's website so I can proceed the update. But this one just sat there and nothing happened. So how could I update this plug-in?

Thank you.

الحل المُختار

Open up Add-Ons and disable the Google Earth one. Go to http://www.google.com/intl/en_us/earth/explore/products/plugin.html and install the new one over the old one, which will need enabling - simples!

Read this answer in context 👍 43

All Replies (13)

more options

A couple of choices, if you want the latest version of Google Earth and the plugin, get it from http://www.google.com/earth/index.html

If you just want the plugin, you can get it from http://www.google.com/intl/en_us/earth/explore/products/plugin.html

more options

I opened my Google Earth to check if there's any new update, none.

The 2nd link you sent me wasn't for Firefox. I am talking about the Firefox Plug-in. Usually, when I checked the Plug-in update, if there's any is out-of-date, I can just clicked the "Update" option and it'll bring me to the developer site and I'll proceed the update from there. But for 'Google Earth', it didn't do that. When I clicked on 'Update', nothing happened.

more options

Hi

I have exactly the same problem. I have an outdated plugin but the "Update" link doesn't do anything. When i browse to the plugin link suggested by TonyE it says "Good news – you already have the Google Earth Plug-in installed. (Version 6.1.0.5001)" There appears to be no link to download the up-to-date plugin

thanks ...

more options

الحل المُختار

Open up Add-Ons and disable the Google Earth one. Go to http://www.google.com/intl/en_us/earth/explore/products/plugin.html and install the new one over the old one, which will need enabling - simples!

more options

Well not quite 'simples' i'm afraid. After installing the plugin, I still have 6.1.0.5001 listed, and when i enable it, firefox plugin checker tells me it's still outdated.

more options

A restart of my machine has now fixed the problem. 6.2.0.5788 is listed and ticked by the checker.

thanks for your help....

more options

Glad it worked. Sorry I forgot to mention that I did the 'upgrade' with Firefox closed so didn't need a restart.

more options

pineman -- Thank you for the tip. I went to the link and downloaded the plug-in, then restart FF and now I have the latest version of Google Earth plug-in.

more options

How do you download the new plugin ...i see no download....sorry not savy..I have disabled the incompatible one .

more options

ribroast -- Did you open the link that pineman posted (the solution I chose)? After you open that link, you should see "Download Google Earth Plug-in" option on the right.

more options

Oh yes. but it has not corrected the plugin . still the old one disabled. i will have another go.thank you.

more options

ribroast -- For some strange reason, to update the Google Earth Plug-in, you'll have to either RESTART your FF or your PC. In my case, I have to restart my FF before the plug-in will show the latest version. richlaughlin said he has to restart his PC.

You can try to restart your FF to see if it works, if not, then restart your PC.

more options

Thank you I see it now in my add on manager but it is still disabled so I will enable and see what happens ...if anything. Thank you.