Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have 2 questions. When I type something into the address bar all I get is mp3tubetoolbar.com. I used to get search results. Also I'm now getting a bunch of pop-ups whenever I load a new page.

  • 8 replies
  • 1 has this problem
  • 31 views
  • آخر ردّ كتبه Lary_Smith

more options

I've run Avast antivirus, Malwarebytes and Spybot and found no problems.I'm running Vista.

All Replies (8)

more options

Try to reset your keyword url settings..instruction are located at top of domain guessing section of Firefox Search the web from the address bar kb and here

more options

I've tried it but the instructions aren't completely clear to me.

more options

What is the current value of the keyword.URL pref on the about:config page?


You can modify the pref keyword.URL on the about:config page to use Google's "I'm Feeling Lucky" or Google's "Browse By Name".


more options

cor-el. Your "I'm feeling lucky" link took me to Google Doodles and the "Browse by Name " took me to the Google search page.

more options

I can get to the about:config page but have no clue what I'm trying to do once there.

more options

You need to find keyword.URL in the about:config page list of preferences. If it has been changed from the default value, you can either modify it to one of the google URLs cor-el suggested, or else reset it like this:

  1. Type about:config in the Firefox address bar and press Enter
  2. If you see a page with the warning message, This might void your warranty!, click the button labeled "I'll be careful, I promise!", to continue
  3. Type keyword in the Filter
  4. In the list of preferences, find keyword.URL (it will be in bold)
  5. Right-click on that preference and select Reset.

If you are able to reset the preference to the default but it changes back when you next reopen Firefox, or if keyword.URL is already set to the default, then something else is causing the problem. See these articles and questions for other ideas (or post back for more help):

Modified by AliceWyman

more options

P.S. Your second question was Also I'm now getting a bunch of pop-ups whenever I load a new page. See the Pop-up blocker settings, exceptions and troubleshooting article, under Pop-ups not being blocked ... If the popups are not coming from Firefox, see:

more options

Maybe you've got a redirect virus? Look, I was infected with a redirect virus called Infomash.org (this post described exactly about my symptoms: http://www.removemalwarespyware.com/hijacked-by-infomash-org-popup-remove-infomash-org-manually-step-by-step/ ) I also had antivirus and antimalware program installed on my computer but nothing helped...really hate those who made viruses!!!