Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Excel workbook saved as web-page - In IE it displays correctly (eg all non-hidden columns) - In Firefox it displays what I expect, plus the first of what should be a series of hidden columns

  • 2 replies
  • 1 has this problem
  • 638 views
  • آخر ردّ كتبه homeric

more options

I saved an Excel workboob as a web-page - In IE 8 it displays exactly as I want (that is all visible, non-hidden columns) - In Firefox 10 it displays the same, plus the first of what should be a series of hidden columns - Why would Firefox see a hidden column which IE doesn't - I'm working on XP (fully up-to-date with all patches applied)

Chosen solution

Thanks fmdeveloper as a result of you confirming that it is an FF bug I delved deeper into it and I've now found a fix as follows:- 1) Unhide Excel columns, format cells to ;;; 2) From first re-formatted col to rightmost end of all cols select & hide When saved as web page this then displays in FireFox as it does in IE NB: After re-formatting previously hidden cols it is necessary to hide all the remaining cols or there will be a display of blank cols in FF where garbled 'hidden entries' were seen previously Regards homeric

Read this answer in context 👍 0

All Replies (2)

more options

Known issue - https://bugzilla.mozilla.org/show_bug.cgi?id=319428

IE is the only browser the renders the column hidden. All other browsers display the column. Don't think that it is going to be fixed by the browsers....

more options

Chosen Solution

Thanks fmdeveloper as a result of you confirming that it is an FF bug I delved deeper into it and I've now found a fix as follows:- 1) Unhide Excel columns, format cells to ;;; 2) From first re-formatted col to rightmost end of all cols select & hide When saved as web page this then displays in FireFox as it does in IE NB: After re-formatting previously hidden cols it is necessary to hide all the remaining cols or there will be a display of blank cols in FF where garbled 'hidden entries' were seen previously Regards homeric