Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Bookmarks Toolbar bookmarks disappearing when arranged next to tabs?

  • 16 replies
  • 1 has this problem
  • 19 views
  • آخر ردّ كتبه the-edmeister

more options

When the Bookmarks Toolbar is sitting next to tabs and many tabs are opened, bookmarks that shift into the overflow menu do not return after the tabs are closed.

Resizing the window smaller and then bigger again restores these "hidden" bookmarks.

Screenshot of issue How it should look Video of issue

Sometimes the overflow doesn't work properly with bookmarks failing to appear on the dropdown list.

Edit: Updated first post to reflect findings.

Modified by ynthrepic

All Replies (16)

more options

Are you saying that as you open more Tabs your bookmarks slide off the right side of the Tab Bar and >> appears?

more options

As you can see in the screenshots the occasion where all of my bookmarks can be seen is when I have many tabs open, and conversely when I have only one tab open all are missing except 'Visited'.

They dissappear randomly; I don't know when. The toolbar behaves as if they are still there; as if they are invisible.

Edit: '>>' still appears as normal. The point is that even when there is a single tab open, the bookmarks remain 'hidden'. Usually 'Visited' tends to stay.

Modified by ynthrepic

more options

If I open a new window, all of the bookmarks will be displayed again in that new window (restarting Firefox also restores them).

more options

OK, 2nd look at it and I can see the problem you are talking about. I can't duplicate that issue, my advice is to try the Firefox SafeMode.

Try the Firefox SafeMode to see how it works there.
A troubleshooting mode, which disables most Add-ons.
(If you're not using it, switch to the Default Theme.)

  • You can open the Firefox 4.0+ SafeMode by holding the Shft key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item, click on Restart with Add-ons Disabled... while Firefox is running.

Don't select anything right now, just use "Continue in SafeMode."

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shft key) to open it again.

If it is good in the Firefox SafeMode, your problem is probably caused by an extension, and you need to figure out which one.
http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes

When you figure out what is causing that, please let us know. It might help other user's who have that problem.

more options

See also http://kb.mozillazine.org/Corrupt_localstore.rdf

Does it make any difference if the Firefox window is maximized?

Does it help if you minimize the window and restore that window not maximized?

more options

Related discussion /forums/contributors/708104

more options

Sorry guys, it really was easier than I thought to replicate. I did just have to open lots of tabs. Screen Capture Video

I worked out that if you resize the window smaller and then expand it again the missing bookmarks reappear.

Some other strnage behavior I found (FRAPS didn't record the dropdown box that appears when there isn't room for all the bookmarks on the toolbar); any items that enter into the dropdown box will be the ones that dissapear when the tabs are closed.

When experimenting, I noticed that sometimes even if you have 40 tabs open, the number of bookmarks that actually appear in the dropdown box (and subsequently vanish when the tabs are closed) is random. As in, all of the bookmarks might be hidden from view, but only Jisho, and Twitter appear when I click the down arrow. (right now I can't get this to replicate, but if I do I'll take a screenshot).

(Edit: fixed my confusing language above)

Modified by ynthrepic

more options

By the way, I do recognise this is a rather strange setup, but on my laptop with only 768px of screen height I want all the vertical realestate I can get.

I think the developers had the foresight to see this and so allowed you to put your toolbars up there. I just wish they would right-align, but you can't win em all.

more options

The Bookmarks button with the "Bookmarks" word is probably causing that quirk where some bookmarks don't reappear from the overflow as the last few open Tabs are closed. That particular button has special properties that nothing else in the UI has; like automatically moving to the Navigation Bar when the Bookmarks Toolbar is closed / hidden. Plus the "pinning" of that button to the right-side of the Bookmarks Toolbar - almost like a "flexible spacer".


See the screenshot for an alternative method that I have used for the last 7 years to get rid of the Bookmarks Toolbar and still be able to access the bookmarks I have in one folder that I created on the Bookmarks Toolbar and then moved.

  1. Add a Folder with no name to the Bookmarks Toolbar.
  2. Move your bookmarks and RSS feeds into that un-named folder.
  3. Open Customize and drag the Bookmarks Toolbar Items to the left side of the Search Bar. Close Customize and then hide the Bookmarks Toolbar.

The bookmarks in that un-named folder will be in a drop-down list from that folder.

Use { Ctrl + B } to access your bookmarks in the Sidebar. Or use { Alt > B } to open the Bookmarks menu on the Menu Bar.

Modified by the-edmeister

more options

Interesting layout, but I do like having my most used sites available with a single click. Even if I do switch methods this behavior with the messed up overflow is still something that needs to be fixed. It's just messy.

more options

Have you searched Bugzilla to see if a Bug report has been filed about that issue?
Without a Bug report there's little probability it would be fixed. That quirk is still present in Nightly 12.0a1, I just checked that development version.

BTW, I was incorrect when I said it was probably caused by the the "Bookmarks" button - I moved that button into the Customize Palette to hide it, and that issue still happened when I closed 8 tabs.

more options

This one talks about strange tab behavior rather than strange bookmark behavior. https://bugzilla.mozilla.org/show_bug.cgi?id=643274

I'll look into submitting a bug report tomorrow (need to make an account etc); bit late tonight. If you've got a system for doing it, and it's not too much trouble by all means ;)

more options

This bug looks related too. I'll add an update and a link. https://bugzilla.mozilla.org/show_bug.cgi?id=668909

Edit: Found another one that dates back to late 2010 - same issue. https://bugzilla.mozilla.org/show_bug.cgi?id=595080

Modified by ynthrepic

more options

This comment has a work-around that works for me.
https://bugzilla.mozilla.org/show_bug.cgi?id=668909#c2

more options

I actually tried that and it didn't seem to work. Just gave it another shot on my home computer and again no dice. Tried a separator and a spacer.

Are you sure the work around actually worked?

more options

It worked on one Profile that has Stylish installed, with a user style that puts tabs in the titlebar in a restored window - the problem surfaces in the SafeMode. In another Profile with no add-ons, that work-around doesn't work.

Sorry, I oughta know better than to check mods like this in anything but a blank Profile.