Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is Firefox 3.5.10 still using Java 1.5 even though I have Java 1.6 is installed

  • No replies
  • 1 has this problem
more options

I am running Mac OSX 10.5.8 with all current updates. I am running Firefox 3.5.10 with all current updates. I have Java enabled in Firefox. I have the Java Embedding Plug-in 0.9.7.2 installed and enabled. In OSX Java preferences, I've placed java 6 at the top, so it should be checked for first.

When I do the plug-in check on the mozilla site, it tells me that my java is outdated.

When I run the java version check at browser spy, it sees the version Java 1.6 is installed but the "java using object and applet tag" is still Java 1.5.

So it appears that the browser or perhaps the Java Embedded plugin is NOT using Java 1.6 even though it is installed in the system.

I had understood that Java Embedded plugin is distributed with Firefox. How can I get it to use Java 1.6 on Mac?