Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Since updating to 6.0 and then to 6.0.1, I have frequent "not responding" errors lasting as long as 30+ seconds.

more options

This occurs at random times such as clicking on a link, trying to scroll up or down, etc.

All Replies (10)

more options

This solution has worked for me: Export bookmarks into HTML, exit Firefox, Remove profile, uninstall Firefox completely, install 3.6, immediately go to Options->Advanced->Update, and disable automatic update. Reinstall favorite add ons, import bookmarks. End of the 6.x curse.

more options

I've been running pretty normal since I did a total uninstall of 6.0 leaving no traces (choose the option to remove everything during uninstall), and re-installed back to 5.0. Several days of zero hang up. Going to try putting 6 back soon.

Modified by lkendter

more options

I don't seem to hang up anymore, and it looks like I can now log into the sites I was having problems logging into before (after deleting my cache last week).

So I guess I am recommending that earlier answer, the one about deleting the cache. Good luck out there, don't lose hope!

Modified by johnpseudonym

more options

Have had this problem for the past 2-3 weeks. It's not Java. I haven't installed Java since my last reinstallation of Windows. The freeze happens on certain websites only, and happens almost every time when I tries to open those sites. I have tried to disable all add-ons/plug-ins, and enable them one by one, but the problems still exists for most of the websites.

Take the websites I visited today as examples:

wilkinsonplus.com Disabling AdBlock Plus will solve the problem on the Wilkinson site.

http://secure.baa.com/baa/baabook.asp?p=p&pr=lhr&al=lhr&src=WLHR02 Problem still exists after disabling all add-ons/plug-ins. This is the airport parking booking site from BAA. Directed from the Heathrow Airport site, but works fine if removing the parameters in the url.

memory.zol.com.cn A Chinese tech website I encountered during work. Problem still exists after disabling all add-ons/plug-ins.

It definitely has something to do with Firefox 6. I have visited the first two sites a number of times before (using previous versions of Firefox), without any problem.

more options

I was getting 5-10 second intervals of "Not Responding" every 5 to 10 seconds...was driving me nuts! Read thrugh the suggestions here and then used CCleaner to clean out my Firefox cache, and problem solved!!! THANKS 'wawaka' !

more options

Hi, everyone! Based on your reports we've been able to reproduce the symptoms that many people have been reporting in this question and others like this. The main symptom in question is that Firefox freezes for anywhere from 20 seconds to 2 minutes every 10 minutes, while utilizing the CPU at 100%.

We don't yet have a fix in our Aurora or Beta channels to test, but we do have a work-around that people can attempt to try to see if they are having the same problem that we've found.

We'd love it if people could try this out and report if it worked for them, or if it didn't. One of our developers, Marco, has posted an extension with instructions on the right options to choose:

http://blog.bonardo.net/2011/09/30/is-your-firefor-freezing-at-regular-intervals

I suffered from this periodic hang and when I ran this on my profile, my Firefox hung for a couple minutes, so please let it complete - it takes some time.

I know that there will be people who have commented on this question for which this will not solve their problems. We've found one serious hang here and are working on reproducing others as well.

Thanks!

more options

Blizzard wrote: > We don't yet have a fix in our Aurora or Beta channels to test, but we do have a work-around that people can attempt to try to see if they are having the same problem that we've found.

Ah... Who is "We", and why should anyone install your software on their computers? You make it sound like you're part of the Mozilla team?

more options

Yes, sorry, I am one of the product team members who deals with platform issues like this.

more options

I might have discovered the solution without starting over with all your places and bookmarks.

Right after i installed 7.0.1 over a week ago,every 10-30 min When i would be watching videos online, it would freeze for 20-30 seconds. Firefox would say ( Not responding) both firefox and the plugin container process would be very large memory files. I tried to go back to Firefox 5.0. No avail it would still freeze.I tried to disable the plugin container . no good. I tried to adjust memory or cache or plugin settings in “about:config”.Nothing fixed it!

I finally discovered why my Firefox 7.01 was periodic hanging fix. It is something to do with some of your personal files. download this this add on and install it https://addons.mozilla.org/en-US/firefox/addon/places-maintenance/

or you can Google "places maintenance Firefox"

After you install the add on, restart Firefox.go to "tools", then "add ons" and then click “extensions” tab ,then click' options" on the "places maintenance" entry. choose "ALL' or just "expire" and hit "execute", then wait until its done., restart Firefox. should be fine then and all my bookmarks, customizations ,settings, and history stays untouched!

After i did this my Firefox did not freeze once for over 3 days straight. Might not work for everyone. I already read that Mozilla is aware of the problem and are working on a fix it in the full version of 8( the 8 beta did not fix the problem for me) . But they said this is a good temporary fix at least,( might be permanent)

For me at least ,Firefox works fine in 7 now. perfect actually.And many people i saw on similar forums had similar problems.

Enjoy. Hope this helped

Modified by imajakov

more options

Yeah, I think this is the places problem we found. The work-around is documented here:

http://blog.bonardo.net/2011/09/30/is-your-firefor-freezing-at-regular-intervals

And we'll have a fix for it in the next Firefox update as well.

Thanks for the nice response!

  1. 1
  2. 2