ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I do NOT like Firefox 5, and I want to know please WHERE I can download the previous version? I don't want this change. NONE of my add-ons work and I need them to. Please someone just tell me where I can get version 4?

  • 13 ردًا
  • 137 have this problem
  • 10 views
  • آخر ردّ كتبه Arbez316

more options

Fast Dial and my Google bar don't work in version 5. This is patently not acceptable to me as I use them every day, all day. I have searched for hours and cannot find a download version for FF4. Please someone help, that's all I need is to get rid of this monstrosity of an update. I DO NOT LIKE IT.

Thank you.

الحل المُختار

Version 4.0.1 can be downloaded here ...

deleted - not supported any longer - missing security patches that are in 3.6.18 and 5.0

Just be sure to uninstall Firefox 5.0 first.

Read this answer in context 👍 11

All Replies (13)

more options

الحل المُختار

Version 4.0.1 can be downloaded here ...

deleted - not supported any longer - missing security patches that are in 3.6.18 and 5.0

Just be sure to uninstall Firefox 5.0 first.

Modified by the-edmeister

more options

Oh thank you thank you, a thousand times!

more options

But how do you preserve your cookies and bookmarks when you uninstall 5.0 first?

more options

Mine were still there.

more options

Firefox 4.0 and 4.0.1 are not secure and are no longer supported - USE AT YOUR OWN RISK.

  • There are already reported attacks on the internet against users of Firefox 4.0 and 4.0.1.
  • Firefox 4.0 and 4.0.1 contain security issues that have not and will not be updated according to the latest information.
  • Firefox 5.0 includes fixes for the security issues in Firefox 4.0.1
  • Firefox 4.0.1 included fixes for security issues in Firefox 4.0.

Only Firefox 5.0 and 3.6.18 are currently supported.

verbal0rchid

In addition, your outdated plugins contain security issues, so you are even more at risk.

Modified by Helper7677

more options

Can I download FF 3.6.18 and have it work on my iMAC G5 with a PC processer?

more options

Can I download FF 3.6.18 and have it work on my iMAC G5 with a PC prosessor?

more options
more options

This FF 5 is GARBAGE! Bad enough I'm on dial up. From the minute I upgraded,I have been running security programs thinking I was corrupted. Im on the XP. I hate IE8, and the FF4 worked wonderful. I uninstalled the 5 in 3 seconds, while keeping my files. It took a while, after trying to reinstall 5 again. It wouldn't go over 51% then shut down. Now I'm at 74% on the 4. I'll take my chances with the older version, even tho THAT crashed my Adobe and took my XP games with it. Im at deleted by a moderator - security concerns If that wont work, By BY Mozilla-you put a real POS in my PC.

Modified by the-edmeister

more options

Another thing that didnt work in FF5 was mt Avast! web rep. It also screwd up my typing, I would look up and sentences would be moved into a preceding paragraph. It is GARBAGE.

more options

http://www.ehow.com/how_6908996_restore-firefox-computer.html Iwent here. When I removed it from my IE8XP, it asked if I wanted to delete files, and I didn't. Hres another info http://www.ehow.com/search.html?q=Fire+Fox+5+problems&skin=corporate&t=all A whole week trying to figure out what was wrong with my PC-FF5. UGH...

more options

Reporting back...#4 is back and working wonderful!! My Avast! web rep is back on, and my book marks and tags were saved. My typing is also back to normal. I had to reload my Add ons tho. MOZILLA_GET RID OF THIS #5 GARBAGE, and support the #4. This is an abomination, and is making people pull their hair out till they figure out it's YOUR new update.

more options

FF4.0 does the same exact thing FF 5.0 does. Web pages load up flashing as black screens. Perhaps I will just go back to utilizing the dreaded IE browser or even Safari. FF is going down hill with these updates it seems